FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-28-2010, 01:39 PM
Graham Murray
 
Default perl 5.12 downgrade ??

Joseph <syscon780@gmail.com> writes:

> The reason I'm asking is that I'm getting some strange errors when using 'sql-ledger' eg.
> Using a hash as a reference is deprecated at SL/IS.pm line 582.

The 'XXX is depreciated" messages are not normally errors. They are just
to inform you that the script is using a depreciated feature and that
unless it is changed (to use a non depreciated mechanism) that it will
stop working in a future version. This is aimed primarily at the scripts
author/maintainer. For a user it should prompt one of three actions, in
order of preference, a) Upgrade to a later version of the script, b)
check if this has already been reported as a bug (either upstream or in
Gentoo) and if not raise a bug report, c) Ignore it.
 
Old 10-28-2010, 02:05 PM
Mick
 
Default perl 5.12 downgrade ??

On 28 October 2010 13:58, Joseph <syscon780@gmail.com> wrote:
> After upgrading to Perl 5.12 and all cleanup "perl-cleaner --all"
> When I run "emerge --depclean" it asked me to removed the following packages
> listed below.
> However, when I check all of them are needed by some other packages. Do I
> need them? (I retained them all)
>
> virtual/perl-Package-Constants
> virtual/perl-Compress-Raw-Zlib
> virtual/perl-Compress-Raw-Bzip2
> dev-java/antlr perl-core/MIME-Base64
> perl-core/Test-Simple
> perl-core/Archive-Tar
> perl-core/Test-Harness
> perl-core/IO-Compress
> perl-core/IO-Zlib
> perl-core/Digest-MD5
> perl-core/CGI
> perl-core/Digest-SHA perl-core/Compress-Raw-Bzip2 perl-core/Sys-Syslog
> perl-core/digest-base perl-core/Compress-Raw-Zlib
> perl-core/version
> perl-core/DB_File
> perl-core/Package-Constants
> dev-java/gjdoc
> perl-core/libnet
>
> The reason I'm asking is that I'm getting some strange errors when using
> 'sql-ledger' eg.
> Using a hash as a reference is deprecated at SL/IS.pm line 582.
>
> I think it might be related to recent perl upgrade.
> Is it possible / safe to downgrade to previous "perl-5.8.8-r8" ?
> or do I just delete the above perl module.

I am getting the same here. I retained everything until things settle
a bit and newer versions get unmasked.

--
Regards,
Mick
 
Old 10-28-2010, 02:58 PM
Joseph
 
Default perl 5.12 downgrade ??

On 10/28/10 15:05, Mick wrote:

On 28 October 2010 13:58, Joseph <syscon780@gmail.com> wrote:

After upgrading to Perl 5.12 and all cleanup "perl-cleaner --all"
When I run "emerge --depclean" it asked me to removed the following packages
listed below.
However, when I check all of them are needed by some other packages. Do I
need them? (I retained them all)

virtual/perl-Package-Constants
virtual/perl-Compress-Raw-Zlib
virtual/perl-Compress-Raw-Bzip2
dev-java/antlr perl-core/MIME-Base64
perl-core/Test-Simple
perl-core/Archive-Tar
perl-core/Test-Harness
perl-core/IO-Compress
perl-core/IO-Zlib
perl-core/Digest-MD5
perl-core/CGI
perl-core/Digest-SHA perl-core/Compress-Raw-Bzip2 perl-core/Sys-Syslog
perl-core/digest-base perl-core/Compress-Raw-Zlib
perl-core/version
perl-core/DB_File
perl-core/Package-Constants
dev-java/gjdoc
perl-core/libnet

The reason I'm asking is that I'm getting some strange errors when using
'sql-ledger' eg.
Using a hash as a reference is deprecated at SL/IS.pm line 582.

I think it might be related to recent perl upgrade.
Is it possible / safe to downgrade to previous "perl-5.8.8-r8" ?
or do I just delete the above perl module.


I am getting the same here. I retained everything until things settle
a bit and newer versions get unmasked.

--
Regards,
Mick


I've posted this message on Gentoo forum and user "krinn" suggested to file a bug as "depclean" not suppose to remove package that depend on
packages that are still in use.


--
Joseph
 
Old 10-28-2010, 04:22 PM
"Arttu V."
 
Default perl 5.12 downgrade ??

On 10/28/10, Joseph <syscon780@gmail.com> wrote:
> I've posted this message on Gentoo forum and user "krinn" suggested to file
> a bug as "depclean" not suppose to remove package that depend on
> packages that are still in use.

I'd imagine most items on your list are simply build-time
dependencies, and they're not needed at all during runtime. Perhaps
you can separate the chaff by using "--with-bdeps n"?

--
Arttu V. -- Running Gentoo is like running with scissors
 
Old 10-28-2010, 04:48 PM
Joseph
 
Default perl 5.12 downgrade ??

On 10/28/10 15:05, Mick wrote:

On 28 October 2010 13:58, Joseph <syscon780@gmail.com> wrote:

After upgrading to Perl 5.12 and all cleanup "perl-cleaner --all"
When I run "emerge --depclean" it asked me to removed the following packages
listed below.
However, when I check all of them are needed by some other packages. Do I
need them? (I retained them all)

virtual/perl-Package-Constants
virtual/perl-Compress-Raw-Zlib
virtual/perl-Compress-Raw-Bzip2
dev-java/antlr perl-core/MIME-Base64
perl-core/Test-Simple
perl-core/Archive-Tar
perl-core/Test-Harness
perl-core/IO-Compress
perl-core/IO-Zlib
perl-core/Digest-MD5
perl-core/CGI
perl-core/Digest-SHA perl-core/Compress-Raw-Bzip2 perl-core/Sys-Syslog
perl-core/digest-base perl-core/Compress-Raw-Zlib
perl-core/version
perl-core/DB_File
perl-core/Package-Constants
dev-java/gjdoc
perl-core/libnet

The reason I'm asking is that I'm getting some strange errors when using
'sql-ledger' eg.
Using a hash as a reference is deprecated at SL/IS.pm line 582.

I think it might be related to recent perl upgrade.
Is it possible / safe to downgrade to previous "perl-5.8.8-r8" ?
or do I just delete the above perl module.


I am getting the same here. I retained everything until things settle
a bit and newer versions get unmasked.

--
Regards,
Mick


I think all these packages can be remove now,
https://bugs.gentoo.org/show_bug.cgi?id=343093


--
Joseph
 
Old 10-28-2010, 07:44 PM
Joseph
 
Default perl 5.12 downgrade ??

On 10/28/10 06:58, Joseph wrote:

After upgrading to Perl 5.12 and all cleanup "perl-cleaner --all"
When I run "emerge --depclean" it asked me to removed the following packages listed below.
However, when I check all of them are needed by some other packages. Do I need them? (I retained them all)

virtual/perl-Package-Constants
virtual/perl-Compress-Raw-Zlib
virtual/perl-Compress-Raw-Bzip2
dev-java/antlr
perl-core/MIME-Base64
perl-core/Test-Simple
perl-core/Archive-Tar
perl-core/Test-Harness
perl-core/IO-Compress
perl-core/IO-Zlib
perl-core/Digest-MD5
perl-core/CGI
perl-core/Digest-SHA
perl-core/Compress-Raw-Bzip2
perl-core/Sys-Syslog
perl-core/digest-base
perl-core/Compress-Raw-Zlib
perl-core/version
perl-core/DB_File
perl-core/Package-Constants
dev-java/gjdoc
perl-core/libnet

The reason I'm asking is that I'm getting some strange errors when using 'sql-ledger' eg.
Using a hash as a reference is deprecated at SL/IS.pm line 582.

I think it might be related to recent perl upgrade.
Is it possible / safe to downgrade to previous "perl-5.8.8-r8" ?
or do I just delete the above perl module.

--
Joseph


I'm trying to downgrade perl on one of my machine to 5.8 and got stuck with a block:
[blocks B ] <sys-devel/libperl-5.10.1 ("<sys-devel/libperl-5.10.1" is blocking dev-lang/perl-5.12.2-r1)

I've tried to mask:

=dev-lang/perl-5.12.2-r1
=sys-devel/libperl-5.10.1


but it doesn't help so I run:
emerge -1 --nodeps =libperl-5.8.8* && emerge --nodeps =perl-5.8.8*

this compiled OK but running "perl-cleaner --all"
it tries to recomile imagemagic and it fails:
emerge -vD1 net-print/foomatic-db-engine:0 dev-db/postgresql-server:8.4 app-office/gnumeric:0 x11-terms/rxvt-unicode:0

libtool: install: warning: remember to run `libtool --finish /usr/lib/ImageMagick-6.6.2/modules-Q16/coders'
make[2]: Leaving directory `/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/work/ImageMagick-6.6.2-5'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/work/ImageMagick-6.6.2-5'
make: *** [install] Error 2
* ERROR: media-gfx/imagemagick-6.6.2.5 failed:
* (no error message)
*
* Call stack:
* ebuild.sh, line 54: Called src_install
* environment, line 2661: Called die
* The specific snippet of code:
* emake DESTDIR="${D}" install || die;
*
* If you need support, post the output of 'emerge --info =media-gfx/imagemagick-6.6.2.5',
* the complete build log and the output of 'emerge -pqv =media-gfx/imagemagick-6.6.2.5'.
* The complete build log is located at '/var/log/portage/media-gfx:imagemagick-6.6.2.5:20101028-182120.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/temp/environment'.
* S: '/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/work/ImageMagick-6.6.2-5'

Any help will be appreciated what to do with it.


--
Joseph
 
Old 10-28-2010, 08:17 PM
Alan McKinnon
 
Default perl 5.12 downgrade ??

Apparently, though unproven, at 21:44 on Thursday 28 October 2010, Joseph did
opine thusly:

> On 10/28/10 06:58, Joseph wrote:
> >After upgrading to Perl 5.12 and all cleanup "perl-cleaner --all"
> >When I run "emerge --depclean" it asked me to removed the following
> >packages listed below. However, when I check all of them are needed by
> >some other packages. Do I need them? (I retained them all)
> >
> >virtual/perl-Package-Constants
> >virtual/perl-Compress-Raw-Zlib
> >virtual/perl-Compress-Raw-Bzip2
> >dev-java/antlr
> >perl-core/MIME-Base64
> >perl-core/Test-Simple
> >perl-core/Archive-Tar
> >perl-core/Test-Harness
> >perl-core/IO-Compress
> >perl-core/IO-Zlib
> >perl-core/Digest-MD5
> >perl-core/CGI
> >perl-core/Digest-SHA
> >perl-core/Compress-Raw-Bzip2
> >perl-core/Sys-Syslog
> >perl-core/digest-base
> >perl-core/Compress-Raw-Zlib
> >perl-core/version
> >perl-core/DB_File
> >perl-core/Package-Constants
> >dev-java/gjdoc
> >perl-core/libnet
> >
> >The reason I'm asking is that I'm getting some strange errors when using
> >'sql-ledger' eg. Using a hash as a reference is deprecated at SL/IS.pm
> >line 582.
> >
> >I think it might be related to recent perl upgrade.
> >Is it possible / safe to downgrade to previous "perl-5.8.8-r8" ?
> >or do I just delete the above perl module.
> >
> >--
> >Joseph
>
> I'm trying to downgrade perl on one of my machine to 5.8 and got stuck with
> a block: [blocks B ] <sys-devel/libperl-5.10.1
> ("<sys-devel/libperl-5.10.1" is blocking dev-lang/perl-5.12.2-r1)

No that won't work. Read the output and understand what it is telling you:

Something with a version smaller than libperl-5.10.1 will be downgraded but
that will conflict with perl-5.12.2-r1 which *will still be installed at the
time libperl is downgraded*.

This only makes sense as you can only merge one thing at a time and they block
each other. Either way it is done, you will get a block like this.

The solution is to remove the packages and remerge them correctly (which
nicely sidesteps the entire problem). Or you could use portage-2.2 which has
support for much the same thing. Obviously you don't have that portage though.

As perl is not required to run emerge, you can safely do this:

emerge -C libperl perl
emerge <stuff you do want>




>
> I've tried to mask:
> >=dev-lang/perl-5.12.2-r1
> >=sys-devel/libperl-5.10.1
>
> but it doesn't help so I run:
> emerge -1 --nodeps =libperl-5.8.8* && emerge --nodeps =perl-5.8.8*
>
> this compiled OK but running "perl-cleaner --all"
> it tries to recomile imagemagic and it fails:
> emerge -vD1 net-print/foomatic-db-engine:0 dev-db/postgresql-server:8.4
> app-office/gnumeric:0 x11-terms/rxvt-unicode:0
>
> libtool: install: warning: remember to run `libtool --finish
> /usr/lib/ImageMagick-6.6.2/modules-Q16/coders' make[2]: Leaving directory
> `/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/work/ImageMagick-6.6.2-5'
> make[1]: *** [install-am] Error 2
> make[1]: Leaving directory
> `/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/work/ImageMagick-6.6.2-5'
> make: *** [install] Error 2
> * ERROR: media-gfx/imagemagick-6.6.2.5 failed:
> * (no error message)
> *
> * Call stack:
> * ebuild.sh, line 54: Called src_install
> * environment, line 2661: Called die
> * The specific snippet of code:
> * emake DESTDIR="${D}" install || die;
> *
> * If you need support, post the output of 'emerge --info
> =media-gfx/imagemagick-6.6.2.5', * the complete build log and the output
> of 'emerge -pqv =media-gfx/imagemagick-6.6.2.5'. * The complete build log
> is located at
> '/var/log/portage/media-gfx:imagemagick-6.6.2.5:20101028-182120.log'. *
> The ebuild environment file is located at
> '/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/temp/environment'. * S:
> '/var/tmp/portage/media-gfx/imagemagick-6.6.2.5/work/ImageMagick-6.6.2-5'
>
> Any help will be appreciated what to do with it.

--
alan dot mckinnon at gmail dot com
 
Old 10-30-2010, 07:39 PM
Tanstaafl
 
Default perl 5.12 downgrade ??

On 2010-10-28 9:39 AM, Graham Murray wrote:
> The 'XXX is depreciated" messages are not normally errors. They are just
> to inform you that the script is using a depreciated feature and that
> unless it is changed (to use a non depreciated mechanism) that it will
> stop working in a future version.

<peeve-mode>
It is 'deprecated', not 'depreciated'. Depreciated means something
totally different from deprecated.
</peeve-mode>
 

Thread Tools




All times are GMT. The time now is 01:52 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org