FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-14-2010, 01:15 PM
Vincent Launchbury
 
Default Printer not working after world update

Hi list,

I've been using my printer problem free for years, but a recent world
update seems to have broken something. Now whenever I print I get:

(/usr/libexec/cups/filter/foomatic-rip) stopped with status 1!
[Job 129] Job stopped due to filter errors.

and the job eventually vanishes from the queue. I've tried reinstalling
(and later downgrading) foomatic-filters, ghostscript-gpl, and cups.
I've also tried deleting and re-adding the printer, restarting cups,
restarting the printer.. etc, and nothing seems to be helping.

The foomatic-rip script says the return code 1 means "printer error
occured", but my printer's error light isn't flashing.

Also, revdep-rebuild shows nothing, and I do read ewarns. Hopefully I
haven't missed something obvious. Any ideas?

Thanks,
Vincent.

Current versions:
foomatic-filters-3.0.20080507
ghostscript-gpl-8.71-r1
cups-1.3.11-r2
Printer:
PagePro 1350W (simple ps-compat, using ppd from openprinting.org)
 
Old 10-14-2010, 05:45 PM
Mick
 
Default Printer not working after world update

On Thursday 14 October 2010 14:15:12 Vincent Launchbury wrote:
> Hi list,
>
> I've been using my printer problem free for years, but a recent world
> update seems to have broken something. Now whenever I print I get:
>
> (/usr/libexec/cups/filter/foomatic-rip) stopped with status 1!
> [Job 129] Job stopped due to filter errors.
>
> and the job eventually vanishes from the queue. I've tried reinstalling
> (and later downgrading) foomatic-filters, ghostscript-gpl, and cups.
> I've also tried deleting and re-adding the printer, restarting cups,
> restarting the printer.. etc, and nothing seems to be helping.
>
> The foomatic-rip script says the return code 1 means "printer error
> occured", but my printer's error light isn't flashing.
>
> Also, revdep-rebuild shows nothing, and I do read ewarns. Hopefully I
> haven't missed something obvious. Any ideas?
>
> Thanks,
> Vincent.
>
> Current versions:
> foomatic-filters-3.0.20080507
> ghostscript-gpl-8.71-r1
> cups-1.3.11-r2
> Printer:
> PagePro 1350W (simple ps-compat, using ppd from openprinting.org)

Have you tried unmasking and using cups-1.4.4-r2 ?

I came up to some problems as described in a previous thread and some nice
people in this list suggested to use a later version, which fixed some (but
not all) of my problems.

Regards,
Mick
 
Old 10-15-2010, 04:15 AM
Vincent Launchbury
 
Default Printer not working after world update

On 10/14/10 13:45, Mick wrote:
> Have you tried unmasking and using cups-1.4.4-r2 ?

Thanks! It didn't fix things, but it did lead me to the solution.
Apparently cups 1.4 has much more verbose logging, which pointed me to
an issue with the min12xxw driver. Cups 1.4 doesn't seem to detect USB
printers though, but fixing the driver issue and downgrading back to 1.3
got me printing again .

> I came up to some problems as described in a previous thread and some nice
> people in this list suggested to use a later version, which fixed some (but
> not all) of my problems.

I guess each version has it's pros and cons. Thanks for the pointer.

Regards,
Vincent.
 
Old 10-15-2010, 07:33 AM
Mick
 
Default Printer not working after world update

On Friday 15 October 2010 05:15:03 Vincent Launchbury wrote:
> On 10/14/10 13:45, Mick wrote:
> > Have you tried unmasking and using cups-1.4.4-r2 ?
>
> Thanks! It didn't fix things, but it did lead me to the solution.
> Apparently cups 1.4 has much more verbose logging, which pointed me to
> an issue with the min12xxw driver. Cups 1.4 doesn't seem to detect USB
> printers though, but fixing the driver issue and downgrading back to 1.3
> got me printing again .
>
> > I came up to some problems as described in a previous thread and some
> > nice people in this list suggested to use a later version, which fixed
> > some (but not all) of my problems.
>
> I guess each version has it's pros and cons. Thanks for the pointer.

You're welcome. Have a look at the 1.4.4-r2 USE flags. There's a usb flag
there which allows cups to access raw usb devices directly - you may not need
another driver for your printer.

Regards,
Mick
 
Old 10-15-2010, 08:03 AM
Peter Humphrey
 
Default Printer not working after world update

On Friday 15 October 2010 05:15:03 Vincent Launchbury wrote:

> Cups 1.4 doesn't seem to detect USB printers though, but fixing the
> driver issue and downgrading back to 1.3 got me printing again .

It detects some but not others. I raised bug 337266 about this.


--
Rgds
Peter. Linux Counter 5290, 1994-04-23.
 

Thread Tools




All times are GMT. The time now is 07:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org