FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-11-2010, 04:38 PM
James
 
Default anyone use 389ds?

Has anyone here successfully installed 389 Directory Server from the
ebuilds in the portage tree?

http://bugs.gentoo.org/104554

While trying to install I run into an issue like this:

-->8--

[ebuild N ] app-admin/389-console-1.1.6 111 kB
[ebuild N ] www-apps/389-dsgw-1.1.5 USE="adminserver -debug" 731 kB
[blocks B ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"
is blocking sys-devel/libtool-2.2.10)

Total: 48 packages (43 new, 4 in new slots, 1 reinstall), Size of
downloads: 101,668 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-devel/libtool-2.2.10, installed) pulled in by
>=sys-devel/libtool-2.2.6b required by (dev-libs/apr-1.4.2, ebuild
scheduled for merge)
>=sys-devel/libtool-2.2.6b required by
(net-nds/389-admin-1.1.11_rc1, ebuild scheduled for merge)
>=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,
ebuild scheduled for merge)
(and 7 more)

(sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by
sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,
ebuild scheduled for merge)
>=sys-devel/libtool-2.2.6b required by
(net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)

--8<--

I'm uncertain which of these packages are actually necessary and if
any of the 389ds packages conflict with each other. But it seems that
some of the 389ds packages want a certain version of libtool, while
other packages want a different version.

Any thoughts / ideas would be helpful.

-james
 
Old 10-12-2010, 08:33 AM
李健
 
Default anyone use 389ds?

Do you have libtool-2*:1.5 installed? ( emerge -pv sys-devel/ibtool )If so, try unmerging it. ( emerge -av --unmerge sys-devel/libtool-2*:1.5 )
I am not sure.Just have a try. ( newbie )

HTH --lijian

2010/10/12 James <jtp@nc.rr.com>

Has anyone here successfully installed 389 Directory Server from the

ebuilds in the portage tree?



http://bugs.gentoo.org/104554



While trying to install I run into an issue like this:



-->8--



[ebuild *N * *] app-admin/389-console-1.1.6 *111 kB

[ebuild *N * *] www-apps/389-dsgw-1.1.5 *USE="adminserver -debug" 731 kB

[blocks B * * ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"

is blocking sys-devel/libtool-2.2.10)



Total: 48 packages (43 new, 4 in new slots, 1 reinstall), Size of

downloads: 101,668 kB

Conflict: 1 block (1 unsatisfied)



** Error: The above package list contains packages which cannot be

** installed at the same time on the same system.



*(sys-devel/libtool-2.2.10, installed) pulled in by

* *>=sys-devel/libtool-2.2.6b required by (dev-libs/apr-1.4.2, ebuild

scheduled for merge)

* *>=sys-devel/libtool-2.2.6b required by

(net-nds/389-admin-1.1.11_rc1, ebuild scheduled for merge)

* *>=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,

ebuild scheduled for merge)

* *(and 7 more)



*(sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by

* *sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,

ebuild scheduled for merge)

* *>=sys-devel/libtool-2.2.6b required by

(net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)



--8<--



I'm uncertain which of these packages are actually necessary and if

any of the 389ds packages conflict with each other. But it seems that

some of the 389ds packages want a certain version of libtool, while

other packages want a different version.



Any thoughts / ideas would be helpful.



-james
 
Old 10-12-2010, 07:36 PM
James
 
Default anyone use 389ds?

Hi,

Yep -- I have it installed.

[i] sys-devel/libtool (2.2.10(2)@09/26/2010): A shared library tool
for developers

I've tried unmasking ~amd64 to no avail. I believe the issue is that
one of the 389ds packages wants an older version of libtool, while
another package in the list of 389ds wants a newer version.

I guess there really isn't much of a "howto" regarding how to use
389ds on Gentoo -- are all of these packages required? If not, which
ones should I depend on? Several of these packages are named "console"
-- one is Java, another one "ds" console (whatever that is).

~ % eix -c 389
[N] app-admin/389-admin-console (~1.1.4(1.1)): 389 Server Management
Console (jar and help files)
[N] app-admin/389-console (~1.1.6(1.1)): A Java based console for
remote management 389 server
[N] app-admin/389-ds-console (~1.2.3-r1(1.2)): Java based remote
management console used for Managing 389-admin 389-ds
[N] dev-libs/389-adminutil (~1.1.10): 389 adminutil
[N] net-nds/389-admin (~1.1.11_rc1): 389 Directory Server (admin)
[N] net-nds/389-ds-base (~1.2.6-r1): 389 Directory Server (core
librares and daemons )
[N] www-apps/389-dsgw (~1.1.5): 389 Directory Server Gateway Web Application
Found 7 matches.

Thoughts?

-james

On Tue, Oct 12, 2010 at 4:33 AM, 李健 <kdlijian@gmail.com> wrote:
> Do you have libtool-2*:1.5 installed? ( emerge -pv sys-devel/ibtool )
> If so, try unmerging it. ( emerge -av --unmerge sys-devel/libtool-2*:1.5 )
> I am not sure.Just have a try. ( newbie )
> HTH --lijian
>
> 2010/10/12 James <jtp@nc.rr.com>
>>
>> Has anyone here successfully installed 389 Directory Server from the
>> ebuilds in the portage tree?
>>
>> http://bugs.gentoo.org/104554
>>
>> While trying to install I run into an issue like this:
>>
>> -->8--
>>
>> [ebuild *N * *] app-admin/389-console-1.1.6 *111 kB
>> [ebuild *N * *] www-apps/389-dsgw-1.1.5 *USE="adminserver -debug" 731 kB
>> [blocks B * * ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"
>> is blocking sys-devel/libtool-2.2.10)
>>
>> Total: 48 packages (43 new, 4 in new slots, 1 reinstall), Size of
>> downloads: 101,668 kB
>> Conflict: 1 block (1 unsatisfied)
>>
>> ** Error: The above package list contains packages which cannot be
>> ** installed at the same time on the same system.
>>
>> *(sys-devel/libtool-2.2.10, installed) pulled in by
>> * *>=sys-devel/libtool-2.2.6b required by (dev-libs/apr-1.4.2, ebuild
>> scheduled for merge)
>> * *>=sys-devel/libtool-2.2.6b required by
>> (net-nds/389-admin-1.1.11_rc1, ebuild scheduled for merge)
>> * *>=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,
>> ebuild scheduled for merge)
>> * *(and 7 more)
>>
>> *(sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by
>> * *sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,
>> ebuild scheduled for merge)
>> * *>=sys-devel/libtool-2.2.6b required by
>> (net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)
>>
>> --8<--
>>
>> I'm uncertain which of these packages are actually necessary and if
>> any of the 389ds packages conflict with each other. But it seems that
>> some of the 389ds packages want a certain version of libtool, while
>> other packages want a different version.
>>
>> Any thoughts / ideas would be helpful.
>>
>> -james
>>
>
>
 
Old 10-13-2010, 07:17 AM
李健
 
Default anyone use 389ds?

I don't know.
Last time when "emerge --update --deep --newuse world" I suffered some "Blocks", I don't know how to solve that properly.
Then I unmerged all the releated packages(include dependencies) and remerged the packages I need. It works.


I mean maybe you can just make this, without knowing everything clearly right now. Of course, if you are not in a PRODUCTION environment.*

2010/10/13 James <jtp@nc.rr.com>

Hi,



Yep -- I have it installed.



[i] sys-devel/libtool (2.2.10(2)@09/26/2010): A shared library tool

for developers



I've tried unmasking ~amd64 to no avail. I believe the issue is that

one of the 389ds packages wants an older version of libtool, while

another package in the list of 389ds wants a newer version.



I guess there really isn't much of a "howto" regarding how to use

389ds on Gentoo -- are all of these packages required? If not, which

ones should I depend on? Several of these packages are named "console"

-- one is Java, another one "ds" console (whatever that is).



~ % eix -c 389

[N] app-admin/389-admin-console (~1.1.4(1.1)): 389 Server Management

Console (jar and help files)

[N] app-admin/389-console (~1.1.6(1.1)): A Java based console for

remote management 389 server

[N] app-admin/389-ds-console (~1.2.3-r1(1.2)): Java based remote

management console used for Managing 389-admin 389-ds

[N] dev-libs/389-adminutil (~1.1.10): 389 adminutil

[N] net-nds/389-admin (~1.1.11_rc1): 389 Directory Server (admin)

[N] net-nds/389-ds-base (~1.2.6-r1): 389 Directory Server (core

librares and daemons )

[N] www-apps/389-dsgw (~1.1.5): 389 Directory Server Gateway Web Application

Found 7 matches.



Thoughts?



-james



On Tue, Oct 12, 2010 at 4:33 AM, 李健 <kdlijian@gmail.com> wrote:

> Do you have libtool-2*:1.5 installed? ( emerge -pv sys-devel/ibtool )

> If so, try unmerging it. ( emerge -av --unmerge sys-devel/libtool-2*:1.5 )

> I am not sure.Just have a try. ( newbie )

> HTH --lijian

>

> 2010/10/12 James <jtp@nc.rr.com>

>>

>> Has anyone here successfully installed 389 Directory Server from the

>> ebuilds in the portage tree?

>>

>> http://bugs.gentoo.org/104554

>>

>> While trying to install I run into an issue like this:

>>

>> -->8--

>>

>> [ebuild *N * *] app-admin/389-console-1.1.6 *111 kB

>> [ebuild *N * *] www-apps/389-dsgw-1.1.5 *USE="adminserver -debug" 731 kB

>> [blocks B * * ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"

>> is blocking sys-devel/libtool-2.2.10)

>>

>> Total: 48 packages (43 new, 4 in new slots, 1 reinstall), Size of

>> downloads: 101,668 kB

>> Conflict: 1 block (1 unsatisfied)

>>

>> ** Error: The above package list contains packages which cannot be

>> ** installed at the same time on the same system.

>>

>> *(sys-devel/libtool-2.2.10, installed) pulled in by

>> * *>=sys-devel/libtool-2.2.6b required by (dev-libs/apr-1.4.2, ebuild

>> scheduled for merge)

>> * *>=sys-devel/libtool-2.2.6b required by

>> (net-nds/389-admin-1.1.11_rc1, ebuild scheduled for merge)

>> * *>=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,

>> ebuild scheduled for merge)

>> * *(and 7 more)

>>

>> *(sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by

>> * *sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,

>> ebuild scheduled for merge)

>> * *>=sys-devel/libtool-2.2.6b required by

>> (net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)

>>

>> --8<--

>>

>> I'm uncertain which of these packages are actually necessary and if

>> any of the 389ds packages conflict with each other. But it seems that

>> some of the 389ds packages want a certain version of libtool, while

>> other packages want a different version.

>>

>> Any thoughts / ideas would be helpful.

>>

>> -james

>>

>

>
 
Old 10-13-2010, 03:37 PM
James
 
Default anyone use 389ds?

I'm pretty sure this is a bug. I've tried to emerge these packages on
a fresh / new system and the 389-ds-base package has a dependency
conflict.

-->8--

[ebuild N ] net-nds/389-ds-base-1.2.6-r1 USE="bitwise dna
kerberos ldapi pam-passthru presence -auto-dn-suffix -autobind -debug
-doc (-selinux)" 2,803 kB
[blocks B ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"
is blocking sys-devel/libtool-2.2.10)

Total: 14 packages (10 new, 3 in new slots, 1 reinstall), Size of
downloads: 27,734 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-devel/libtool-2.2.10, installed) pulled in by
>=sys-devel/libtool-2.2.6b required by (dev-libs/svrcore-4.0.4,
ebuild scheduled for merge)
>=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,
ebuild scheduled for merge)

(sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by
sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,
ebuild scheduled for merge)
>=sys-devel/libtool-2.2.6b required by
(net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)

--8<--

I can't see a way to get around this blocked package issue as the
dependencies require different versions of the package than the actual
package I'm trying to emerge.

-j


2010/10/13 李健 <kdlijian@gmail.com>:
> I don't know.
> Last time when "emerge --update --deep --newuse world" I suffered some
> "Blocks", I don't know how to solve that properly.
> Then I unmerged all the releated packages(include dependencies) and remerged
> the packages I need. It works.
>
> I mean maybe you can just make this, without knowing everything clearly
> right now. Of course, if you are not in a PRODUCTION environment.
>
> 2010/10/13 James <jtp@nc.rr.com>
>>
>> Hi,
>>
>> Yep -- I have it installed.
>>
>> [i] sys-devel/libtool (2.2.10(2)@09/26/2010): A shared library tool
>> for developers
>>
>> I've tried unmasking ~amd64 to no avail. I believe the issue is that
>> one of the 389ds packages wants an older version of libtool, while
>> another package in the list of 389ds wants a newer version.
>>
>> I guess there really isn't much of a "howto" regarding how to use
>> 389ds on Gentoo -- are all of these packages required? If not, which
>> ones should I depend on? Several of these packages are named "console"
>> -- one is Java, another one "ds" console (whatever that is).
>>
>> ~ % eix -c 389
>> [N] app-admin/389-admin-console (~1.1.4(1.1)): 389 Server Management
>> Console (jar and help files)
>> [N] app-admin/389-console (~1.1.6(1.1)): A Java based console for
>> remote management 389 server
>> [N] app-admin/389-ds-console (~1.2.3-r1(1.2)): Java based remote
>> management console used for Managing 389-admin 389-ds
>> [N] dev-libs/389-adminutil (~1.1.10): 389 adminutil
>> [N] net-nds/389-admin (~1.1.11_rc1): 389 Directory Server (admin)
>> [N] net-nds/389-ds-base (~1.2.6-r1): 389 Directory Server (core
>> librares and daemons )
>> [N] www-apps/389-dsgw (~1.1.5): 389 Directory Server Gateway Web
>> Application
>> Found 7 matches.
>>
>> Thoughts?
>>
>> -james
>>
>> On Tue, Oct 12, 2010 at 4:33 AM, 李健 <kdlijian@gmail.com> wrote:
>> > Do you have libtool-2*:1.5 installed? ( emerge -pv sys-devel/ibtool )
>> > If so, try unmerging it. ( emerge -av --unmerge sys-devel/libtool-2*:1.5
>> > )
>> > I am not sure.Just have a try. ( newbie )
>> > HTH --lijian
>> >
>> > 2010/10/12 James <jtp@nc.rr.com>
>> >>
>> >> Has anyone here successfully installed 389 Directory Server from the
>> >> ebuilds in the portage tree?
>> >>
>> >> http://bugs.gentoo.org/104554
>> >>
>> >> While trying to install I run into an issue like this:
>> >>
>> >> -->8--
>> >>
>> >> [ebuild N ] app-admin/389-console-1.1.6 111 kB
>> >> [ebuild N ] www-apps/389-dsgw-1.1.5 USE="adminserver -debug" 731
>> >> kB
>> >> [blocks B ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"
>> >> is blocking sys-devel/libtool-2.2.10)
>> >>
>> >> Total: 48 packages (43 new, 4 in new slots, 1 reinstall), Size of
>> >> downloads: 101,668 kB
>> >> Conflict: 1 block (1 unsatisfied)
>> >>
>> >> * Error: The above package list contains packages which cannot be
>> >> * installed at the same time on the same system.
>> >>
>> >> (sys-devel/libtool-2.2.10, installed) pulled in by
>> >> >=sys-devel/libtool-2.2.6b required by (dev-libs/apr-1.4.2, ebuild
>> >> scheduled for merge)
>> >> >=sys-devel/libtool-2.2.6b required by
>> >> (net-nds/389-admin-1.1.11_rc1, ebuild scheduled for merge)
>> >> >=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,
>> >> ebuild scheduled for merge)
>> >> (and 7 more)
>> >>
>> >> (sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by
>> >> sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,
>> >> ebuild scheduled for merge)
>> >> >=sys-devel/libtool-2.2.6b required by
>> >> (net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)
>> >>
>> >> --8<--
>> >>
>> >> I'm uncertain which of these packages are actually necessary and if
>> >> any of the 389ds packages conflict with each other. But it seems that
>> >> some of the 389ds packages want a certain version of libtool, while
>> >> other packages want a different version.
>> >>
>> >> Any thoughts / ideas would be helpful.
>> >>
>> >> -james
>> >>
>> >
>> >
>>
>
>
 
Old 10-13-2010, 04:08 PM
Alan McKinnon
 
Default anyone use 389ds?

Apparently, though unproven, at 17:37 on Wednesday 13 October 2010, James did
opine thusly:

> I'm pretty sure this is a bug. I've tried to emerge these packages on
> a fresh / new system and the 389-ds-base package has a dependency
> conflict.
>
> -->8--
>
> [ebuild N ] net-nds/389-ds-base-1.2.6-r1 USE="bitwise dna
> kerberos ldapi pam-passthru presence -auto-dn-suffix -autobind -debug
> -doc (-selinux)" 2,803 kB
> [blocks B ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"
> is blocking sys-devel/libtool-2.2.10)
>
> Total: 14 packages (10 new, 3 in new slots, 1 reinstall), Size of
> downloads: 27,734 kB
> Conflict: 1 block (1 unsatisfied)
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> (sys-devel/libtool-2.2.10, installed) pulled in by
> >=sys-devel/libtool-2.2.6b required by (dev-libs/svrcore-4.0.4,
> ebuild scheduled for merge)
> >=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,
> ebuild scheduled for merge)
>
> (sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by
> sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,
> ebuild scheduled for merge)
> >=sys-devel/libtool-2.2.6b required by
> (net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)
>
> --8<--
>
> I can't see a way to get around this blocked package issue as the
> dependencies require different versions of the package than the actual
> package I'm trying to emerge.

# eix -e libtool
[i] sys-devel/libtool
Available versions:
(1.3) 1.3.5
(1.5) **1.5.26 (~)1.5.26-r1 2.2.6b **9999
(2) (~)2.2.8-r1 2.2.10{tbz2} **2.4
{test vanilla}
Installed versions: 2.2.10(2){tbz2}(12:30:40 10/06/10)(-vanilla)
Homepage: http://www.gnu.org/software/libtool/
Description: A shared library tool for developers


Do you have libtool:1.5 installed? Any effect?


--
alan dot mckinnon at gmail dot com
 
Old 10-13-2010, 05:08 PM
James
 
Default anyone use 389ds?

On Wed, Oct 13, 2010 at 12:08 PM, Alan McKinnon <alan.mckinnon@gmail.com> wrote:
> Apparently, though unproven, at 17:37 on Wednesday 13 October 2010, James did
> opine thusly:
>
>> I'm pretty sure this is a bug. I've tried to emerge these packages on
>> a fresh / new system and the 389-ds-base package has a dependency
>> conflict.
>>
>> -->8--
>>
>> [ebuild *N * *] net-nds/389-ds-base-1.2.6-r1 *USE="bitwise dna
>> kerberos ldapi pam-passthru presence -auto-dn-suffix -autobind -debug
>> -doc (-selinux)" 2,803 kB
>> [blocks B * * ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5"
>> is blocking sys-devel/libtool-2.2.10)
>>
>> Total: 14 packages (10 new, 3 in new slots, 1 reinstall), Size of
>> downloads: 27,734 kB
>> Conflict: 1 block (1 unsatisfied)
>>
>> ** Error: The above package list contains packages which cannot be
>> ** installed at the same time on the same system.
>>
>> * (sys-devel/libtool-2.2.10, installed) pulled in by
>> * * >=sys-devel/libtool-2.2.6b required by (dev-libs/svrcore-4.0.4,
>> ebuild scheduled for merge)
>> * * >=sys-devel/libtool-2.2.6b required by (dev-libs/mozldap-6.0.6-r2,
>> ebuild scheduled for merge)
>>
>> * (sys-devel/libtool-2.2.6b, ebuild scheduled for merge) pulled in by
>> * * sys-devel/libtool:1.5 required by (net-nds/389-ds-base-1.2.6-r1,
>> ebuild scheduled for merge)
>> * * >=sys-devel/libtool-2.2.6b required by
>> (net-nds/389-ds-base-1.2.6-r1, ebuild scheduled for merge)
>>
>> --8<--
>>
>> I can't see a way to get around this blocked package issue as the
>> dependencies require different versions of the package than the actual
>> package I'm trying to emerge.
>
> # eix -e libtool
> [i] sys-devel/libtool
> * * Available versions:
> * * * *(1.3) * 1.3.5
> * * * *(1.5) * **1.5.26 (~)1.5.26-r1 2.2.6b **9999
> * * * *(2) * * (~)2.2.8-r1 2.2.10{tbz2} **2.4
> * * * *{test vanilla}
> * * Installed versions: *2.2.10(2){tbz2}(12:30:40 10/06/10)(-vanilla)
> * * Homepage: * * * * * *http://www.gnu.org/software/libtool/
> * * Description: * * * * A shared library tool for developers
>
>
> Do you have libtool:1.5 installed? Any effect?

Looks like I have libtool 2.2.10 (like you) installed; should I mask
the newer version and attempt a 1.5 installation?

eix -e libtool
[i] sys-devel/libtool
Available versions:
(1.3) 1.3.5
(1.5) **1.5.26 ~1.5.26-r1 2.2.6b **9999
(2) ~2.2.8-r1 2.2.10 **2.4
{test vanilla}
Installed versions: 2.2.10(2)(07:58:35 AM 10/03/2010)(-vanilla)
Homepage: http://www.gnu.org/software/libtool/
Description: A shared library tool for developers

Won't that affect other packages, too?

-james
 
Old 10-13-2010, 07:54 PM
Alan McKinnon
 
Default anyone use 389ds?

Apparently, though unproven, at 19:08 on Wednesday 13 October 2010, James did
opine thusly:

> > # eix -e libtool
> > [i] sys-devel/libtool
> > Available versions:
> > (1.3) 1.3.5
> > (1.5) **1.5.26 (~)1.5.26-r1 2.2.6b **9999
> > (2) (~)2.2.8-r1 2.2.10{tbz2} **2.4
> > {test vanilla}
> > Installed versions: 2.2.10(2){tbz2}(12:30:40 10/06/10)(-vanilla)
> > Homepage: http://www.gnu.org/software/libtool/
> > Description: A shared library tool for developers
> >
> >
> > Do you have libtool:1.5 installed? Any effect?
>
> Looks like I have libtool 2.2.10 (like you) installed; should I mask
> the newer version and attempt a 1.5 installation?
>
> eix -e libtool
> [i] sys-devel/libtool
> Available versions:
> (1.3) 1.3.5
> (1.5) **1.5.26 ~1.5.26-r1 2.2.6b **9999
> (2) ~2.2.8-r1 2.2.10 **2.4
> {test vanilla}
> Installed versions: 2.2.10(2)(07:58:35 AM 10/03/2010)(-vanilla)
> Homepage: http://www.gnu.org/software/libtool/
> Description: A shared library tool for developers
>
> Won't that affect other packages, too?


389ds wants libtool 2.2.6b which is in SLOT 1.5.
You have 2.2.10 which is SLOT 2.
So they can install side-by-side without colliding.

You'd have to ensure 389ds uses the correct libtool and that other packages
don't get confused. I have no idea how to do that - every time I look into
libtool I come away thinking it's an unholy mess that should never have been
suffered to spawn. This directly results in my skills with it remaining at
zero.


--
alan dot mckinnon at gmail dot com
 

Thread Tools




All times are GMT. The time now is 10:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org