Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Baselayout 1.12.13 & bug 291916 (http://www.linux-archive.org/gentoo-user/422622-baselayout-1-12-13-bug-291916-a.html)

Philip Webb 09-04-2010 12:20 PM

Baselayout 1.12.13 & bug 291916
 
Today -- some time after most other users (smile) -- I ran into bug 291916 .
I updated my Asus EEE netbook to Baselayout 1.12.13 & got the messages
"assuming udev failed somewhere, as /dev/zero does not exist" etc ;
downgrading back to Baselayout 1.12.11.1 solved the problem.
I've been using 1.12.13 on the desktop since 2009-11-14 w/o problems.

The bug suggests booting from a live USB & emptying /sys ,
but that seems awkward & hardly the long-term solution.
What is the current proper practice when upgrading to Baselayout 1.12.13 ?

Or is the best solution to move to Baselayout 2 ?
What are others' experiences ?

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca

Mick 09-04-2010 06:28 PM

Baselayout 1.12.13 & bug 291916
 
On Saturday 04 September 2010 13:20:06 Philip Webb wrote:
> Today -- some time after most other users (smile) -- I ran into bug 291916
> . I updated my Asus EEE netbook to Baselayout 1.12.13 & got the messages
> "assuming udev failed somewhere, as /dev/zero does not exist" etc ;
> downgrading back to Baselayout 1.12.11.1 solved the problem.
> I've been using 1.12.13 on the desktop since 2009-11-14 w/o problems.
>
> The bug suggests booting from a live USB & emptying /sys ,
> but that seems awkward & hardly the long-term solution.
> What is the current proper practice when upgrading to Baselayout 1.12.13 ?
>
> Or is the best solution to move to Baselayout 2 ?
> What are others' experiences ?

I did not have this problem on two x86 and one amd64 systems. My amd64 box
has:

$ cat /usr/src/linux/.config | grep CONFIG_SYSFS
# CONFIG_SYSFS_DEPRECATED_V2 is not set
CONFIG_SYSFS=y

Isn't this simply a matter of configuring your kernel accordingly?
--
Regards,
Mick

Philip Webb 09-05-2010 10:47 AM

Baselayout 1.12.13 & bug 291916
 
100904 Mick wrote:
> On Saturday 04 September 2010 13:20:06 Philip Webb wrote:
>> Today I ran into bug 291916.
>> I updated my Asus EEE netbook to Baselayout 1.12.13 & got the messages
>> "assuming udev failed somewhere, as /dev/zero does not exist" etc ;
>> downgrading back to Baselayout 1.12.11.1 solved the problem.
>> I've been using 1.12.13 on the desktop since 2009-11-14 w/o problems.
>> What is the current proper practice when upgrading to Baselayout 1.12.13 ?
> I did not have this problem on two x86 and one amd64 systems.
> My amd64 box has:
> $ cat /usr/src/linux/.config | grep CONFIG_SYSFS
> # CONFIG_SYSFS_DEPRECATED_V2 is not set
> CONFIG_SYSFS=y
> Isn't this simply a matter of configuring your kernel accordingly?

No, it isn't ! -- I had already noticed that suggestion in Forum entries.
My netbook shows exactly the same reply as you show for your AMD64 box.

Thanks for trying to help. Any further suggestions welcome.

>> Or is the best solution to move to Baselayout 2 ?

Does anyone have thoughts on this part ?

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca


All times are GMT. The time now is 10:51 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.