FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-19-2008, 02:32 PM
Uwe Thiem
 
Default KDE 4.0.0

Hi folks,

after the painful and time-consuming creation of /etc/portage/package.unmask
for KDE 4, <emerge --pretend --verbose "=kde-base/kde-meta-4.0.0" tells me:
[blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
kde-base/kdelibs-4.0.0)

I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I cannot
unemerge 3.5.7. How can I work around this?

Uwe

--
If a man speaks in a forest, and no woman listens to him,
is he still lying?
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 02:42 PM
Dale
 
Default KDE 4.0.0

Uwe Thiem wrote:
> Hi folks,
>
> after the painful and time-consuming creation of /etc/portage/package.unmask
> for KDE 4, <emerge --pretend --verbose "=kde-base/kde-meta-4.0.0" tells me:
> [blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
> kde-base/kdelibs-4.0.0)
>
> I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I cannot
> unemerge 3.5.7. How can I work around this?
>
> Uwe
>
>

For future reference, check out autounmask. I found out about it the
other day. I have not used it yet but I'm hopeful it works.

Also, there is a thread on the forums about this, I think you have to
have 3.5.8* version to do this. Not sure why tho. Isn't KDE 4.0
slotted? Can't you have 3.5 AND 4.0 installed and select which version
you want to log into?

Dale

:-) :-)
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 02:52 PM
Δημήτριος Ροπόκης
 
Default KDE 4.0.0

On Sat, 19 Jan 2008 17:42:55 +0200, Dale <dalek1967@bellsouth.net> wrote:


Uwe Thiem wrote:

Hi folks,

after the painful and time-consuming creation of
/etc/portage/package.unmask
for KDE 4, <emerge --pretend --verbose "=kde-base/kde-meta-4.0.0" tells
me:

[blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
kde-base/kdelibs-4.0.0)

I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I
cannot

unemerge 3.5.7. How can I work around this?

Uwe




For future reference, check out autounmask. I found out about it the
other day. I have not used it yet but I'm hopeful it works.

Also, there is a thread on the forums about this, I think you have to
have 3.5.8* version to do this. Not sure why tho. Isn't KDE 4.0
slotted? Can't you have 3.5 AND 4.0 installed and select which version
you want to log into?

Dale

:-) :-)


Autounmask looks to work,
but some packets with ~86 I think need manual check.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 03:31 PM
Paul Salters
 
Default KDE 4.0.0

On Saturday 19 January 2008 16:52:45 Δημήτριος Ροπόκης wrote:
> On Sat, 19 Jan 2008 17:42:55 +0200, Dale <dalek1967@bellsouth.net> wrote:
> > Uwe Thiem wrote:
> >> Hi folks,
> >>
> >> after the painful and time-consuming creation of
> >> /etc/portage/package.unmask
> >> for KDE 4, <emerge --pretend --verbose "=kde-base/kde-meta-4.0.0" tells
> >> me:
> >> [blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
> >> kde-base/kdelibs-4.0.0)
> >>
> >> I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I
> >> cannot
> >> unemerge 3.5.7. How can I work around this?
> >>
> >> Uwe
> >
> > For future reference, check out autounmask. I found out about it the
> > other day. I have not used it yet but I'm hopeful it works.
> >
> > Also, there is a thread on the forums about this, I think you have to
> > have 3.5.8* version to do this. Not sure why tho. Isn't KDE 4.0
> > slotted? Can't you have 3.5 AND 4.0 installed and select which version
> > you want to log into?
> >
> > Dale
> >
> > :-) :-)
>
> Autounmask looks to work,
> but some packets with ~86 I think need manual check.

hi,

you need to unmask kde-base/kdebase-3.5.7-r6 and emerge that.
should work

Paul
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 03:43 PM
Uwe Thiem
 
Default KDE 4.0.0

On 19 January 2008, Dale wrote:
> Uwe Thiem wrote:
> > Hi folks,
> >
> > after the painful and time-consuming creation of
> > /etc/portage/package.unmask for KDE 4, <emerge --pretend --verbose
> > "=kde-base/kde-meta-4.0.0" tells me: [blocks B ]
> > <kde-base/kdebase-3.5.7-r6 (is blocking
> > kde-base/kdelibs-4.0.0)
> >
> > I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I
> > cannot unemerge 3.5.7. How can I work around this?
> >
> > Uwe
>
> For future reference, check out autounmask. I found out about it the
> other day. I have not used it yet but I'm hopeful it works.

I'll have look into autounmask.

>
> Also, there is a thread on the forums about this, I think you have to
> have 3.5.8* version to do this. Not sure why tho. Isn't KDE 4.0
> slotted? Can't you have 3.5 AND 4.0 installed and select which version
> you want to log into?

Exactly. So why is kdebase-3.5.7-r6 (which is not even installed here)
blocking kdelibs-4.0.0?

Uwe

--
If a man speaks in a forest, and no woman listens to him,
is he still lying?
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 04:06 PM
Uwe Thiem
 
Default KDE 4.0.0

On 19 January 2008, Paul Salters wrote:
> On Saturday 19 January 2008 16:52:45 Δημήτριος Ροπόκης wrote:
> > On Sat, 19 Jan 2008 17:42:55 +0200, Dale <dalek1967@bellsouth.net> wrote:
> > > Uwe Thiem wrote:
> > >> Hi folks,
> > >>
> > >> after the painful and time-consuming creation of
> > >> /etc/portage/package.unmask
> > >> for KDE 4, <emerge --pretend --verbose "=kde-base/kde-meta-4.0.0"
> > >> tells me:
> > >> [blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
> > >> kde-base/kdelibs-4.0.0)
> > >>
> > >> I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I
> > >> cannot
> > >> unemerge 3.5.7. How can I work around this?
> > >>
> > >> Uwe
> > >
> > > For future reference, check out autounmask. I found out about it the
> > > other day. I have not used it yet but I'm hopeful it works.
> > >
> > > Also, there is a thread on the forums about this, I think you have to
> > > have 3.5.8* version to do this. Not sure why tho. Isn't KDE 4.0
> > > slotted? Can't you have 3.5 AND 4.0 installed and select which version
> > > you want to log into?
> > >
> > > Dale
> > >
> > > :-) :-)
> >
> > Autounmask looks to work,
> > but some packets with ~86 I think need manual check.
>
> hi,
>
> you need to unmask kde-base/kdebase-3.5.7-r6 and emerge that.
> should work

???

According to emerge, kdebase-3.5.7-r6 is *blocking* kdelibs-4.0.0. See my
original post.

Uwe

--
If a man speaks in a forest, and no woman listens to him,
is he still lying?
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 04:19 PM
Neil Bothwick
 
Default KDE 4.0.0

On Sat, 19 Jan 2008 17:32:13 +0200, Uwe Thiem wrote:

> [blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
> kde-base/kdelibs-4.0.0)
>
> I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I
> cannot unemerge 3.5.7. How can I work around this?

It's <3.5.7, do you have an older version lying around, as well as 3.5.8?
Or it something else trying to pull it in, what does --tree tell you?


--
Neil Bothwick

Top Oxymorons Number 3: Working vacation
 
Old 01-19-2008, 04:27 PM
Dale
 
Default KDE 4.0.0

Uwe Thiem wrote:
>
>
> ???
>
> According to emerge, kdebase-3.5.7-r6 is *blocking* kdelibs-4.0.0. See my
> original post.
>
> Uwe
>
>

I can't find it but I read somewhere that portage wants at least
3.5.8-r2 or better to install 4.0. Again, I have NO CLUE why. My
question if this is true, what if you never had KDE installed to begin
with? Then what? Install the old one then upgrade? Something fishy.

I also read where there is a issue or two with regard to qt. May want
to get your boots on for that too.

Confused.

Dale

:-) :-)
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 04:35 PM
Juul
 
Default KDE 4.0.0

Uwe Thiem schreef:
> On 19 January 2008, Paul Salters wrote:
>
>> hi,
>>
>> you need to unmask kde-base/kdebase-3.5.7-r6 and emerge that.
>> should work
>>
>
> ???
>
> According to emerge, kdebase-3.5.7-r6 is *blocking* kdelibs-4.0.0. See my
> original post.
>
It is blocking older versions 3.5.7-r6. Upgrade to 3.5.7-r6 and the
block will be gone.

Juul

--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-19-2008, 04:39 PM
Uwe Thiem
 
Default KDE 4.0.0

On 19 January 2008, Neil Bothwick wrote:
> On Sat, 19 Jan 2008 17:32:13 +0200, Uwe Thiem wrote:
> > [blocks B ] <kde-base/kdebase-3.5.7-r6 (is blocking
> > kde-base/kdelibs-4.0.0)
> >
> > I do not have emerge kdebase-3.5.7 but kdebase-3.5.8. The3refore, I
> > cannot unemerge 3.5.7. How can I work around this?
>
> It's <3.5.7, do you have an older version lying around, as well as 3.5.8?
> Or it something else trying to pull it in, what does --tree tell you?

Oh, gawd! I completely missed the "<". =8-O

Yes, I do have some older versions of KDE lying around. Alright, some unmerge
to be done.

BIG thanks!!!!! And a Hansa draught will be ready for you if you ever visit
Namibia. ;-)

Uwe

--
If a man speaks in a forest, and no woman listens to him,
is he still lying?
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 12:50 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org