FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 08-05-2010, 04:51 PM
Jarry
 
Default Updating dev-libs/glib pulls a lot of packages...

Hi,
After just one week I am updating one of my servers but I am
rather terrified by all the stuff the new glib wants to install:

# emerge --pretend --update glib
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild N ] app-text/build-docbook-catalog-1.4
[ebuild N ] app-arch/unzip-6.0-r1 USE="bzip2 unicode"
[ebuild N ] app-text/sgml-common-0.6.3-r5
[ebuild N ] dev-libs/libgpg-error-1.7 USE="nls -common-lisp"
[ebuild N ] app-text/docbook-xsl-stylesheets-1.75.2
[ebuild N ] dev-libs/libgcrypt-1.4.5
[ebuild N ] dev-libs/libxslt-1.1.26 USE="crypt python -debug"
[ebuild N ] app-text/docbook-xml-dtd-4.3-r1
[ebuild N ] dev-util/gtk-doc-am-1.15
[ebuild U ] dev-libs/glib-2.24.1-r1 [2.22.5]

Why are suddenly all those ebuilds needed with new glib?

Jarry

--
__________________________________________________ _____________
This mailbox accepts e-mails only from selected mailing-lists!
Everything else is considered to be spam and therefore deleted.
 
Old 08-05-2010, 05:51 PM
Vaeth
 
Default Updating dev-libs/glib pulls a lot of packages...

> [ebuild N ] app-text/build-docbook-catalog-1.4
> [ebuild N ] app-arch/unzip-6.0-r1 USE="bzip2 unicode"
> [ebuild N ] app-text/sgml-common-0.6.3-r5
> [ebuild N ] dev-libs/libgpg-error-1.7 USE="nls -common-lisp"
> [ebuild N ] app-text/docbook-xsl-stylesheets-1.75.2
> [ebuild N ] dev-libs/libgcrypt-1.4.5
> [ebuild N ] dev-libs/libxslt-1.1.26 USE="crypt python -debug"
> [ebuild N ] app-text/docbook-xml-dtd-4.3-r1
> [ebuild N ] dev-util/gtk-doc-am-1.15
> [ebuild U ] dev-libs/glib-2.24.1-r1 [2.22.5]
>
> Why are suddenly all those ebuilds needed with new glib?

http://bugs.gentoo.org/show_bug.cgi?id=318475
 
Old 08-06-2010, 06:41 AM
Alan McKinnon
 
Default Updating dev-libs/glib pulls a lot of packages...

On Thursday 05 August 2010 18:51:54 Jarry wrote:
> Hi,
> After just one week I am updating one of my servers but I am
> rather terrified by all the stuff the new glib wants to install:
>
> # emerge --pretend --update glib
> These are the packages that would be merged, in order:
> Calculating dependencies... done!
> [ebuild N ] app-text/build-docbook-catalog-1.4
> [ebuild N ] app-arch/unzip-6.0-r1 USE="bzip2 unicode"
> [ebuild N ] app-text/sgml-common-0.6.3-r5
> [ebuild N ] dev-libs/libgpg-error-1.7 USE="nls -common-lisp"
> [ebuild N ] app-text/docbook-xsl-stylesheets-1.75.2
> [ebuild N ] dev-libs/libgcrypt-1.4.5
> [ebuild N ] dev-libs/libxslt-1.1.26 USE="crypt python -debug"
> [ebuild N ] app-text/docbook-xml-dtd-4.3-r1
> [ebuild N ] dev-util/gtk-doc-am-1.15
> [ebuild U ] dev-libs/glib-2.24.1-r1 [2.22.5]
>
> Why are suddenly all those ebuilds needed with new glib?
>
> Jarry


You have enabled USE=doc"

unzip, libgpg-error and libgcrypt look like routine updates

--
alan dot mckinnon at gmail dot com
 
Old 08-06-2010, 07:19 AM
Jarry
 
Default Updating dev-libs/glib pulls a lot of packages...

On 6. 8. 2010 8:41, Alan McKinnon wrote:

On Thursday 05 August 2010 18:51:54 Jarry wrote:

# emerge --pretend --update glib
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild N ] app-text/build-docbook-catalog-1.4
[ebuild N ] app-arch/unzip-6.0-r1 USE="bzip2 unicode"
[ebuild N ] app-text/sgml-common-0.6.3-r5
[ebuild N ] dev-libs/libgpg-error-1.7 USE="nls -common-lisp"
[ebuild N ] app-text/docbook-xsl-stylesheets-1.75.2
[ebuild N ] dev-libs/libgcrypt-1.4.5
[ebuild N ] dev-libs/libxslt-1.1.26 USE="crypt python -debug"
[ebuild N ] app-text/docbook-xml-dtd-4.3-r1
[ebuild N ] dev-util/gtk-doc-am-1.15
[ebuild U ] dev-libs/glib-2.24.1-r1 [2.22.5]


You have enabled USE=doc"


I do not have this USE-flag enabled. And I am sure I did not
change USE for long time so I do not understand why suddenly
so many packages want to be installed...


unzip, libgpg-error and libgcrypt look like routine updates


I do not think so. If they were just updates, they should be
marked as "[ebuild U]"...

Jarry

--
__________________________________________________ _____________
This mailbox accepts e-mails only from selected mailing-lists!
Everything else is considered to be spam and therefore deleted.
 
Old 08-06-2010, 08:35 AM
Alan McKinnon
 
Default Updating dev-libs/glib pulls a lot of packages...

On Friday 06 August 2010 09:19:28 Jarry wrote:
> On 6. 8. 2010 8:41, Alan McKinnon wrote:
> > On Thursday 05 August 2010 18:51:54 Jarry wrote:
> >> # emerge --pretend --update glib
> >> These are the packages that would be merged, in order:
> >> Calculating dependencies... done!
> >> [ebuild N ] app-text/build-docbook-catalog-1.4
> >> [ebuild N ] app-arch/unzip-6.0-r1 USE="bzip2 unicode"
> >> [ebuild N ] app-text/sgml-common-0.6.3-r5
> >> [ebuild N ] dev-libs/libgpg-error-1.7 USE="nls -common-lisp"
> >> [ebuild N ] app-text/docbook-xsl-stylesheets-1.75.2
> >> [ebuild N ] dev-libs/libgcrypt-1.4.5
> >> [ebuild N ] dev-libs/libxslt-1.1.26 USE="crypt python -debug"
> >> [ebuild N ] app-text/docbook-xml-dtd-4.3-r1
> >> [ebuild N ] dev-util/gtk-doc-am-1.15
> >> [ebuild U ] dev-libs/glib-2.24.1-r1 [2.22.5]
> >
> > You have enabled USE=doc"
>
> I do not have this USE-flag enabled. And I am sure I did not
> change USE for long time so I do not understand why suddenly
> so many packages want to be installed...

Looks like it is enabled but you are not aware of it. From the ebuild:

DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.16
>=sys-devel/gettext-0.11
>=dev-util/gtk-doc-am-1.11
doc? (
>=dev-libs/libxslt-1.0
>=dev-util/gtk-doc-1.11
~app-text/docbook-xml-dtd-4.1.2 )"

>
> > unzip, libgpg-error and libgcrypt look like routine updates
>
> I do not think so. If they were just updates, they should be
> marked as "[ebuild U]"...

unzip is probably being pulled in from sgml-common
the gpg stuff is coming from dev-libs/libxslt-1.1.26 USE="crypt python -
debug"

So it's all perfectly legit.

emerge with -t is your friend in such cases.


--
alan dot mckinnon at gmail dot com
 
Old 08-06-2010, 09:14 AM
Neil Bothwick
 
Default Updating dev-libs/glib pulls a lot of packages...

On Fri, 6 Aug 2010 10:35:21 +0200, Alan McKinnon wrote:

> > I do not have this USE-flag enabled. And I am sure I did not
> > change USE for long time so I do not understand why suddenly
> > so many packages want to be installed...
>
> Looks like it is enabled but you are not aware of it. From the ebuild:
>
> DEPEND="${RDEPEND}
> >=dev-util/pkgconfig-0.16
> >=sys-devel/gettext-0.11
> >=dev-util/gtk-doc-am-1.11
> doc? (
> >=dev-libs/libxslt-1.0
> >=dev-util/gtk-doc-1.11
> ~app-text/docbook-xml-dtd-4.1.2 )"

gtk-doc-am is now a hard dependency, and it depends on the other three.

Jarry, this is mentioned in both the ebuild comments and the ChangeLog,
the latter should be the first place you look for unexpected changes.


--
Neil Bothwick

The computer revolution is over. The computers won.
 

Thread Tools




All times are GMT. The time now is 03:06 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org