FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-18-2008, 08:21 AM
Helmut Jarausch
 
Default Java emerge problem

Hi,

while doing an emerge --update --deep world

I get the error message
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

dev-java/java-config:2

('ebuild', '/', 'dev-java/java-config-2.0.33-r1', 'merge') pulled in by
('binary', '/', 'dev-java/sun-jre-bin-1.6.0.03', 'merge')

('binary', '/', 'dev-java/java-config-2.1.3', 'merge') pulled in by
('binary', '/', 'dev-java/jsch-0.1.36-r1', 'merge')
('binary', '/', 'dev-java/junit-3.8.2-r1', 'merge')
('binary', '/', 'dev-java/commons-logging-1.1-r4', 'merge')
(and 20 more)


Looking at dev-java/sun-jre-bin-1.6.0.03.ebuild I cannot see where
there is a dependency on dev-java/java-config-2.0.33-r1 .

I had to unmerge dev-java/sun-jre-bin before emerge --update --deep world

Can somebody please explain this to me?

Many thanks,

Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 12:35 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org