FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-24-2007, 04:30 AM
Thufir
 
Default emerge v gem for rails

I'm running into some error messages from rails when running "script/
generate controller foo" and am wondering if it's related to package
management, a mismatch between gems and emerge. Do not use gems, use
emerge? The wiki is incorrect?

The gentoo wiki, <http://gentoo-wiki.com/HOWTO_RoR>, says to:

emerge -av sqlite3-ruby
gem install sqlite3-ruby

Select sqlite3-ruby 1.1.0 (ruby) when prompted.

However, that version doesn't appear to be an option for the gem:

arrakis ~ #
arrakis ~ # gem install sqlite3-ruby
Select which gem to install for your platform (i686-linux)
1. sqlite3-ruby 1.2.1 (mswin32)
2. sqlite3-ruby 1.2.1 (ruby)
3. sqlite3-ruby 1.2.0 (mswin32)
4. sqlite3-ruby 1.2.0 (ruby)
5. Skip this gem
6. Cancel installation
> 6
ERROR: While executing gem ... (Gem::RemoteInstallationCancelled)
Installation of sqlite3-ruby cancelled.
arrakis ~ #
arrakis ~ # ruby --version
ruby 1.8.6 (2007-09-24 patchlevel 111) [i686-linux]
arrakis ~ #




On the other hand, "gem list --local" and eix are consistent and show:

arrakis ~ # eix sqlite3-ruby
[i] dev-ruby/sqlite3-ruby
Available versions: 1.1.0 ~1.2.1
Installed versions: 1.1.0(13:32:16 11/18/07)(doc)
Homepage: http://rubyforge.org/projects/sqlite-ruby/
Description: An extension library to access a SQLite
database from Ruby

arrakis ~ #


So, it looks like the version of sqlite3-ruby installed matches the
instructions at the wiki, but the version number doesn't seem to match
what's available through "gem"; and the wiki specifically states to
install the gem.

The error I'm running into may be totally unrelated to this. It seems a
bit odd to me that sqlite3-ruby must be emerged through portage and that
gem must install it as well -- one or the other would seem to be
sufficient.



thanks,

Thufir

--
gentoo-user@gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 01:43 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org