Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Cannot upgrade kde-base/superkaramba (http://www.linux-archive.org/gentoo-user/396849-cannot-upgrade-kde-base-superkaramba.html)

Matthias Fechner 07-09-2010 05:14 AM

Cannot upgrade kde-base/superkaramba
 
Hi,

I tried the last days to do a
emerge -avuDN world

but it fails at the package
kde-base/superkaramba-4.4.4

I get the error message:
Linking CXX shared library ../../lib/libsuperkaramba.so
CMakeFiles/superkaramba.dir/python/meter.o: In function
`QString2PyString(QString)':

meter.cpp:(.text+0x6e): undefined reference to `PyUnicodeUCS4_FromUnicode'
CMakeFiles/superkaramba.dir/python/meter.o: In function
`PyString2QString(_object*)':

meter.cpp:(.text+0x1bf): undefined reference to `PyUnicodeUCS4_AsUnicode'
/usr/lib/gcc/i686-pc-linux-gnu/4.4.3/../../../../i686-pc-linux-gnu/bin/ld:
warning: creating a DT_TEXTREL in object.

collect2: ld returned 1 exit status
make[2]: *** [lib/libsuperkaramba.so.4.4.0] Error 1

I already tried to rebuild all depending libs starting from python to
kdelibs but it does not help.


Has maybe anyone here an idea what the problem could be?

Thanks
Matthias

--

"Programming today is a race between software engineers striving to
build bigger and better idiot-proof programs, and the universe trying to
produce bigger and better idiots. So far, the universe is winning." --
Rich Cook

"Arttu V." 07-10-2010 02:18 PM

Cannot upgrade kde-base/superkaramba
 
On 7/9/10, Matthias Fechner <idefix@fechner.net> wrote:
> Hi,
>
> I tried the last days to do a
> emerge -avuDN world
>
> but it fails at the package
> kde-base/superkaramba-4.4.4
>
> I get the error message:
> Linking CXX shared library ../../lib/libsuperkaramba.so
> CMakeFiles/superkaramba.dir/python/meter.o: In function
> `QString2PyString(QString)':
> meter.cpp:(.text+0x6e): undefined reference to `PyUnicodeUCS4_FromUnicode'
> CMakeFiles/superkaramba.dir/python/meter.o: In function
> `PyString2QString(_object*)':
> meter.cpp:(.text+0x1bf): undefined reference to `PyUnicodeUCS4_AsUnicode'
> /usr/lib/gcc/i686-pc-linux-gnu/4.4.3/../../../../i686-pc-linux-gnu/bin/ld:
> warning: creating a DT_TEXTREL in object.
> collect2: ld returned 1 exit status
> make[2]: *** [lib/libsuperkaramba.so.4.4.0] Error 1
>
> I already tried to rebuild all depending libs starting from python to
> kdelibs but it does not help.
>
> Has maybe anyone here an idea what the problem could be?

Wild guess: you might have a python version installed which is not
compiled with the wide-unicode support. I'm not sure what all will be
broken by such a situation, but following might help:

qlist -CLIS dev-lang/python | xargs -r emerge -1
python-updater
emerge -1 PyQt4 # unless python-updater took care of it, I don't know
it if will

--
Arttu V. -- Running Gentoo is like running with scissors

Matthias Fechner 07-11-2010 08:03 AM

Cannot upgrade kde-base/superkaramba
 
Hi,

On 07/10/10 16:18, Arttu V. wrote:

Wild guess: you might have a python version installed which is not
compiled with the wide-unicode support. I'm not sure what all will be
broken by such a situation, but following might help:


hm, should not, i started to recompiled everything, but it does not
seems to help, here the information from eix for package dev-lang/python:
2.6.5-r2(2.6)(02:54:47 07/11/10)(berkdb gdbm ipv6 ncurses readline ssl
threads wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk
-wininst)
3.1.2-r3(3.1)(03:04:57 07/11/10)(gdbm ipv6 ncurses readline ssl threads
wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk -wininst)



qlist -CLIS dev-lang/python | xargs -r emerge -1
python-updater
emerge -1 PyQt4 # unless python-updater took care of it, I don't know
it if will


here I get an error message if I try the execute python-updater:
* Starting Python Updater...
* Main active version of Python: 2.6
* Active version of Python 2: 2.6
* Active version of Python 3: 3.1
....
* PVR missing

For this problem I found a bugreport with a patch attached:
http://bugs.gentoo.org/303037

I run the following commands
emerge -C sys-kernel/livecd-kernel

After that I was able to run python-updater.

But the problem keeps like it was, any other suggestions?

Thanks a lot.

Bye
Matthias

--

"Programming today is a race between software engineers striving to
build bigger and better idiot-proof programs, and the universe trying to
produce bigger and better idiots. So far, the universe is winning." --
Rich Cook


All times are GMT. The time now is 02:00 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.