FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-28-2010, 07:23 PM
Mick
 
Default dev-util/cvs is needed by Enligthenment

It seems that dev-util/cvs-1.12.12-r6 was used by E17, but it is no longer in
portage. I was running revdep-rebuild and got stuck:

=================================
[snip ...]
* All prepared. Starting rebuild
emerge --oneshot --verbose --pretend dev-libs/e_dbus:0
dev-libs/ecore:0
media-libs/edje:0
media-libs/evas:0
net-libs/exchange:0
x11-wm/enlightenment:0.17

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-util/cvs".
(dependency required by "x11-wm/enlightenment-9999" [ebuild])
(dependency required by "x11-wm/enlightenment:0.17" [argument])

*
* revdep-rebuild failed to emerge all packages.
=================================

I now seem to have dev-vcs/cvs-1.12.12-r6 installed, but evidently it won't
do. :-(

What now?
--
Regards,
Mick
 
Old 06-28-2010, 09:12 PM
Alan McKinnon
 
Default dev-util/cvs is needed by Enligthenment

On Monday 28 June 2010 21:23:52 Mick wrote:
> It seems that dev-util/cvs-1.12.12-r6 was used by E17, but it is no longer
> in portage. I was running revdep-rebuild and got stuck:
>
> =================================
> [snip ...]
> * All prepared. Starting rebuild
> emerge --oneshot --verbose --pretend dev-libs/e_dbus:0
> dev-libs/ecore:0
> media-libs/edje:0
> media-libs/evas:0
> net-libs/exchange:0
> x11-wm/enlightenment:0.17
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
>
> emerge: there are no ebuilds to satisfy "dev-util/cvs".
> (dependency required by "x11-wm/enlightenment-9999" [ebuild])
> (dependency required by "x11-wm/enlightenment:0.17" [argument])
>
> *
> * revdep-rebuild failed to emerge all packages.
> =================================
>
> I now seem to have dev-vcs/cvs-1.12.12-r6 installed, but evidently it won't
> do. :-(

vapier's enlightenment overlay is woefully out of date, but even so you have
not synced it in a while. That change to dev-vcs/cvs was made ages ago.
Besides, e17 has not been in cvs for about 18 months, it's now svn

A much better supported overlay is to be found at the e17 site:
http://svn.enlightenment.org/svn/e/trunk/packaging/gentoo

It's actively supported by the e17 gentoo-using devs, ably lead by barberei

--
alan dot mckinnon at gmail dot com
 
Old 06-28-2010, 10:04 PM
Mick
 
Default dev-util/cvs is needed by Enligthenment

On Monday 28 June 2010 22:12:27 you wrote:
> On Monday 28 June 2010 21:23:52 Mick wrote:
> > It seems that dev-util/cvs-1.12.12-r6 was used by E17, but it is no
> > longer in portage. I was running revdep-rebuild and got stuck:
> >
> > =================================
> > [snip ...]
> >
> > * All prepared. Starting rebuild
> >
> > emerge --oneshot --verbose --pretend dev-libs/e_dbus:0
> > dev-libs/ecore:0
> > media-libs/edje:0
> > media-libs/evas:0
> > net-libs/exchange:0
> > x11-wm/enlightenment:0.17
> >
> > These are the packages that would be merged, in order:
> >
> > Calculating dependencies... done!
> >
> > emerge: there are no ebuilds to satisfy "dev-util/cvs".
> > (dependency required by "x11-wm/enlightenment-9999" [ebuild])
> > (dependency required by "x11-wm/enlightenment:0.17" [argument])
> >
> > *
> > * revdep-rebuild failed to emerge all packages.
> >
> > =================================
> >
> > I now seem to have dev-vcs/cvs-1.12.12-r6 installed, but evidently it
> > won't do. :-(
>
> vapier's enlightenment overlay is woefully out of date, but even so you
> have not synced it in a while. That change to dev-vcs/cvs was made ages
> ago. Besides, e17 has not been in cvs for about 18 months, it's now svn
>
> A much better supported overlay is to be found at the e17 site:
> http://svn.enlightenment.org/svn/e/trunk/packaging/gentoo
>
> It's actively supported by the e17 gentoo-using devs, ably lead by barberei

Thanks Alan,


I have not used Vapier's overlay, but following your earlier suggestions
(thank you again) I used efl:

http://svn.enlightenment.org/svn/e/trunk/packaging/gentoo/Documentation/layman/overlays.xml
-f -a efl

I was under the impression that I have been updating efl, because I have this
in my make.conf:

source /var/lib/layman/make.conf

Which in turn seems to contain:
==================
PORTDIR_OVERLAY="
/var/lib/layman/efl
$PORTDIR_OVERLAY
"
==================

I am a noob with layman and still trying to learn my way around it, so am I
missing something simple here?

PS. I resync'ed manually and ran revdep-rebuild a couple of times which
rebuilt a few packages from enlightenment. Will log into it in a minute,
hopefully all will be OK.
--
Regards,
Mick
 

Thread Tools




All times are GMT. The time now is 06:00 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org