FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-23-2010, 11:14 PM
Allan Gottlieb
 
Default unable to drive the VGA output

Laptop: dell E6510
Gentoo: ~amd64
Graphics: nvidia VVS 3100M

I am unable to drive the VGA output. Symptoms include

* Executing "xrandr" does not mention LVDS or VGA
(and using --output VGA gives a warning that VGA doesn't exist)

* Pushing Fn-F8 produces a "p" (the keycap of f8 shows in blue a picture
of a laptop and a monitor) instead of showing the screen on the other
display.

The xorg.conf file generated by nvidia-xconfig (below) is fairly simple.
I just added the module section at the end.

Any help would be appreciated.

allan

================================================== ==============

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Apr 22 20:35:23 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from data in "/etc/conf.d/gpm"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Module"
# Load "dri"
load "glx"
EndSection
 
Old 06-24-2010, 06:14 PM
Allan Gottlieb
 
Default unable to drive the VGA output

At Thu, 24 Jun 2010 20:02:13 +0200 Matthias Krebs <matthias.krebs@gmail.com> wrote:

> Am Donnerstag 24 Juni 2010, 01:14:44 schrieb Allan Gottlieb:
>> Laptop: dell E6510
>> Gentoo: ~amd64
>> Graphics: nvidia VVS 3100M
>>
>> I am unable to drive the VGA output. Symptoms include
>>
>> * Executing "xrandr" does not mention LVDS or VGA
>> (and using --output VGA gives a warning that VGA doesn't exist)
> try with default like :
> xrandr --output default --mode 1280x1024

This works and permits me to change the resolution of the display.

> xrandr without options show the available resolutions, second line shows the
> output names, like "DVI-0 connected" or "default connected". on my one box
> with the nvidia driver i have "default connected"

Right. I just have "default connected" as well.
Do you know how to enable DVI-0 connected?

Your msg encourages me to search documentation about the nvidia driver.

thanks,
allan
 

Thread Tools




All times are GMT. The time now is 01:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org