FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-19-2010, 07:37 AM
 
Default Compilation aborted for setuptools-0.6.12

Hi,

compilation of setuptools-0.6.12 aborts woth:
copying tests/api_tests.txt -> build/src/tests
Traceback (most recent call last):
File "setup.py", line 24, in <module>
from lib2to3.main import main
File "/usr/lib/python3.1/lib2to3/main.py", line 12, in <module>
from . import refactor
File "/usr/lib/python3.1/lib2to3/refactor.py", line 25, in <module>
from . import pytree, pygram
File "/usr/lib/python3.1/lib2to3/pygram.py", line 35, in <module>
del python_grammar_no_print_statement.keywords["print"]
KeyError: 'print'
* ERROR: dev-python/setuptools-0.6.12 failed:
* Building failed with CPython 3.1 in distutils_building() function
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 4648: Called distutils_src_compile
* environment, line 1278: Called python_execute_function 'distutils_building'
* environment, line 3426: Called die
* The specific snippet of code:
* die "${failure_message}";
*
* If you need support, post the output of 'emerge --info =dev-python/setuptools-0.6.12',
* the complete build log and the output of 'emerge -pqv =dev-python/setuptools-0.6.12'.
* The complete build log is located at '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/environment'.
* S: '/var/tmp/portage/dev-python/setuptools-0.6.12/work/distribute-0.6.12'

>>> Failed to emerge dev-python/setuptools-0.6.12, Log file:

>>> '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/build.log'

* Messages for package dev-python/setuptools-0.6.12:

* ERROR: dev-python/setuptools-0.6.12 failed:
* Building failed with CPython 3.1 in distutils_building() function
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 4648: Called distutils_src_compile
* environment, line 1278: Called python_execute_function 'distutils_building'
* environment, line 3426: Called die
* The specific snippet of code:
* die "${failure_message}";
*
* If you need support, post the output of 'emerge --info =dev-python/setuptools-0.6.12',
* the complete build log and the output of 'emerge -pqv =dev-python/setuptools-0.6.12'.
* The complete build log is located at '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/environment'.
* S: '/var/tmp/portage/dev-python/setuptools-0.6.12/work/distribute-0.6.12'
solfire:/root>qsearch setuptools
search: Updating ebuild cache ...
search: Finished 27398 entries in 0.474906 seconds
dev-python/setuptools Distribute (fork of Setuptools) is a collection of extensions to Distutils

f you need the addtional files mentioned above please dont hesitat to
mail me.
I only dont with to clutter the mailing list.

How can I fix that bug?

Best regards.
mcc
 
Old 06-19-2010, 02:43 PM
walt
 
Default Compilation aborted for setuptools-0.6.12

On 06/19/2010 12:37 AM, meino.cramer@gmx.de wrote:


Hi,

compilation of setuptools-0.6.12 aborts woth:
copying tests/api_tests.txt -> build/src/tests
Traceback (most recent call last):
File "setup.py", line 24, in<module>
from lib2to3.main import main
File "/usr/lib/python3.1/lib2to3/main.py", line 12, in<module>
from . import refactor
File "/usr/lib/python3.1/lib2to3/refactor.py", line 25, in<module>


Have you set eselect python to use python-3 instead of python-2? If so,
try setting it back to python-2.
 
Old 06-19-2010, 02:55 PM
 
Default Compilation aborted for setuptools-0.6.12

walt <w41ter@gmail.com> [10-06-19 16:48]:
> On 06/19/2010 12:37 AM, meino.cramer@gmx.de wrote:
> >
> >Hi,
> >
> >compilation of setuptools-0.6.12 aborts woth:
> >copying tests/api_tests.txt -> build/src/tests
> >Traceback (most recent call last):
> > File "setup.py", line 24, in<module>
> > from lib2to3.main import main
> > File "/usr/lib/python3.1/lib2to3/main.py", line 12, in<module>
> > from . import refactor
> > File "/usr/lib/python3.1/lib2to3/refactor.py", line 25, in<module>
>
> Have you set eselect python to use python-3 instead of python-2? If
> so,
> try setting it back to python-2.
>
>

No, python 2.6 ist set according to the output of

eselect python list

python 3.1 is installed but not selected.

What else can produce this compilation error?

Best regards,
mcc
 
Old 06-19-2010, 03:56 PM
David W Noon
 
Default Compilation aborted for setuptools-0.6.12

On Sat, 19 Jun 2010 17:00:02 +0200, meino.cramer@gmx.de wrote about Re:
[gentoo-user] Re: Compilation aborted for setuptools-0.6.12:

>walt <w41ter@gmail.com> [10-06-19 16:48]:
[snip]
>> Have you set eselect python to use python-3 instead of python-2? If
>> so,
>> try setting it back to python-2.
>
>No, python 2.6 ist set according to the output of
>
> eselect python list
>
>python 3.1 is installed but not selected.
>
>What else can produce this compilation error?

Have you run python-updater?

When new packages have Python components, they will build both 2.6 and
3.1 modules if possible. This means that their dependencies also need
to have both 2.6 and 3.1 modules. You achieve this by running
python-updater; this can take several hours.
--
Regards,

Dave [RLU #314465]
================================================== ====================
dwnoon@ntlworld.com (David W Noon)
================================================== ====================
 
Old 06-19-2010, 04:06 PM
 
Default Compilation aborted for setuptools-0.6.12

David W Noon <dwnoon@ntlworld.com> [10-06-19 18:00]:
> On Sat, 19 Jun 2010 17:00:02 +0200, meino.cramer@gmx.de wrote about Re:
> [gentoo-user] Re: Compilation aborted for setuptools-0.6.12:
>
> >walt <w41ter@gmail.com> [10-06-19 16:48]:
> [snip]
> >> Have you set eselect python to use python-3 instead of python-2? If
> >> so,
> >> try setting it back to python-2.
> >
> >No, python 2.6 ist set according to the output of
> >
> > eselect python list
> >
> >python 3.1 is installed but not selected.
> >
> >What else can produce this compilation error?
>
> Have you run python-updater?
>
> When new packages have Python components, they will build both 2.6 and
> 3.1 modules if possible. This means that their dependencies also need
> to have both 2.6 and 3.1 modules. You achieve this by running
> python-updater; this can take several hours.
> --
> Regards,
>
> Dave [RLU #314465]
> ================================================== ====================
> dwnoon@ntlworld.com (David W Noon)
> ================================================== ====================


Hi Dave,

wait...hopefully I understand this correctly, before I start to screw
up my newly installed system...

State 1 right after installing Gentoo: Pyton2.6 selected, installed
and up.
State 2 some days later while upateing python3.1 was offered but
should *not* eselect python 3.1 since some older package are still
not updated to work correctly with 3.1
State 3 setuptools seems to try to compile against 3.1 and failed.

Now I should run python-updater to ... (scratching my head)?
To update to python 3.1..but setuptools failed while compiling
against python 3.1

It seems I myself feel a little screwed up,,,

?

Best regards,
mcc
 
Old 06-19-2010, 05:44 PM
David W Noon
 
Default Compilation aborted for setuptools-0.6.12

On Sat, 19 Jun 2010 18:10:02 +0200, meino.cramer@gmx.de wrote about Re:
[gentoo-user] Re: Compilation aborted for setuptools-0.6.12:

[snip]
>wait...hopefully I understand this correctly, before I start to screw
>up my newly installed system...
>
>State 1 right after installing Gentoo: Pyton2.6 selected, installed
>and up.
>State 2 some days later while upateing python3.1 was offered but
>should *not* eselect python 3.1 since some older package are still
>not updated to work correctly with 3.1
>State 3 setuptools seems to try to compile against 3.1 and failed.
>
>Now I should run python-updater to ... (scratching my head)?

You need to run python-updater so that there are python modules for all
packages that are compatible with both releases of Python. This is
because any such package will attempt to build modules for both Python
interpreters, even though you are currently using only 2.6.

>To update to python 3.1..but setuptools failed while compiling
>against python 3.1

Just run python-updater first, as this will take care of any
build-time dependencies of setuptools. Then try to emerge your general
updates, which should build setuptools correctly.
--
Regards,

Dave [RLU #314465]
================================================== ====================
dwnoon@ntlworld.com (David W Noon)
================================================== ====================
 
Old 06-19-2010, 05:54 PM
Alan McKinnon
 
Default Compilation aborted for setuptools-0.6.12

On Saturday 19 June 2010 18:06:58 meino.cramer@gmx.de wrote:
> David W Noon <dwnoon@ntlworld.com> [10-06-19 18:00]:
> > On Sat, 19 Jun 2010 17:00:02 +0200, meino.cramer@gmx.de wrote about Re:
> >
> > [gentoo-user] Re: Compilation aborted for setuptools-0.6.12:
> > >walt <w41ter@gmail.com> [10-06-19 16:48]:
> > [snip]
> >
> > >> Have you set eselect python to use python-3 instead of python-2? If
> > >> so,
> > >> try setting it back to python-2.
> > >
> > >No, python 2.6 ist set according to the output of
> > >
> > > eselect python list
> > >
> > >python 3.1 is installed but not selected.
> > >
> > >What else can produce this compilation error?
> >
> > Have you run python-updater?
> >
> > When new packages have Python components, they will build both 2.6 and
> > 3.1 modules if possible. This means that their dependencies also need
> > to have both 2.6 and 3.1 modules. You achieve this by running
> > python-updater; this can take several hours.
>
> Hi Dave,
>
> wait...hopefully I understand this correctly, before I start to screw
> up my newly installed system...
>
> State 1 right after installing Gentoo: Pyton2.6 selected, installed
> and up.
> State 2 some days later while upateing python3.1 was offered but
> should *not* eselect python 3.1 since some older package are still
> not updated to work correctly with 3.1
> State 3 setuptools seems to try to compile against 3.1 and failed.
>
> Now I should run python-updater to ... (scratching my head)?
> To update to python 3.1..but setuptools failed while compiling
> against python 3.1
>
> It seems I myself feel a little screwed up,,,
>
> ?
>
> Best regards,
> mcc

Did you miss the significance of this part?

"This means that their dependencies also need to have both 2.6 and 3.1
modules. You achieve this by running python-updater; this can take several
hours."

--
alan dot mckinnon at gmail dot com
 
Old 06-19-2010, 06:30 PM
Dale
 
Default Compilation aborted for setuptools-0.6.12

Alan McKinnon wrote:

On Saturday 19 June 2010 18:06:58 meino.cramer@gmx.de wrote:


David W Noon<dwnoon@ntlworld.com> [10-06-19 18:00]:


On Sat, 19 Jun 2010 17:00:02 +0200, meino.cramer@gmx.de wrote about Re:

[gentoo-user] Re: Compilation aborted for setuptools-0.6.12:


walt<w41ter@gmail.com> [10-06-19 16:48]:


[snip]



Have you set eselect python to use python-3 instead of python-2? If
so,
try setting it back to python-2.


No, python 2.6 ist set according to the output of

eselect python list

python 3.1 is installed but not selected.

What else can produce this compilation error?


Have you run python-updater?

When new packages have Python components, they will build both 2.6 and
3.1 modules if possible. This means that their dependencies also need
to have both 2.6 and 3.1 modules. You achieve this by running
python-updater; this can take several hours.


Hi Dave,

wait...hopefully I understand this correctly, before I start to screw
up my newly installed system...

State 1 right after installing Gentoo: Pyton2.6 selected, installed
and up.
State 2 some days later while upateing python3.1 was offered but
should *not* eselect python 3.1 since some older package are still
not updated to work correctly with 3.1
State 3 setuptools seems to try to compile against 3.1 and failed.

Now I should run python-updater to ... (scratching my head)?
To update to python 3.1..but setuptools failed while compiling
against python 3.1

It seems I myself feel a little screwed up,,,

?

Best regards,
mcc


Did you miss the significance of this part?

"This means that their dependencies also need to have both 2.6 and 3.1
modules. You achieve this by running python-updater; this can take several
hours."




Or if he doesn't really need python 3, he can just mask the thing until
he does need it. Of course, he may have to run python-updater again or
rebuild the same packages again to get them to not use python 3.


Yep, making this stable hasn't confused anyone yet. o_O

Dale

:-) :-)
 
Old 06-19-2010, 11:38 PM
 
Default Compilation aborted for setuptools-0.6.12

Dale <rdalek1967@gmail.com> [10-06-20 01:33]:
> Alan McKinnon wrote:
> >On Saturday 19 June 2010 18:06:58 meino.cramer@gmx.de wrote:
> >
> >>David W Noon<dwnoon@ntlworld.com> [10-06-19 18:00]:
> >>
> >>>On Sat, 19 Jun 2010 17:00:02 +0200, meino.cramer@gmx.de wrote about
> >>>Re:
> >>>
> >>>[gentoo-user] Re: Compilation aborted for setuptools-0.6.12:
> >>>
> >>>>walt<w41ter@gmail.com> [10-06-19 16:48]:
> >>>>
> >>>[snip]
> >>>
> >>>
> >>>>>Have you set eselect python to use python-3 instead of python-2?
> >>>>>If
> >>>>>so,
> >>>>>try setting it back to python-2.
> >>>>>
> >>>>No, python 2.6 ist set according to the output of
> >>>>
> >>>> eselect python list
> >>>>
> >>>>python 3.1 is installed but not selected.
> >>>>
> >>>>What else can produce this compilation error?
> >>>>
> >>>Have you run python-updater?
> >>>
> >>>When new packages have Python components, they will build both 2.6
> >>>and
> >>>3.1 modules if possible. This means that their dependencies also
> >>>need
> >>>to have both 2.6 and 3.1 modules. You achieve this by running
> >>>python-updater; this can take several hours.
> >>>
> >>Hi Dave,
> >>
> >>wait...hopefully I understand this correctly, before I start to screw
> >>up my newly installed system...
> >>
> >>State 1 right after installing Gentoo: Pyton2.6 selected, installed
> >>and up.
> >>State 2 some days later while upateing python3.1 was offered but
> >>should *not* eselect python 3.1 since some older package are still
> >>not updated to work correctly with 3.1
> >>State 3 setuptools seems to try to compile against 3.1 and failed.
> >>
> >>Now I should run python-updater to ... (scratching my head)?
> >>To update to python 3.1..but setuptools failed while compiling
> >>against python 3.1
> >>
> >>It seems I myself feel a little screwed up,,,
> >>
> >>?
> >>
> >>Best regards,
> >>mcc
> >>
> >Did you miss the significance of this part?
> >
> >"This means that their dependencies also need to have both 2.6 and 3.1
> >modules. You achieve this by running python-updater; this can take
> >several
> >hours."
> >
> >
>
> Or if he doesn't really need python 3, he can just mask the thing until
> he does need it. Of course, he may have to run python-updater again or
> rebuild the same packages again to get them to not use python 3.
>
> Yep, making this stable hasn't confused anyone yet. o_O
>
> Dale
>
> :-) :-)
>

Ok, I run python-updater and It fails with (guess...drumroll):



* Messages for package dev-python/setuptools-0.6.12:

* ERROR: dev-python/setuptools-0.6.12 failed:
* Building failed with CPython 3.1 in distutils_building() function
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 4627: Called distutils_src_compile
* environment, line 1257: Called python_execute_function 'distutils_building'
* environment, line 3405: Called die
* The specific snippet of code:
* die "${failure_message}";
*
* If you need support, post the output of 'emerge --info =dev-python/setuptools-0.6.12',
* the complete build log and the output of 'emerge -pqv =dev-python/setuptools-0.6.12'.
* The complete build log is located at '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/environment'.
* S: '/var/tmp/portage/dev-python/setuptools-0.6.12/work/distribute-0.6.12'
*
* The following package has failed to build or install:
*
* ('ebuild', '/', 'dev-python/setuptools-0.6.12', 'merge'), Log file:
* '/var/tmp/portage/dev-python/setuptools-0.6.12/temp/build.log'
*


And yes: I need python 3.1 (building the svn version of blender needs
it, which gets installed under /uss/local/...)

Is this the infamous cat, which bits into its own tail... ?

Best regards,
mcc
 
Old 06-20-2010, 01:18 AM
David Abbott
 
Default Compilation aborted for setuptools-0.6.12

On Sat, Jun 19, 2010 at 7:38 PM, <meino.cramer@gmx.de> wrote:
> And yes: I need python 3.1 (building the svn version of blender needs
> it, which gets installed under /uss/local/...)
>
> Is this the infamous cat, which bits into its own tail... ?
>
> Best regards,
> mcc
>

You can set your main active version of python as 2.6, and still have
3.1 installed to build and run Blender.
http://www.gentoo.org/proj/en/Python/developersguide.xml

I have not seen the ebuild you are using for your svn version of
blender so not sure if it will work as is.
Python is not ready as yet to run as your main active version yet and
looks like you found one of the reasons.

--
David Abbott (dabbott)
 

Thread Tools




All times are GMT. The time now is 04:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org