FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-09-2010, 05:24 PM
Sebastian Beßler
 
Default Strange python-updater error

Am 09.06.2010 12:32, schrieb Jacques Montier:
> Hi all,

Hi,

> dev-lang/-MERGING-python:2.5

I get this also sometimes when I have a emerge running and use
python-updater at the same time.

Then waiting for the emerge to stop normaly helps.

Greetings

Sebastian
 
Old 06-10-2010, 05:36 AM
Dale
 
Default Strange python-updater error

Tanstaafl wrote:

On 2010-06-09 12:28 PM, Neil Bothwick wrote:


On Wed, 9 Jun 2010 18:21:17 +0200, Alex Schuster wrote:


I'm guessing it won't hurt anything, again as long as I don't
stupidly switch to it?



Right.



And if a script specifically wants Python 3, it is there for it to
use.


Cool, thanks guys...




I agree with the other replies. You have it there now so just let it
be. Just don't switch to it until there is a news item that says
everything is ready. I would even make sure everything depends on
python 3 and nothing depends on python 2 before switching, just in case
you have something that will break and cause you grief.


To think the devs didn't believe this was going to cause some confusion.
< sighs >


Dale

:-) :-)
 
Old 06-10-2010, 10:24 AM
Sebastian Beßler
 
Default Strange python-updater error

Am 10.06.2010 07:36, schrieb Dale:

> To think the devs didn't believe this was going to cause some confusion.

There is a news regarding python 3 after the install of python 3.
It clearly says that is ok to have both installed parallel, and runnig
python-updater is recommended, but you should never ever set python 3 as
system default until further notice.

On the dev-list putting python 3 into stable and how to handle it was
debated with many powerful emotions assigned.

They knew what they did.. If how they handled that problem is good or
not is a other pair of shoes.

Greetings

Sebastian
 
Old 06-10-2010, 05:11 PM
Dale
 
Default Strange python-updater error

Sebastian Beßler wrote:

Am 10.06.2010 07:36, schrieb Dale:



To think the devs didn't believe this was going to cause some confusion.


There is a news regarding python 3 after the install of python 3.
It clearly says that is ok to have both installed parallel, and runnig
python-updater is recommended, but you should never ever set python 3 as
system default until further notice.

On the dev-list putting python 3 into stable and how to handle it was
debated with many powerful emotions assigned.

They knew what they did.. If how they handled that problem is good or
not is a other pair of shoes.

Greetings

Sebastian




Yep, I was part of that discussion so I know about it. News item or
not, marking something as stable still confuses people when you are then
told you can't use it. With most packages it would not matter much but
when very little can use this package, it is sort of silly.


Dale

:-) :-)
 

Thread Tools




All times are GMT. The time now is 02:09 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org