FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-09-2010, 10:32 AM
Jacques Montier
 
Default Strange python-updater error

Hi all,

After upgrading world, i installed python-3.1.2-r3 with already
installed python-2.6.4-r1
As recommended, i ran python-updater ; so python-updater added some
packages to the list as :
app-office/openoffice-bin:0
dev-lang/-MERGING-python:2.5
...

The output is an error about dev-lang/-MERGING-python:2.5 as invalid atom !
Where does that "-MERGING-" come from ?
Any idea about it ?

Thank you for your help.

Cheers,

--
Jacques
 
Old 06-09-2010, 01:17 PM
walt
 
Default Strange python-updater error

On 06/09/2010 03:32 AM, Jacques Montier wrote:

Hi all,

After upgrading world, i installed python-3.1.2-r3 with already
installed python-2.6.4-r1
As recommended, i ran python-updater ; so python-updater added some
packages to the list as :
app-office/openoffice-bin:0
dev-lang/-MERGING-python:2.5
...

The output is an error about dev-lang/-MERGING-python:2.5 as invalid atom !
Where does that "-MERGING-" come from ?


Which version of python are you actually using now? AFAIK the portage utilities
don't yet work correctly if you are using python-3.
 
Old 06-09-2010, 01:33 PM
Neil Bothwick
 
Default Strange python-updater error

On Wed, 09 Jun 2010 12:32:05 +0200, Jacques Montier wrote:

> The output is an error about dev-lang/-MERGING-python:2.5 as invalid
> atom ! Where does that "-MERGING-" come from ?

It's an orphaned file left in /var/db/pkg by an aborted emerge attempt.
Delete it and try again.
 
Old 06-09-2010, 01:47 PM
Jacques Montier
 
Default Strange python-updater error

Le 09/06/2010 15:17, walt a gentiment tapote:
> On 06/09/2010 03:32 AM, Jacques Montier wrote:
>> Hi all,
>>
>> After upgrading world, i installed python-3.1.2-r3 with already
>> installed python-2.6.4-r1
>> As recommended, i ran python-updater ; so python-updater added some
>> packages to the list as :
>> app-office/openoffice-bin:0
>> dev-lang/-MERGING-python:2.5
>> ...
>>
>> The output is an error about dev-lang/-MERGING-python:2.5 as invalid
>> atom !
>> Where does that "-MERGING-" come from ?
>
> Which version of python are you actually using now? AFAIK the portage
> utilities
> don't yet work correctly if you are using python-3.
>
>
>
>
I use python2.6, but both 2.6 and 3.1 are installed.

Jacques
 
Old 06-09-2010, 02:26 PM
Dale
 
Default Strange python-updater error

Jacques Montier wrote:

Le 09/06/2010 15:17, walt a gentiment tapote:


On 06/09/2010 03:32 AM, Jacques Montier wrote:


Hi all,

After upgrading world, i installed python-3.1.2-r3 with already
installed python-2.6.4-r1
As recommended, i ran python-updater ; so python-updater added some
packages to the list as :
app-office/openoffice-bin:0
dev-lang/-MERGING-python:2.5
...

The output is an error about dev-lang/-MERGING-python:2.5 as invalid
atom !
Where does that "-MERGING-" come from ?


Which version of python are you actually using now? AFAIK the portage
utilities
don't yet work correctly if you are using python-3.






I use python2.6, but both 2.6 and 3.1 are installed.

Jacques




Just for the record, installing python 3.1 is fine but DON'T switch to
it. Very little works with it right now. There was a HUGE discussion
about this on -dev. It's confusing because python 3.1 is stable but you
can't switch to it yet since not much is ready for it.


The best thing to do is to mask python 3.1 until you can actually switch
to it. That is what most devs are recommending. If you don't have
something that has to have it, mask it for now.


Dale

:-) :-)
 
Old 06-09-2010, 02:33 PM
Jacques Montier
 
Default Strange python-updater error

--
Jacques

Site : http://sites.google.com/site/jacquesfr35/
Le 09/06/2010 16:26, Dale a gentiment tapote:
> Jacques Montier wrote:
>> Le 09/06/2010 15:17, walt a gentiment tapote:
>>
>>> On 06/09/2010 03:32 AM, Jacques Montier wrote:
>>>
>>>> Hi all,
>>>>
>>>> After upgrading world, i installed python-3.1.2-r3 with already
>>>> installed python-2.6.4-r1
>>>> As recommended, i ran python-updater ; so python-updater added some
>>>> packages to the list as :
>>>> app-office/openoffice-bin:0
>>>> dev-lang/-MERGING-python:2.5
>>>> ...
>>>>
>>>> The output is an error about dev-lang/-MERGING-python:2.5 as invalid
>>>> atom !
>>>> Where does that "-MERGING-" come from ?
>>>>
>>> Which version of python are you actually using now? AFAIK the portage
>>> utilities
>>> don't yet work correctly if you are using python-3.
>>>
>>>
>>>
>>>
>>>
>> I use python2.6, but both 2.6 and 3.1 are installed.
>>
>> Jacques
>>
>>
>
> Just for the record, installing python 3.1 is fine but DON'T switch to
> it. Very little works with it right now. There was a HUGE discussion
> about this on -dev. It's confusing because python 3.1 is stable but
> you can't switch to it yet since not much is ready for it.
>
> The best thing to do is to mask python 3.1 until you can actually
> switch to it. That is what most devs are recommending. If you don't
> have something that has to have it, mask it for now.
>
> Dale
>
> :-) :-)
>
>
with eselect python list, i get this :
# Available Python interpreters:
[1] python2.6 *
[2] python3.1
So python2.6 is the main active version ; therefore is it necessary to
mask it ?

Jacques
 
Old 06-09-2010, 03:07 PM
Jacques Montier
 
Default Strange python-updater error

Le 09/06/2010 15:33, Neil Bothwick a gentiment tapote:
> On Wed, 09 Jun 2010 12:32:05 +0200, Jacques Montier wrote:
>
>
>> The output is an error about dev-lang/-MERGING-python:2.5 as invalid
>> atom ! Where does that "-MERGING-" come from ?
>>
> It's an orphaned file left in /var/db/pkg by an aborted emerge attempt.
> Delete it and try again.
>
Yes ! it works !

thanks a lot !

Jacques
 
Old 06-09-2010, 03:08 PM
Dale
 
Default Strange python-updater error

Jacques Montier wrote:


--
Jacques

Site : http://sites.google.com/site/jacquesfr35/
Le 09/06/2010 16:26, Dale a gentiment tapote:


Jacques Montier wrote:


Le 09/06/2010 15:17, walt a gentiment tapote:



On 06/09/2010 03:32 AM, Jacques Montier wrote:



Hi all,

After upgrading world, i installed python-3.1.2-r3 with already
installed python-2.6.4-r1
As recommended, i ran python-updater ; so python-updater added some
packages to the list as :
app-office/openoffice-bin:0
dev-lang/-MERGING-python:2.5
...

The output is an error about dev-lang/-MERGING-python:2.5 as invalid
atom !
Where does that "-MERGING-" come from ?



Which version of python are you actually using now? AFAIK the portage
utilities
don't yet work correctly if you are using python-3.







I use python2.6, but both 2.6 and 3.1 are installed.

Jacques




Just for the record, installing python 3.1 is fine but DON'T switch to
it. Very little works with it right now. There was a HUGE discussion
about this on -dev. It's confusing because python 3.1 is stable but
you can't switch to it yet since not much is ready for it.

The best thing to do is to mask python 3.1 until you can actually
switch to it. That is what most devs are recommending. If you don't
have something that has to have it, mask it for now.

Dale

:-) :-)




with eselect python list, i get this :
# Available Python interpreters:
[1] python2.6 *
[2] python3.1
So python2.6 is the main active version ; therefore is it necessary to
mask it ?

Jacques




If I recall correctly, there are a few programs that can run with python
3. Thing is, there are still a LOT of them that can't run with it and
must have python 2. If you switch to python 3, you will have a mess on
your hands. If nothing actually requires python 3, mask it for now. It
will be a while before you will have to have it anyway. When that time
comes, portage will tell you that some package that must have python 3
only is masked. Then you can remove the mask, install it and switch to it.


This is just to save you some "issues" later on. Trying to use python 3
right now is not going to work. Wait until things are able to use and
go through the update process then and only have to do it once.


That's my $0.02 worth.

Dale

:-) :-)
 
Old 06-09-2010, 03:24 PM
Tanstaafl
 
Default Strange python-updater error

On 2010-06-09 11:08 AM, Dale wrote:
> If I recall correctly, there are a few programs that can run with
> python 3. Thing is, there are still a LOT of them that can't run with
> it and must have python 2. If you switch to python 3, you will have a
> mess on your hands. If nothing actually requires python 3, mask it
> for now. It will be a while before you will have to have it anyway.
> When that time comes, portage will tell you that some package that
> must have python 3 only is masked. Then you can remove the mask,
> install it and switch to it.
>
> This is just to save you some "issues" later on. Trying to use python
> 3 right now is not going to work. Wait until things are able to use
> and go through the update process then and only have to do it once.
>
> That's my $0.02 worth.

So... for those of use who have already installed it (and thankfully I
did actually read the notes about not switching to it), should me
uninstall it then mask it? Or just leave it alone? I'm guessing it won't
hurt anything, again as long as I don't stupidly switch to it?
 
Old 06-09-2010, 04:21 PM
Alex Schuster
 
Default Strange python-updater error

Tanstaafl writes:

> So... for those of use who have already installed it (and thankfully I
> did actually read the notes about not switching to it), should me
> uninstall it then mask it? Or just leave it alone?

For the sake of simplicity, I just leave it alone.

> I'm guessing it
> won't hurt anything, again as long as I don't stupidly switch to it?

Right.

Wonko
 

Thread Tools




All times are GMT. The time now is 04:32 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org