FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-15-2008, 07:37 AM
Michael Schmarck
 
Default Single click is interpreted as double click

Hello.

Yesterday, I upgraded to xorg-server 1.4 from 1.3. I also recompiled
all the x11-drivers packages, including xf86-input-mouse-1.2.3.

Today, I started Xorg 1.4 for the 1st time. When I now single click
something, the system seems to get a double click. Examples:

- In jedit, when I single click a word, the word is highlighted. This
should only happen, when a double click is done.
- In Nautilus, when I single click a folder, it is opened
- In Epiphany, when browsing for a file, I single clicked on a folder
in the "File Browse" dialog on the right hand side, where also the
files are displayed. The folder was opened right away. This should
not have happened.
- Firefox behaves just like Epiphany.

I uploaded my Xorg.conf to <http://pastebin.ca/855818>. I used the
exact same Xorg.conf with xorg-server-1.3, and there a single click
wasn't "misinterpreted".

Normally, I use Gnome with metacity as my window manager. But I also
tried a barebone twm setup, which misbehaves just like my normal
Gnome setup.

I'm using a very simple Dell branded Logitech Optical USB Mouse
via USB.

What might be broken there?

Thanks,
Michael

--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-15-2008, 08:16 AM
Sascha Hlusiak
 
Default Single click is interpreted as double click

> Yesterday, I upgraded to xorg-server 1.4 from 1.3. I also recompiled
> all the x11-drivers packages, including xf86-input-mouse-1.2.3.
>
> Today, I started Xorg 1.4 for the 1st time. When I now single click
> something, the system seems to get a double click. Examples:
>
> I uploaded my Xorg.conf to <http://pastebin.ca/855818>. I used the
> exact same Xorg.conf with xorg-server-1.3, and there a single click
> wasn't "misinterpreted".
>
> I'm using a very simple Dell branded Logitech Optical USB Mouse
> via USB.
>
> What might be broken there?
Can you paste your /var/log/Xorg.0.log, too?

I think you have too many mice in your running X, there is /dev/input/mice,
which is supposed to gather all mouse data, as well as /dev/psaux (which is
included in /dev/input/mice, as far as I know). Remove the psaux device and
see if it still happens. The data is reported twice so I guess your mouse
might also move twice as fast and generate double clicks.

Maybe hotplugging is involved too, if you use hal-0.5.10.

Sascha
 
Old 01-15-2008, 09:51 AM
"Michael Schmarck"
 
Default Single click is interpreted as double click

Hello!

On Jan 15, 2008 10:16 AM, Sascha Hlusiak <saschahlusiak@arcor.de> wrote:

> > Yesterday, I upgraded to xorg-server 1.4 from 1.3. I also recompiled
> > all the x11-drivers packages, including xf86-input-mouse-1.2.3.
> >
> > Today, I started Xorg 1.4 for the 1st time. When I now single click
> > something, the system seems to get a double click. Examples:
> >
>
> > I uploaded my Xorg.conf to <http://pastebin.ca/855818>. I used the
> > exact same Xorg.conf with xorg-server-1.3, and there a single click
> > wasn't "misinterpreted".
> >
>
> > I'm using a very simple Dell branded Logitech Optical USB Mouse
> > via USB.
> >
> > What might be broken there?
> Can you paste your /var/log/Xorg.0.log, too?

Sure. It's attached to this mail.

> I think you have too many mice in your running X, there is /dev/input/mice,
> which is supposed to gather all mouse data, as well as /dev/psaux (which is
> included in /dev/input/mice, as far as I know).

You mean the Identifier "Logitech LX7" and "USB Maus", correct?
This used to work fine, but I'll give that a try and report back!

> Remove the psaux device and
> see if it still happens. The data is reported twice so I guess your mouse
> might also move twice as fast and generate double clicks.

It seems like, that the system thinks that the left mouse button
is always pressed, or something like that. For example, in
Knode, I cannot right click on a group and get the context menu
displayed. It is, as if the left button is pressed always.

> Maybe hotplugging is involved too, if you use hal-0.5.10.

I've got hal-0.5.10 installed. But that as well doesn't cause
any problems in Xorg 1.3.0.0. I just verified this, by downgrading
to 1.3.0.0 - there, everything is well!

Michael
 
Old 01-15-2008, 10:07 AM
"Michael Schmarck"
 
Default Single click is interpreted as double click

Hello again.

On Jan 15, 2008 11:51 AM, Michael Schmarck
<michael.schmarck@habmalnefrage.de> wrote:
> On Jan 15, 2008 10:16 AM, Sascha Hlusiak <saschahlusiak@arcor.de> wrote:

> > > Yesterday, I upgraded to xorg-server 1.4 from 1.3. I also recompiled
> > > all the x11-drivers packages, including xf86-input-mouse-1.2.3.
> > >
> > > Today, I started Xorg 1.4 for the 1st time. When I now single click
> > > something, the system seems to get a double click. Examples:
> > >
> >
> > > I uploaded my Xorg.conf to <http://pastebin.ca/855818>. I used the
> > > exact same Xorg.conf with xorg-server-1.3, and there a single click
> > > wasn't "misinterpreted".
> > >
> >
> > > I'm using a very simple Dell branded Logitech Optical USB Mouse
> > > via USB.
> > >
> > > What might be broken there?

[...]

> > I think you have too many mice in your running X, there is /dev/input/mice,
> > which is supposed to gather all mouse data, as well as /dev/psaux (which is
> > included in /dev/input/mice, as far as I know).
>
> You mean the Identifier "Logitech LX7" and "USB Maus", correct?
> This used to work fine, but I'll give that a try and report back!

I now commented the Logitech LX7 entry in the layout
section of my xorg.conf and also commented out the LX7
all together. Please see <http://pastebin.ca/855885>
for an updated version of my xorg.conf, which I attached
as well. I also attached a new Xorg.0.log.

Best regards,
Michael
 
Old 01-15-2008, 04:45 PM
Sascha Hlusiak
 
Default Single click is interpreted as double click

> > > I think you have too many mice in your running X, there is
> > > /dev/input/mice, which is supposed to gather all mouse data, as well as
> > > /dev/psaux (which is included in /dev/input/mice, as far as I know).
> >
> > You mean the Identifier "Logitech LX7" and "USB Maus", correct?
> > This used to work fine, but I'll give that a try and report back!
>
> I now commented the Logitech LX7 entry in the layout
> section of my xorg.conf and also commented out the LX7
> all together. Please see <http://pastebin.ca/855885>
> for an updated version of my xorg.conf, which I attached
> as well. I also attached a new Xorg.0.log.
Still the USB Mouse is added twice, most likely by hal/hotplugging.

hal-0.5.10 introduced support for telling xorg what to hotplug.
xorg-server-1.4 introduced support of hal hotplugging (triggered with the hal
use flag), so both together hotplug mice! See in the logfile at the end, it
says which devices are evaluated and added. To keep it short, just disable
hotplugging in xorg by adding:

Option "AutoAddDevices" "false"

to Section ServerFlags. Then good ol' xorg.conf alone is used.


Sascha
 
Old 01-16-2008, 06:17 AM
"Michael Schmarck"
 
Default Single click is interpreted as double click

Hello again!

On Jan 15, 2008 6:45 PM, Sascha Hlusiak <saschahlusiak@arcor.de> wrote:

> says which devices are evaluated and added. To keep it short, just disable
> hotplugging in xorg by adding:
>
> Option "AutoAddDevices" "false"
>
> to Section ServerFlags. Then good ol' xorg.conf alone is used.

I did that (see attached files), but that also was of no help

Too bad... :/

Thanks for the time you spent so far!

Michael
 
Old 01-16-2008, 08:18 AM
Sascha Hlusiak
 
Default Single click is interpreted as double click

Hello,

Am Mittwoch 16 Januar 2008 08:17:52 schrieb Michael Schmarck:
> Hello again!
>
> On Jan 15, 2008 6:45 PM, Sascha Hlusiak <saschahlusiak@arcor.de> wrote:
> > says which devices are evaluated and added. To keep it short, just
> > disable hotplugging in xorg by adding:
> >
> > Option "AutoAddDevices" "false"
> >
> > to Section ServerFlags. Then good ol' xorg.conf alone is used.
>
> I did that (see attached files), but that also was of no help
>
> Too bad... :/
>
> Thanks for the time you spent so far!
(==) |-->Input Device "USB Maus"
(==) The core pointer device wasn't specified explicitly in the layout.
Using the first mouse device.

What if you now change the
InputDevice "USB Maus" "SendCoreEvents"
to
InputDevice "USB Maus" "CorePointer"
?


Sascha
 
Old 01-16-2008, 08:41 AM
Michael Schmarck
 
Default Single click is interpreted as double click

Sascha Hlusiak wrote:
>
>
> What if you now change the
> InputDevice "USB Maus" "SendCoreEvents"
> to
> InputDevice "USB Maus" "CorePointer"
> ?
>

YEAH!

That solved it. I can now single click again.

Most excellent.

Thanks a lot!

-----
--
Michael Schmarck
michael.schmarck@habmalnefrage.de
--
View this message in context: http://www.nabble.com/Single-click-is-interpreted-as-double-click-tp14834025p14875978.html
Sent from the gentoo-user mailing list archive at Nabble.com.

--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 01:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org