FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-27-2010, 09:42 AM
Dale
 
Default emerge --keep-going but it doesn't

Hi folks.

I'm doing a fresh install onto another hard drive. Just felt like doing
a fresh one instead of copying. Anyway, I got most everything
installed. I was doing my last set of installs, things like seamonkey,
firefox, pigdin, gtkam and all the other programs I use for this and
that. I did copy my old make.conf over from the old install. I have
the --keep-going option in there. Who wants to start a LARGE emerge to
have it stop for some package that isn't a big deal?


I'm sure people have heard of googleearth and the file size mismatch
problem. I thought it was fixed since I have not had the issue in a
good while. Anyway, it appears it wasn't fixed. Portage stopped
because of this package and while it should be finished, it now has
about another 7 hours of compile time.


Can someone explain to me why it stopped instead of finishing with the
other packages? Googleearth is not a library and nothing else depends
on it either. It failing is not a issue. I would much rather portage
to have emerged the rest then told me googleearth was having its usual
bad hair day.


Is there another option I can use that I don't know about?

Thanks.

Dale

:-) :_)
 
Old 05-27-2010, 12:18 PM
walt
 
Default emerge --keep-going but it doesn't

On 05/27/2010 02:42 AM, Dale wrote:

Hi folks.

I'm doing a fresh install onto another hard drive. Just felt like doing a fresh
one instead of copying. Anyway, I got most everything installed. I was doing my
last set of installs, things like seamonkey, firefox, pigdin, gtkam and all the

> other programs I use for this and that. I did copy my old make.conf over from the
> old install. I have the --keep-going option in there.

Hm. Does it work if you use the --keep-going option on the command line instead
of in make.conf?
 
Old 05-27-2010, 02:39 PM
Dale
 
Default emerge --keep-going but it doesn't

walt wrote:

On 05/27/2010 02:42 AM, Dale wrote:

Hi folks.

I'm doing a fresh install onto another hard drive. Just felt like
doing a fresh
one instead of copying. Anyway, I got most everything installed. I
was doing my
last set of installs, things like seamonkey, firefox, pigdin, gtkam
and all the
> other programs I use for this and that. I did copy my old make.conf
over from the

> old install. I have the --keep-going option in there.

Hm. Does it work if you use the --keep-going option on the command
line instead

of in make.conf?




I haven't tried that. Your suggestion made me think of something to
look at tho. I checked the logs since it records what is being done and
the options. I noticed this:


1274924669: *** emerge --with-bdeps --ask --verbose --buildpkg
seamonkey gkrellm hddtemp kbackup k3b tkdvd myspell-en screen uptimed
scribus autounmask elogv elogviewer flagedit mirrorselect pfl porthole
gimp gtkam hugin alsamixergui avidemux smplayer iftop nettop traceroute
wireshark pppconfig wvdial iptables pidgin ntp whois hplip
http-replicator googleearth hdparm hwinfo lshw smartmontools dosfstools
shake sys-power/nut htop iotop lsof links mozilla-firefox adobe-flash
gecko-mediaplayer mesa-progs gkrellm-themes

1274924866: >>> emerge (1 of 137) sys-fs/sysfsutils-2.1.0 to /

So, emerge picks up on the others but not that one. I then moved it
from one section in make.conf and put it in the other. Now it sees the
option. I guess it was in the wrong place. For the record, I had it in
FEATURES and moved it to the EMERGE_DEFAULT_OPTS. I guess the last one
is where it is supposed to be. I may have copied it to the wrong place
since portage would never move things in make.conf. I need better
glasses. lol Funny that emerge didn't print a error tho.


Thanks for shining a light in the dark tunnel.

Dale

:-) :-)
 
Old 05-27-2010, 11:23 PM
walt
 
Default emerge --keep-going but it doesn't

On 05/27/2010 07:39 AM, Dale wrote:

walt wrote:

On 05/27/2010 02:42 AM, Dale wrote:

Hi folks.

I'm doing a fresh install onto another hard drive. Just felt like doing a fresh
one instead of copying. Anyway, I got most everything installed. I was doing my
last set of installs, things like seamonkey, firefox, pigdin, gtkam and all the

> other programs I use for this and that. I did copy my old make.conf over from the
> old install. I have the --keep-going option in there.

Hm. Does it work if you use the --keep-going option on the command line instead
of in make.conf?



I then moved it from one section in make.conf and put it in the other. Now it sees

> the option. I guess it was in the wrong place. For the record, I had it in FEATURES
> and moved it to the EMERGE_DEFAULT_OPTS.

Augh! Why didn't you tell me that years ago? I would have been using that trick
myself all this time.
 
Old 05-28-2010, 12:49 AM
Dale
 
Default emerge --keep-going but it doesn't

walt wrote:

On 05/27/2010 07:39 AM, Dale wrote:

walt wrote:

On 05/27/2010 02:42 AM, Dale wrote:

Hi folks.

I'm doing a fresh install onto another hard drive. Just felt like
doing a fresh
one instead of copying. Anyway, I got most everything installed. I
was doing my
last set of installs, things like seamonkey, firefox, pigdin, gtkam
and all the
> other programs I use for this and that. I did copy my old
make.conf over from the

> old install. I have the --keep-going option in there.

Hm. Does it work if you use the --keep-going option on the command
line instead

of in make.conf?


I then moved it from one section in make.conf and put it in the
other. Now it sees
> the option. I guess it was in the wrong place. For the record, I had
it in FEATURES

> and moved it to the EMERGE_DEFAULT_OPTS.

Augh! Why didn't you tell me that years ago? I would have been using
that trick

myself all this time.




If I knew you needed to know, I would have told you. I wish there was a
mailing list that only had changes being made to portage. New features
and options that we don't know about. Reading the man page just doesn't
get it for me. Sometimes I read the man page but just don't quite have
that light bulb moment.


I think I actually read about that on this list. Someone else was doing
a emerge -e world after really borking something and had frequent
compile failures. I think he was trying to change the CHOST or
something. I remember it was a huge mess.


Sorry I didn't know but will try to do better next time. < Dale gets his
crystal ball out >


Dale

:-) :-)
 

Thread Tools




All times are GMT. The time now is 11:23 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org