FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-11-2010, 04:59 AM
"Kevin O'Gorman"
 
Default Gentoo decapitated

About a week ago, my Gentoo box was in a bad state where there were some packages that would not install, so I was carefully emerging what I could and filed a bug about one in particular that I could not emerge.

Then I got a new kernel, 2.6.32-gentoo-r7, and I booted from it.* Eeeek. No X11 at all.

The logs informed me about some things to do, and I did them, re-emerging a number of things.* I paid particular attention to emerging anything with x11 or xorg in its name.
Long wait.
I got to a point somewhere in there where X11 started, but would recognize neither keyboard nor mouse.

I kept going.* The keyboard started to work.* I could actually log in, but that's not all that useful without a mouse.
Then I started getting complaints about USE flags needed to make some particular packages support some other packages.* I did those too.
Now I'm at the state where "emerge -aDNvu" denies there's any work to do, and revdep-rebuild reports health.
Still no mouse.
Fortunately, I have a laptop that can ssh into the box and I can work with it, but it's still essentially headless.

Anybody run into this state recently?*
If there's a quick fix, I'd rather not make another bug.
--
Kevin O'Gorman, PhD
 

Thread Tools




All times are GMT. The time now is 02:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org