FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-07-2010, 09:36 PM
Jim Cunning
 
Default Cannot emerge x11-libs/qt-webkit-4.6.2-r1

For the last week or perhaps more, I have been unable to complete an emerge
update of world because x11-libs/qt-webkit-4.6.2-r1 fails. I now have just
the following ebuilds that cannot finish because of qt-webkit:

Calculating dependencies... done!
[ebuild U ] x11-libs/qt-webkit-4.6.2-r1 [4.6.2] USE="dbus%* exceptions kde
(-aqua) -debug -pch" 0 kB
[ebuild U ] kde-base/ksplash-4.4.2-r1 [4.4.2] USE="mmx sse sse2 -3dnow (-
altivec) (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -xinerama" 0 kB
[ebuild R ] kde-base/libplasmagenericshell-4.4.2 USE="(-aqua) -debug (-
kdeenablefinal) (-kdeprefix) -test%" 0 kB
[ebuild U ] kde-base/systemsettings-4.4.2-r1 [4.4.2] USE="handbook opengl
usb (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -xinerama" 0 kB
[ebuild U ] app-cdr/k3b-1.91.0_rc2 [1.70.0_beta1] USE="dvd encode flac
handbook%* mad vorbis wav (-aqua) -debug -emovix -ffmpeg (-kdeenablefinal) -
lame -musepack -musicbrainz -sndfile -sox -taglib -vcd" LINGUAS="fr%* -ast% -
be% -bg% -ca% -ca@valencia% -cs% -csb% -da% -de% -el% -en_GB% -eo% -es% -et% -
eu% -fi% -ga% -gl% -he% -hi% -hne% -hr% -hu% -is% -it% -ja% -km% -ko% -ku% -
lt% -mai% -nb% -nds% -nl% -nn% -oc% -pa% -pl% -pt% -pt_BR% -ro% -ru% -se% -sk%
-sl% -sv% -th% -tr% -uk% -zh_CN% -zh_TW%" 0 kB

Total: 5 packages (4 upgrades, 1 reinstall), Size of downloads: 0 kB

Near the end of the emerge, the following error occurs:

compiling .rcc/release-shared/qrc_WebKit.cpp
rm -f libQtWebKit.so.4.6.2 libQtWebKit.so libQtWebKit.so.4 libQtWebKit.so.4.6
linking ../../../../lib/libQtWebKit.so.4.6.2
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../x86_64-pc-linux-
gnu/bin/ldbj/release/HTMLParser.o: file format not recognized; treating as
linker script
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../x86_64-pc-linux-
gnu/bin/ldbj/release/HTMLParser.o:1: syntax error
collect2: ld returned 1 exit status
make: *** [../../../../lib/libQtWebKit.so.4.6.2] Error 1
* ERROR: x11-libs/qt-webkit-4.6.2-r1 failed:
* emake failed

There was a thread on gentoo forums with this very error listed as solved
(https://forums.gentoo.org/viewtopic.php?p=6262495), but the ccache solution
suggested there has no effect on my experience of the problem. Anyone have a
suggestion on how to proceed?

Thanks,
--
Jim
 

Thread Tools




All times are GMT. The time now is 09:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org