FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-05-2010, 08:41 PM
Grant
 
Default new user can't run X apps

I created a new user with useradd but I get X errors like "cannot open
display" and "cannot connect to X server" when I try to run X apps as
the new user. I've tried restarting with the same results. Does
anyone know why this is happening?

- Grant
 
Old 05-05-2010, 08:51 PM
"Arttu V."
 
Default new user can't run X apps

On 5/5/10, Grant <emailgrant@gmail.com> wrote:
> I created a new user with useradd but I get X errors like "cannot open
> display" and "cannot connect to X server" when I try to run X apps as
> the new user. I've tried restarting with the same results. Does
> anyone know why this is happening?

Is the user in the video group?

--
Arttu V.
 
Old 05-05-2010, 09:02 PM
Grant
 
Default new user can't run X apps

>> I created a new user with useradd but I get X errors like "cannot open
>> display" and "cannot connect to X server" when I try to run X apps as
>> the new user. *I've tried restarting with the same results. *Does
>> anyone know why this is happening?
>
> Is the user in the video group?

Yes, I should have said that.

- Grant
 
Old 05-05-2010, 11:14 PM
"Arttu V."
 
Default new user can't run X apps

On 5/6/10, Grant <emailgrant@gmail.com> wrote:
>>> I created a new user with useradd but I get X errors like "cannot open
>>> display" and "cannot connect to X server" when I try to run X apps as
>>> the new user. I've tried restarting with the same results. Does
>>> anyone know why this is happening?
>>
>> Is the user in the video group?
>
> Yes, I should have said that.

How have you set up the X session for the users? Is it specified,
e.g., in /etc/env.d/90xsession or in some user-specific configuration
files that only the other one would have?

Does anything exceptional appear in Xorg.log?

(As you can notice, I'm just guessing and shooting in the dark here.)

--
Arttu V.
 
Old 05-27-2010, 11:29 AM
David Relson
 
Default new user can't run X apps

On Wed, 5 May 2010 13:41:19 -0700
Grant wrote:

> I created a new user with useradd but I get X errors like "cannot open
> display" and "cannot connect to X server" when I try to run X apps as
> the new user. I've tried restarting with the same results. Does
> anyone know why this is happening?
>
> - Grant

Have you tried strace? It'll help tell what the app is doing just
before the "cannot open ..." message is displayed.

HTH,

David
 
Old 05-27-2010, 11:14 PM
walt
 
Default new user can't run X apps

On 05/05/2010 01:41 PM, Grant wrote:

I created a new user with useradd but I get X errors like "cannot open
display" and "cannot connect to X server" when I try to run X apps as
the new user...


Are you also using X as yourself at the same time newuser is trying
to use X?
 

Thread Tools




All times are GMT. The time now is 09:17 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org