FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-04-2010, 04:16 AM
Grant Edwards
 
Default libdb no longer slotted?

It seems that sys-libs/db used to be slotted (I previously had 3 or 4
versions installed). But todays update is failing becuase Python wants
libdb-4.7 and Perl wants libdb-4.3. They won't both install because of
file collisions.

Is libdb no longer slotted?

How does one deal with applications that require different versions of
libdb?

Neither google nor bugzilla have been helpful...



>>> Failed to install sys-libs/db-4.3.29_p1-r1, Log file:

>>> '/var/tmp/portage/sys-libs/db-4.3.29_p1-r1/temp/build.log'

* Messages for package sys-libs/db-4.3.29_p1-r1:

* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* Detected file collision(s):
*
* /usr/bin/db_archive
* /usr/bin/db_checkpoint
* /usr/bin/db_deadlock
* /usr/bin/db_dump
* /usr/bin/db_load
* /usr/bin/db_printlog
* /usr/bin/db_recover
* /usr/bin/db_stat
* /usr/bin/db_upgrade
* /usr/bin/db_verify
*
* Searching all installed packages for file collisions...
*
* Press Ctrl-C to Stop
*
* sys-libs/db-4.7.25_p4
* /usr/bin/db_archive
* /usr/bin/db_checkpoint
* /usr/bin/db_deadlock
* /usr/bin/db_dump
* /usr/bin/db_load
* /usr/bin/db_printlog
* /usr/bin/db_recover
* /usr/bin/db_stat
* /usr/bin/db_upgrade
* /usr/bin/db_verify
*
* Package 'sys-libs/db-4.3.29_p1-r1' NOT merged due to file collisions.
* If necessary, refer to your elog messages for the whole content of the
* above message.
 
Old 05-04-2010, 10:32 AM
Helmut Jarausch
 
Default libdb no longer slotted?

On 4 May, Grant Edwards wrote:
> It seems that sys-libs/db used to be slotted (I previously had 3 or 4
> versions installed). But todays update is failing becuase Python wants
> libdb-4.7 and Perl wants libdb-4.3. They won't both install because of
> file collisions.
>
> Is libdb no longer slotted?
>
> How does one deal with applications that require different versions of
> libdb?
>

First, sys-libs/db is still slotted, of course
eix -n sys-libs/db
gives
[i] sys-libs/db
Available versions:
(1) 1.85-r3
(3) 3.2.9-r11 3.2.9_p2
(4.2) 4.2.52_p4-r2 (~)4.2.52_p5 4.2.52_p5-r1
(4.3) 4.3.29-r2 (~)4.3.29_p1 4.3.29_p1-r1
(4.4) (~)4.4.20_p4 (~)4.4.20_p4-r1
(4.5) 4.5.20_p2 4.5.20_p2-r1{tbz2}
(4.6) 4.6.21_p4{tbz2}
(4.7) (~)4.7.25_p3 4.7.25_p4{tbz2}
(4.8) (~)4.8.24 (~)4.8.26 (~)4.8.30{tbz2}
{doc elibc_FreeBSD examples java nocxx tcl test}
Installed versions: 1.85-r3(1)(12:35:43 PM 07/16/2008) 4.5.20_p2-r1(4.5){tbz2}(05:36:16 PM 04/01/2009)(tcl -doc -elibc_FreeBSD -java -nocxx -test) 4.6.21_p4(4.6){tbz2}(04:06:48 PM 03/23/2009)(tcl -doc -elibc_FreeBSD -java -nocxx -test) 4.7.25_p4(4.7){tbz2}(02:58:36 PM 06/22/2009)(tcl -doc -elibc_FreeBSD -java -nocxx -test) 4.8.30(4.8){tbz2}(09:52:24 AM 05/04/2010)(tcl -doc -elibc_FreeBSD -examples -java -nocxx -test)

Trying
for S in 1 4.5 4.6 4.7 4.8; do
emerge -vpc sys-libs/db:$S
done

shows that here python-2.6.5-r2 uses 4.7 while perl-5.10.1 uses 4.8
and my system is running quite happily (at least, I think so)

Helmut.

--
Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany
 
Old 05-04-2010, 02:23 PM
Daniel Pielmeier
 
Default libdb no longer slotted?

2010/5/4 Grant Edwards <grant.b.edwards@gmail.com>:
> Is libdb no longer slotted?

This is bug #318367 [1]. It looks like the issue is already fixed in
the tree. So just sync your portage tree and the error should be gone.

[1] http://bugs.gentoo.org/318367

--
Daniel Pielmeier
 
Old 05-04-2010, 02:43 PM
Grant Edwards
 
Default libdb no longer slotted?

On 2010-05-04, Helmut Jarausch <jarausch@igpm.rwth-aachen.de> wrote:
> On 4 May, Grant Edwards wrote:
>> It seems that sys-libs/db used to be slotted (I previously had 3 or 4
>> versions installed). But todays update is failing becuase Python wants
>> libdb-4.7 and Perl wants libdb-4.3. They won't both install because of
>> file collisions.
>>
>> Is libdb no longer slotted?
>>
>> How does one deal with applications that require different versions of
>> libdb?
>>
>
> First, sys-libs/db is still slotted, of course
> eix -n sys-libs/db
> gives
> [i] sys-libs/db
> Available versions:
> (1) 1.85-r3
> (3) 3.2.9-r11 3.2.9_p2
> (4.2) 4.2.52_p4-r2 (~)4.2.52_p5 4.2.52_p5-r1
> (4.3) 4.3.29-r2 (~)4.3.29_p1 4.3.29_p1-r1
> (4.4) (~)4.4.20_p4 (~)4.4.20_p4-r1
> (4.5) 4.5.20_p2 4.5.20_p2-r1{tbz2}
> (4.6) 4.6.21_p4{tbz2}
> (4.7) (~)4.7.25_p3 4.7.25_p4{tbz2}
> (4.8) (~)4.8.24 (~)4.8.26 (~)4.8.30{tbz2}
> {doc elibc_FreeBSD examples java nocxx tcl test}
> Installed versions: 1.85-r3(1)(12:35:43 PM 07/16/2008) 4.5.20_p2-r1(4.5){tbz2}(05:36:16 PM 04/01/2009)(tcl -doc -elibc_FreeBSD -java -nocxx -test) 4.6.21_p4(4.6){tbz2}(04:06:48 PM 03/23/2009)(tcl -doc -elibc_FreeBSD -java -nocxx -test) 4.7.25_p4(4.7){tbz2}(02:58:36 PM 06/22/2009)(tcl -doc -elibc_FreeBSD -java -nocxx -test) 4.8.30(4.8){tbz2}(09:52:24 AM 05/04/2010)(tcl -doc -elibc_FreeBSD -examples -java -nocxx -test)

Yes, that's what I saw before the latest update.

> Trying
> for S in 1 4.5 4.6 4.7 4.8; do
> emerge -vpc sys-libs/db:$S
> done

No matter what order I do that in, the second one always fails because
of file collisions.

> shows that here python-2.6.5-r2 uses 4.7 while perl-5.10.1 uses 4.8
> and my system is running quite happily (at least, I think so)

I wonder what happened to mine...

--
Grant Edwards grant.b.edwards Yow! I'm shaving!!
at I'M SHAVING!!
gmail.com
 
Old 05-04-2010, 02:47 PM
Grant Edwards
 
Default libdb no longer slotted?

On 2010-05-04, Daniel Pielmeier <billie@gentoo.org> wrote:
> 2010/5/4 Grant Edwards <grant.b.edwards@gmail.com>:
>> Is libdb no longer slotted?
>
> This is bug #318367 [1]. It looks like the issue is already fixed in
> the tree. So just sync your portage tree and the error should be gone.
>
> [1] http://bugs.gentoo.org/318367

That wasn't there when I searched last night -- I was starting to
think it was just me...

--
Grant Edwards grant.b.edwards Yow! I've got an IDEA!!
at Why don't I STARE at you
gmail.com so HARD, you forget your
SOCIAL SECURITY NUMBER!!
 

Thread Tools




All times are GMT. The time now is 05:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org