FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-10-2008, 06:22 PM
"b.n."
 
Default expat update (was:Update After a Year)

Neil Bothwick ha scritto:
> The expat upgrade was less than a year ago for stable systems.

Sorry if hijacking the thread, but: it's a long time I have expat-1.9.6
and, even if 2.0.1 is in portage, emerge -av world doesn't tell me to
upgrade (I guess emerge -Dav would, but why should I?). Should I do
nonetheless, or can I wait?

m.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 01-10-2008, 06:39 PM
Neil Bothwick
 
Default expat update (was:Update After a Year)

On Thu, 10 Jan 2008 20:22:06 +0100, b.n. wrote:

> Sorry if hijacking the thread, but: it's a long time I have expat-1.9.6
> and, even if 2.0.1 is in portage, emerge -av world doesn't tell me to
> upgrade (I guess emerge -Dav would, but why should I?). Should I do
> nonetheless, or can I wait?

If portage isn't forcing you to install it, you don't need it. On the
other hand, it is a bit of a pain to update, so you may as well get it
over with when you know you have the time to deal with it.


--
Neil Bothwick

"Do you reply to our surveys.?"
[X]Never [ ]Always [ ]Sometimes
 
Old 01-11-2008, 05:49 AM
Alan McKinnon
 
Default expat update (was:Update After a Year)

On Thursday 10 January 2008, b.n. wrote:
> Neil Bothwick ha scritto:
> > The expat upgrade was less than a year ago for stable systems.
>
> Sorry if hijacking the thread, but: it's a long time I have
> expat-1.9.6 and, even if 2.0.1 is in portage, emerge -av world
> doesn't tell me to upgrade (I guess emerge -Dav would, but why should
> I?). Should I do nonetheless, or can I wait?

I find emerge -uND world every so often is a good idea, as updates are
then incremental and I can deal with problems one at a time instead of
lots all at once.

I don't know of any good reason why you *should* upgrade to expat-2.0.1
right now, other than simply staying up to date. Be prepared to become
good friends with revdep-rebuild when you *do* do it, the upgrade
caused huge numbers of broken linkages to libexpat.so.0

alan


--
Alan McKinnon
alan dot mckinnon at gmail dot com
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 08:39 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org