FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-09-2010, 11:14 AM
Peter Humphrey
 
Default Kompozer

Hello list,

Has anyone here got kompozer to build on a Gentoo ~amd64 box? I did have
a version running some months ago and I've tried to upgrade it but
failed. The compiled versions require old libs that aren't installed
here and the source needs some incantation I haven't found yet.

I use Bluefish for HTML maintenance, but kompozer is useful for
developing CSS.

Thanks for any tips.

--
Rgds
Peter.
 
Old 03-09-2010, 01:05 PM
Neil Walker
 
Default Kompozer

On 09/03/10 12:14, Peter Humphrey wrote:
> Has anyone here got kompozer to build on a Gentoo ~amd64 box?

I have kompozer-0.8_beta1 running on this box which is amd64 but
quite a long list in /etc/portage/package.keywords.


Be lucky,

Neil
http://www.neiljw.com/
 
Old 03-09-2010, 02:41 PM
Peter Humphrey
 
Default Kompozer

On Tuesday 09 March 2010 14:05:03 Neil Walker wrote:

> I have kompozer-0.8_beta1 running on this box which is amd64 but
> quite a long list in /etc/portage/package.keywords.

Well, as this box is ~amd64 I shouldn't need any of those. But kompozer
isn't in portage as far as I can see, so how did you get it installed?

--
Rgds
Peter.
 
Old 03-09-2010, 07:56 PM
Neil Walker
 
Default Kompozer

On 09/03/10 15:41, Peter Humphrey wrote:
>> I have kompozer-0.8_beta1 running on this box which is amd64 but
>> quite a long list in /etc/portage/package.keywords.
>>
> Well, as this box is ~amd64 I shouldn't need any of those. But kompozer
> isn't in portage as far as I can see, so how did you get it installed?
>

I got an ebuild somewhere, probably bugzilla. If you want a copy, I've
put it on http://www.neiljw.net/kompozer-0.8_beta1.ebuild.


Be lucky,

Neil
http://www.neiljw.net/
 
Old 03-09-2010, 08:53 PM
Neil Walker
 
Default Kompozer

On 09/03/10 20:56, Neil Walker wrote:
> If you want a copy, I've put it on http://www.neiljw.net/kompozer-0.8_beta1.ebuild
>

Hehe. It seems a few people wanted that but I did see a couple of
http 404s in the logs. That's because you included the full stop.


Be lucky,

Neil
http://www.neiljw.net/
 
Old 03-10-2010, 12:13 AM
Peter Humphrey
 
Default Kompozer

On Tuesday 09 March 2010 20:56:04 Neil Walker wrote:

> I got an ebuild somewhere, probably bugzilla. If you want a copy,
> I've put it on http://www.neiljw.net/kompozer-0.8_beta1.ebuild.

Thanks Neil. I'll have a look at it in the morning. Or maybe the
afternoon, remembering some unfortunate incidents recently when I hadn't
woken up properly (Hello Neil B.)

--
Rgds
Peter.
 
Old 03-12-2010, 10:21 PM
Peter Humphrey
 
Default Kompozer

On Tuesday 09 March 2010 20:56:04 Neil Walker wrote:
> On 09/03/10 15:41, Peter Humphrey wrote:
> >> I have kompozer-0.8_beta1 running on this box which is amd64 but
> >> quite a long list in /etc/portage/package.keywords.
> >
> > Well, as this box is ~amd64 I shouldn't need any of those. But
> > kompozer isn't in portage as far as I can see, so how did you get
> > it installed?
>
> I got an ebuild somewhere, probably bugzilla. If you want a copy,
> I've put it on http://www.neiljw.net/kompozer-0.8_beta1.ebuild.

I tried this just now. I saved your ebuild as /usr/local/portage/app-
editors/kompozer/kompozer-0.8_beta1.ebuild, then ran ebuild [...]
manifest on it, then tried to emerge it. I got this configuration error:

configure: error: --enable-application=APP is required

which I've seen before when trying to compile this program. I didn't
manage to solve it then, and i haven't this time either.

Any clues? Thanks for the help so far.

--
Rgds
Peter.
 
Old 03-13-2010, 07:27 AM
Neil Walker
 
Default Kompozer

On 12/03/10 23:21, Peter Humphrey wrote:

>> I got an ebuild somewhere, probably bugzilla. If you want a copy,
>> I've put it on http://www.neiljw.net/kompozer-0.8_beta1.ebuild.
>>
> I tried this just now. I saved your ebuild as /usr/local/portage/app-
> editors/kompozer/kompozer-0.8_beta1.ebuild, then ran ebuild [...]
> manifest on it, then tried to emerge it. I got this configuration error:
>
> configure: error: --enable-application=APP is required
>
> which I've seen before when trying to compile this program. I didn't
> manage to solve it then, and i haven't this time either.
>
> Any clues? Thanks for the help so far.
>

Sorry about that. It's been a few weeks since I did this and had forgotten
that another file is needed:

http://www.neiljw.net/mozconfig-0.8_beta1

Put that file in the files subdirectory of wherever you have the ebuild then
remake the manifest. The emerge starts with a warning about mozconfig.eclass
but you can just ignore that. Then go read "War and Peace" or something
because it takes a while even on four cores.

Be lucky,

Neil
http://www.neiljw.com
 
Old 03-13-2010, 08:39 AM
Neil Walker
 
Default Kompozer

To those people still trying to download the files, please

note there is NO full stop (period) at the end of the ebuild

filename. The two files you need are:

http://www.neiljw.net/kompozer-0.8_beta1.ebuild

and

http://www.neiljw.net/mozconfig-0.8_beta1



Be lucky,

Neil

http://www.neiljw.com/
 
Old 03-13-2010, 10:40 AM
Peter Humphrey
 
Default Kompozer

On Saturday 13 March 2010 08:27:08 Neil Walker wrote:

> http://www.neiljw.net/mozconfig-0.8_beta1
>
> Put that file in the files subdirectory of wherever you have the
> ebuild then remake the manifest. The emerge starts with a warning
> about mozconfig.eclass but you can just ignore that. Then go read
> "War and Peace" or something because it takes a while even on four
> cores.

Ah. So now it builds ok (18 min here) but when I call "kompozer" from a
command line I get:

/usr/lib/kompozer/run-mozilla.sh: line 131: 13315 Segmentation fault
"$prog" ${1+"$@"}

This is odd, as that line is just the opening curly brace of the
moz_run_program() function.

I notice, though, at the head of the run-mozilla.sh script, this
assignment: MOZ_PROGRAM="". I tried setting this instead to:
MOZ_PROGRAM="./kompozer-bin" but I got the same seg fault (except that
the 13315 had changed to 30525).

I'm near my debugging limit here.

--
Rgds
Peter.
 

Thread Tools




All times are GMT. The time now is 07:48 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org