FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-05-2010, 01:19 PM
Jacques Montier
 
Default equery warnings

Hi all,

While using equery, i get this warning :
"/usr/lib/portage/pym/portage/util/__init__.py:1121: DeprecationWarning:
The 'myroot' parameter for portage.config.getvirtuals() is deprecated
result = lazy_item.func(*pargs, **kwargs)"
Nevertheless equery 's working fine.

Any idea ?
Thank you

Regards

--
Jacques
 
Old 03-05-2010, 08:32 PM
Dale
 
Default equery warnings

chrome://messenger/locale/messengercompose/composeMsgs.properties:

Hi all,

While using equery, i get this warning :
"/usr/lib/portage/pym/portage/util/__init__.py:1121: DeprecationWarning:
The 'myroot' parameter for portage.config.getvirtuals() is deprecated
result = lazy_item.func(*pargs, **kwargs)"
Nevertheless equery 's working fine.

Any idea ?
Thank you

Regards

--
Jacques




Upgrade to the latest gentoolkit.

[IP-] [ ] app-portage/gentoolkit-0.3.0_rc9:

I had the same error and the problem appears to be that I had portage in
keyword/unmask but not gentoolkit. There appears to be a mismatch for
this version. After I updated to the version above, it works fine. The
latest portage and the latest gentoolkit likes each other and no more
error message.


Hope that helps.

Dale

:-) :--)
 
Old 03-06-2010, 10:45 AM
Jacques Montier
 
Default equery warnings

Le 05/03/2010 22:32, Dale a gentiment tapote:
> chrome://messenger/locale/messengercompose/composeMsgs.properties:
>> Hi all,
>>
>> While using equery, i get this warning :
>> "/usr/lib/portage/pym/portage/util/__init__.py:1121: DeprecationWarning:
>> The 'myroot' parameter for portage.config.getvirtuals() is deprecated
>> result = lazy_item.func(*pargs, **kwargs)"
>> Nevertheless equery 's working fine.
>>
>> Any idea ?
>> Thank you
>>
>> Regards
>>
>> --
>> Jacques
>>
>>
>
> Upgrade to the latest gentoolkit.
>
> [IP-] [ ] app-portage/gentoolkit-0.3.0_rc9:
>
> I had the same error and the problem appears to be that I had portage
> in keyword/unmask but not gentoolkit. There appears to be a mismatch
> for this version. After I updated to the version above, it works
> fine. The latest portage and the latest gentoolkit likes each other
> and no more error message.
>
> Hope that helps.
>
> Dale
>
> :-) :--)
>
>
>
>

Thank you Dale,
Now it works fine !

Regards,


Jacques
 

Thread Tools




All times are GMT. The time now is 09:36 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org