FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-16-2010, 07:45 PM
Philip Webb
 
Default copy-paste no longer works with (g)vim + OpenOffice

I have updated to the latest stable (G)vim 7.2.303
& suddenly can no longer copy+paste from Vim into Open Office:
it doesn't work at all with Gvim & unpredictably with Vim in a Konsole.
I can copy+paste from Most in a Konsole to Open Office as usual.
This is on the Fluxbox desktop with Unicode & a generally reliable system.
I've checked Gentoo bugs & forum, but there's no sign of the problem.

Has anyone else seen this ? Would anyone care to test it ?
Could anyone tell me what other pgms/pkgs are involved in copy+paste
between different apps on a desktop ? Might it be Poppler ?

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 02-16-2010, 09:51 PM
Willie Wong
 
Default copy-paste no longer works with (g)vim + OpenOffice

On Tue, Feb 16, 2010 at 03:45:30PM -0500, Philip Webb wrote:
> I have updated to the latest stable (G)vim 7.2.303
> & suddenly can no longer copy+paste from Vim into Open Office:
> it doesn't work at all with Gvim & unpredictably with Vim in a Konsole.
> I can copy+paste from Most in a Konsole to Open Office as usual.
> This is on the Fluxbox desktop with Unicode & a generally reliable system.
> I've checked Gentoo bugs & forum, but there's no sign of the problem.

Which copy+paste? The high-light with mouse and middle click to paste
method, or some other one?

Can you copy and paste from (g)vim to another Konsole? To any other
application?

What use-flag did you compile (g)vim with?

>
> Has anyone else seen this ? Would anyone care to test it ?
> Could anyone tell me what other pgms/pkgs are involved in copy+paste
> between different apps on a desktop ? Might it be Poppler ?

Poppler? surely not. Why do you think a PDF renderer would have
anything to do with copy and paste?

W
--
Willie W. Wong wwong@math.princeton.edu
Data aequatione quotcunque fluentes quantitae involvente fluxiones invenire
et vice versa ~~~ I. Newton
 
Old 02-17-2010, 10:42 AM
Philip Webb
 
Default copy-paste no longer works with (g)vim + OpenOffice

100216 Willie Wong wrote:
> On Tue, Feb 16, 2010 at 03:45:30PM -0500, Philip Webb wrote:
>> I have updated to the latest stable (G)vim 7.2.303
>> & suddenly can no longer copy+paste from Vim into Open Office:
>> it doesn't work at all with Gvim & unpredictably with Vim in a Konsole.
>> I can copy+paste from Most in a Konsole to Open Office as usual.
>> This is on the Fluxbox desktop with Unicode & a generally reliable system.
> Which copy+paste? high-light with mouse and middle click to paste?

Yes: are there other methods ? -- it also doesn't work
if I high-light with 'v' & the (left-)arrow key(s).

> Can you copy and paste from (g)vim to another Konsole?

Yes, no problem.

> To any other application?

Yes, to Leafpad, Kwrite, (Xfce) Terminal & Xterm.

> What use-flag did you compile (g)vim with?

root:502 ~> eix gvim
[i] app-editors/gvim
Available versions: 7.0.235 ~7.0.243 7.1.123 ~7.1.330 7.2.182 ~7.2.264 7.2.303 ~7.2.359 {acl aqua bash-completion cscope debug gnome gpm gtk motif netbeans nextaw nls perl python ruby}
Installed versions: 7.2.303([2010-02-15 16:38:53])(gpm gtk motif perl python -acl -aqua -bash-completion -cscope -debug -gnome -netbeans -nextaw -nls -ruby)

OO was compiled with :

root:503 ~> eix openoffice
[i] app-office/openoffice
Installed versions: 3.1.1([2010-02-15 15:12:54])(cups dbus gstreamer gtk java kde nsplugin opengl -aqua -bash-completion -binfilter -debug -eds -elibc_FreeBSD -gnome -kdeenablefinal -ldap -linguas_af ... -linguas_zu -mono -odk -pam -templates)

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 02-17-2010, 03:57 PM
Willie Wong
 
Default copy-paste no longer works with (g)vim + OpenOffice

On Wed, Feb 17, 2010 at 06:42:40AM -0500, Philip Webb wrote:
> > Which copy+paste? high-light with mouse and middle click to paste?
>
> Yes: are there other methods ? -- it also doesn't work
> if I high-light with 'v' & the (left-)arrow key(s).

In Gnome at least you can high-light with mouse, right click, hit
copy, and go to another window, right click, and hit paste....

Is visual mode even suppose to work for this purpose? I don't think
hitting v and moving left and right is suppose to dump the selected
sections into the copy-paste buffer.
>
> > Can you copy and paste from (g)vim to another Konsole?
>
> Yes, no problem.
>
> > To any other application?
>
> Yes, to Leafpad, Kwrite, (Xfce) Terminal & Xterm.

So basically the problem is OO then. Can you copy and paste from other
applications to OO?

Perhaps it is a problem with encodings? Years ago I had trouble
occasionally when I try to copy and past stuff from Firefox to Vim in
a rxvt terminal. Then I found out the hiccup is due to 'proper'
apostrophes, commas, and en- and em-dashes. Unicode characters does
not want to be pasted into a non-unicode terminal.

try emerging (if you don't have it installed already) the little
program 'xsel'. You can use it to manipulate the selection buffers.
Try trouble shooting with it to see what the problem is.

http://www.vergenet.net/~conrad/software/xsel/xsel.1x.html

HTH,

W
--
Willie W. Wong wwong@math.princeton.edu
Data aequatione quotcunque fluentes quantitae involvente fluxiones invenire
et vice versa ~~~ I. Newton
 
Old 02-17-2010, 05:18 PM
Philip Webb
 
Default copy-paste no longer works with (g)vim + OpenOffice

100217 Willie Wong wrote:
> On Wed, Feb 17, 2010 at 06:42:40AM -0500, Philip Webb wrote:
>>> Which copy+paste? high-light with mouse and middle click to paste?
>> Yes: are there other methods ? -- it also doesn't work
>> if I high-light with 'v' & the (left-)arrow key(s).
> In Gnome you can high-light with mouse, right click, hit copy
> and go to another window, right click, and hit paste.

I didn't know that one (smile), but only the 1st half works here;
when I R-click in the OO file, there's no 'paste' option
& using the 'paste' button on the toolbar gives
"Requested clipboard format is not available".

> Is visual mode even suppose to work for this purpose?
> I don't think hitting 'v' and moving left and right
> is supposed to dump the selected sections into the copy-paste buffer.

I don't know what it's "supposed" to do, but till last Sunday
it had been regularly doing a paste into OO after a copy w mouse or 'v'.
I didn't update anything else at the same time which seems relevant:
Gzip Java-config Pykde Hplip Gnuconfig Psmisc
(that's why I mentioned Poppler, which I updated the previous week).

>>> Can you copy and paste from (g)vim to another Konsole?
>> Yes, no problem.
>>> To any other application?
>> Yes, to Leafpad, Kwrite, (Xfce) Terminal & Xterm.
> So basically the problem is OO then.

No ! -- there was no change to OO last weekend, only to (G)vim !

> Can you copy and paste from other applications to OO?

Yes, at least from Konsole Terminal Leafpad:
I mentioned the Most+Konsole workaround in my OP.

> Perhaps it is a problem with encodings?

I haven't changed those for a long time, certainly not last weekend.

> HTH

I'm certainly v grateful for your suggestions, but they don't get anywhere.
I assume you don't use both Gvim & OO (7.2.303 & 3.1.1)
or you could test it for yourself: can anyone else test this ?
Does anyone else have useful thoughts ?

If not, it looks like a bug to report.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 02-17-2010, 09:57 PM
Willie Wong
 
Default copy-paste no longer works with (g)vim + OpenOffice

On Wed, Feb 17, 2010 at 01:18:21PM -0500, Philip Webb wrote:
> I didn't know that one (smile), but only the 1st half works here;
> when I R-click in the OO file, there's no 'paste' option
> & using the 'paste' button on the toolbar gives
> "Requested clipboard format is not available".

Okay, so OO does smart pasting where it also treats formatting I
guess. So this is most likely a bug.

> > So basically the problem is OO then.
>
> No ! -- there was no change to OO last weekend, only to (G)vim !

Yes, it is a problem with OO. It is trying to be too smart with the
paste-buffer. Somehow it is not treating the selection as pure text as
it ought to.

Out of curiosity, does this happen for any text file in gvim or only
those with certain file extensions? I assume it is also a problem when
you just open up vim with an empty buffer and type some random junk
and try to copy and paste that?

No, I don't use OO at all, and much as I'd like to help, I'm not about
to try to install *that* on my underpowered netbook. Actually, I don't
even use gvim: vim in a terminal is good enough for me.

Hum, just a thought! Do you have vim compiled with the vim-with-x USE
flag? Try toggling it. Part of the flag is supposed to help behaviour
with interaction against X clipboard.

I am pretty out of ideas otherwise, good luck on your quest, and sorry
for not being more helpful.

Cheers,

W

--
Willie W. Wong wwong@math.princeton.edu
Data aequatione quotcunque fluentes quantitae involvente fluxiones invenire
et vice versa ~~~ I. Newton
 

Thread Tools




All times are GMT. The time now is 07:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org