FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-10-2010, 04:13 PM
James Ausmus
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 8:59 AM, Stroller <stroller@stellar.eclipse.co.uk> wrote:

Hi there,



Upgrading some packages today I saw:



Qt3 is deprecated and unsupported, both upstream and by the Gentoo Qt

Project. x11-libs/qt:3 will be removed from portage soon. See

http://archives.gentoo.org/gentoo-dev/msg_f988855f798764822704bbbd743ab6f7.xml

You are encouraged to use Qt4 instead.



However when I try to resolve this, I find that only 3.3 versions are marked as stable:



$ eix x11-libs/qt$

[i] x11-libs/qt

* * Available versions:

* * * *(3) * * 3.3.8b-r1 3.3.8b-r2

* * * *(4) * * [M]4.5.3 [M]~4.6.1

* * * *{cups dbus debug doc examples firebird immqt immqt-bc ipv6 kde mysql nas nis odbc opengl postgres qt3support sqlite xinerama}

* * Installed versions: *3.3.8b-r2(3)(14:05:56 10/02/10)(cups doc examples -debug -firebird -immqt -immqt-bc -ipv6 -mysql -nas -nis -odbc -opengl -postgres -sqlite -xinerama)

* * Homepage: * * * * * *http://qt.nokia.com/

* * Description: * * * * The Qt toolkit is a comprehensive C++ application development framework



$





Is anyone else seeing this, please?



The message posted to Gentoo-dev suggests that Qt3 is going away right about NOW, but this doesn't seem to add up to what I'm seeing.



Thanks in advance for any comments,



It's monolithic vs. split ebuilds - Qt4 in Gentoo has gone to a modular ebuild system - the monolithic Qt4 build is not supported.

Try:

eix -C x11-libs qt-


HTH-


James

*
Stroller.
 
Old 02-10-2010, 04:30 PM
Mark Knecht
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 8:59 AM, Stroller
<stroller@stellar.eclipse.co.uk> wrote:
> Hi there,
>
> Upgrading some packages today I saw:
>
> Qt3 is deprecated and unsupported, both upstream and by the Gentoo Qt
> Project. x11-libs/qt:3 will be removed from portage soon. See
> http://archives.gentoo.org/gentoo-dev/msg_f988855f798764822704bbbd743ab6f7.xml
> You are encouraged to use Qt4 instead.
>
> However when I try to resolve this, I find that only 3.3 versions are marked
> as stable:
>
> $ eix x11-libs/qt$
> [i] x11-libs/qt
> * * Available versions:
> * * * *(3) * * 3.3.8b-r1 3.3.8b-r2
> * * * *(4) * * [M]4.5.3 [M]~4.6.1
> * * * *{cups dbus debug doc examples firebird immqt immqt-bc ipv6 kde mysql
> nas nis odbc opengl postgres qt3support sqlite xinerama}
> * * Installed versions: *3.3.8b-r2(3)(14:05:56 10/02/10)(cups doc examples
> -debug -firebird -immqt -immqt-bc -ipv6 -mysql -nas -nis -odbc -opengl
> -postgres -sqlite -xinerama)
> * * Homepage: * * * * * *http://qt.nokia.com/
> * * Description: * * * * The Qt toolkit is a comprehensive C++ application
> development framework
>
> $
>
>
> Is anyone else seeing this, please?
>
> The message posted to Gentoo-dev suggests that Qt3 is going away right about
> NOW, but this doesn't seem to add up to what I'm seeing.
>
> Thanks in advance for any comments,
>
> Stroller.
>
>
>

I seem to have them both installed with only my old version of MYthTV
requiring qt-3.3.8

- Mark

firefly distfiles # eix -Ic qt
[i] dev-python/PyQt4 (4.6.2@02/03/10): A set of Python bindings for
the Qt toolkit
[i] virtual/poppler-qt4 (0.12.3-r1@02/04/10): Virtual package,
includes packages that contain libpoppler-qt4.so
[i] x11-libs/qt (3.3.8b-r2(3)@01/30/10): The Qt toolkit is a
comprehensive C++ application development framework
[i] x11-libs/qt-core (4.5.3-r2(4)@01/31/10): The Qt toolkit is a
comprehensive C++ application development framework
[i] x11-libs/qt-dbus (4.5.3-r1(4)@01/31/10): The DBus module for the Qt toolkit
[i] x11-libs/qt-gui (4.5.3-r2(4)@01/31/10): The GUI module for the Qt toolkit
[i] x11-libs/qt-opengl (4.5.3-r1(4)@02/03/10): The OpenGL module for
the Qt toolkit
[i] x11-libs/qt-qt3support (4.5.3(4)@02/02/10): The Qt3 support module
for the Qt toolkit
[i] x11-libs/qt-script (4.5.3-r1(4)@01/31/10): The ECMAScript module
for the Qt toolkit
[i] x11-libs/qt-sql (4.5.3(4)@01/31/10): The SQL module for the Qt toolkit
[i] x11-libs/qt-svg (4.5.3-r1(4)@02/03/10): The SVG module for the Qt toolkit
[i] x11-libs/qt-test (4.5.3-r1(4)@02/03/10): The testing framework
module for the Qt toolkit
[i] x11-libs/qt-webkit (4.5.3(4)@02/03/10): The Webkit module for the Qt toolkit
Found 13 matches.
firefly distfiles # equery depends =x11-libs/qt-3.3.8b-r2
[ Searching for packages depending on =x11-libs/qt-3.3.8b-r2... ]
media-tv/mythtv-0.21_p20877 (>=x11-libs/qt-3.3:3[mysql,opengl])
x11-themes/mythtv-themes-0.21_p16505 (>=x11-libs/qt-3.3:3)
firefly distfiles #
 
Old 02-10-2010, 05:20 PM
Mark Knecht
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 9:33 AM, Neil Bothwick <neil@digimed.co.uk> wrote:
> On Wed, 10 Feb 2010 16:59:16 +0000, Stroller wrote:
>
>> The message posted to Gentoo-dev suggests that Qt3 is going away right
>> about NOW, but this doesn't seem to add up to what I'm seeing.
>
> The message says it will be masked on Feb 21st and removed on March 21st.
> So you have eleven days to add it to package.unmask and nearly six weeks
> before you need to add the kde-sunset overlay. That's assuming the ebuilds
> that depend on QT3 haven't been updated to wiork with QT4, which is
> highly likely as that would require upstream changes for most of them too.
>
> It's a minor inconvenience, but they are giving us a decent warning.
>
>
> --
> Neil Bothwick

So am I at any great risk doing an emerge -C qt-3.3 and then expecting
revdep-rebuild to fix up mythtv-0.21 with qt-4 using whatever it has
ffor qt3-support?

I'm __really__ not ready to upgrade my whole MythTV setup 0.22 if 0.21
requires qt-3 and the qt3 support stuff in qt4 doesn't work. That
would be very painful for me even given 6 weeks.

- Mark
 
Old 02-10-2010, 06:19 PM
Mark Knecht
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 10:46 AM, Neil Bothwick <neil@digimed.co.uk> wrote:
> On Wed, 10 Feb 2010 09:30:19 -0800, Mark Knecht wrote:
>
>> I seem to have them both installed with only my old version of MYthTV
>> requiring qt-3.3.8
>
> That's easy then, switch to MythTV 0.22, it's much better
>
>
> --
> Neil Bothwick

I don't care at all that it's much better. I care that what I have
works and the family doesn't bother me.

My Myth server is PowerPC based and so everytime I switch there's
always things to relearn in terms of updating kernel and risks that
others don't have.

And I cannot update mythfrontend on my desktop machine without
updating EVERY machine on the network to 0.22, so that's 2 desktops, 2
dedicated machines hooked to TVs and the server. That's a lot of work
just because someone decides they don't want to support it anymore.

On the other hand, if the qt4 qt3-support works then I don't update
from 0.21 at all.

Again, I cannot see the 0.22 gives me anything I care about but
there's no way to know until I commit to making the change.

Cheers,
Mark
 
Old 02-10-2010, 07:14 PM
Manuel McLure
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 11:47 AM, Neil Bothwick <neil@digimed.co.uk> wrote:
> Upgrading from 0.21 to 0.22 was painless AFAIR. I made a backup of the
> database but didn't need. You do need to upgrade all backends and
> frontends at the same time, but then it's just a matter of restarting
> them and you're OK. I did "emerge --onlydeps mythtv && emerge -B mythtv"
> first so that I could then run emerge -k mythtv on the server to minimise
> the time it was down.

It can be painless, but you could also run into the "corrupt database
encoding" problem on Gentoo. I did, and had to follow the steps at
http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding to fix a
"partial corruption" before the upgrade would succeed.

However, I'm quite happy with the behavior and performance of 0.22, so
it was definitely worth the pain.
--
Manuel A. McLure WW1FA <manuel@mclure.org> <http://www.mclure.org>
...for in Ulthar, according to an ancient and significant law,
no man may kill a cat. -- H.P. Lovecraft
 
Old 02-10-2010, 11:03 PM
Mark Knecht
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 11:40 AM, Volker Armin Hemmann
<volkerarmin@googlemail.com> wrote:
<SNIP>
>>
>> Again, I cannot see the 0.22 gives me anything I care about but
>> there's no way to know until I commit to making the change.
>>
>> Cheers,
>> Mark
>
> if everything works, why are you even bothering with updates? Why do you care
> at all that qt3 is going away?
>
> but as I told you, the solution is quickpkg.
>
> And for quickly deploying packages:
> buidpkg
> BINHOST.
>
> have a look at man emerge, man make.conf

Volker,
Thanks. I've not used quickpkg before but it seems like a very good
short term solution.

If I understand correctly I'd do something more or less like this?

1) quickpkg =qt-3.3.8xxxxxxx This creates the binary package and
stores it in /usr/portage/package. I've done this step and the package
is there.

2) emerge -C =qt-3.3.8xxxxx to remove the original. Easy when I do it.

3) emerge -pvg =qt-3.3.8b-r2 to get it to use the quickpkg version

This all seems to work but it complains a bit about PORTAGE_BINHOST
not being set. As best I can tell that's only for using another
machine to get the binary? Is that true? Is seems from these commands
that it's finding the one I just made. Or is there a format for doing
this and pointing at a local directory?

firefly ~ # emerge -pvg =x11-libs/qt-3.3.8b-r2

These are the packages that would be merged, in order:

Calculating dependencies !!! PORTAGE_BINHOST unset, but use is requested.
... done!
[binary R ] x11-libs/qt-3.3.8b-r2 USE="cups ipv6 mysql opengl
-debug -doc -examples (-firebird) -immqt -immqt-bc -nas -nis -odbc
-postgres -sqlite -xinerama"

Total: 1 package (1 reinstall, 1 binary), Size of downloads: 0 kB
firefly ~ # emerge -pv =x11-libs/qt-3.3.8b-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/qt-3.3.8b-r2 USE="cups ipv6 mysql opengl
-debug -doc -examples (-firebird) -immqt -immqt-bc -nas -nis -odbc
-postgres -sqlite -xinerama" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
firefly ~ #


Thanks,
Mark
 
Old 02-10-2010, 11:34 PM
Mark Knecht
 
Default Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

On Wed, Feb 10, 2010 at 4:03 PM, Mark Knecht <markknecht@gmail.com> wrote:
<SNIP>
> firefly ~ # emerge -pvg =x11-libs/qt-3.3.8b-r2

Ah, instead I should use

emerge --usepkg =x11-libs/qt-3.3.8b-r2

No errors or warnings.

Nice! Now Myth works no matter what happens in portage to qt...

Thanks,
Mark
 

Thread Tools




All times are GMT. The time now is 07:28 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org