Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   digraph error while trying to emerge (http://www.linux-archive.org/gentoo-user/31631-digraph-error-while-trying-emerge.html)

"Justin Patrin" 01-08-2008 03:10 AM

digraph error while trying to emerge
 
I honestly have no idea how to deal with this one. It started a few
weeks ago and I hoped it would go away by itself.

!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'dev-java/bcprov-1.37', 'merge') pulled in by
('ebuild', '/', 'dev-java/bcmail-1.37', 'merge')

('ebuild', '/', 'dev-java/bcprov-1.38', 'merge') pulled in by
('ebuild', '/', 'dev-java/itext-2.0.6', 'merge')

--
Justin Patrin
--
gentoo-user@lists.gentoo.org mailing list

Alan McKinnon 01-08-2008 05:23 AM

digraph error while trying to emerge
 
On Tuesday 08 January 2008, Justin Patrin wrote:
> I honestly have no idea how to deal with this one. It started a few
> weeks ago and I hoped it would go away by itself.
>
> !!! Multiple versions within a single package slot have been
> !!! pulled into the dependency graph:
>
> ('ebuild', '/', 'dev-java/bcprov-1.37', 'merge') pulled in by
> ('ebuild', '/', 'dev-java/bcmail-1.37', 'merge')
>
> ('ebuild', '/', 'dev-java/bcprov-1.38', 'merge') pulled in by
> ('ebuild', '/', 'dev-java/itext-2.0.6', 'merge')

I'm not sure why itext wants to emerge bcprov-1.38 - that version is
unstable and everything else is stable. But itext will be happy with
bcprov-1.37, so mask out bcprov-1.38 as not to be installed:

echo =dev-java/bcprov-1.38 >> /etc/portage/package.mask


--
Alan McKinnon
alan dot mckinnon at gmail dot com
--
gentoo-user@lists.gentoo.org mailing list

"Justin Patrin" 01-08-2008 05:25 AM

digraph error while trying to emerge
 
On Jan 7, 2008 8:10 PM, Justin Patrin <papercrane@gmail.com> wrote:
> I honestly have no idea how to deal with this one. It started a few
> weeks ago and I hoped it would go away by itself.
>
> !!! Multiple versions within a single package slot have been
> !!! pulled into the dependency graph:
>
> ('ebuild', '/', 'dev-java/bcprov-1.37', 'merge') pulled in by
> ('ebuild', '/', 'dev-java/bcmail-1.37', 'merge')
>
> ('ebuild', '/', 'dev-java/bcprov-1.38', 'merge') pulled in by
> ('ebuild', '/', 'dev-java/itext-2.0.6', 'merge')
>

Ah, never mind, I had previously set bcprov ~x86 to install something
or other. Commenting that out fixed this.

dev-java/bcprov ~x86

--
Justin Patrin
--
gentoo-user@lists.gentoo.org mailing list


All times are GMT. The time now is 10:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.