FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-06-2010, 12:49 PM
Michael Sullivan
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

I was hoping that this was a dev boo-boo and would work itself out in
time, but it's been several days and it hasn't, so the problem must be
on my end. See the following listing:

Calculating dependencies ...... . ....... done!
[ebuild N ] sys-power/powermgmt-base-1.22
[ebuild U ] media-libs/libmikmod-3.2.0_beta2-r1 [3.1.11-r5]
[ebuild N ] sys-apps/apmd-3.2.2_p5 USE="X nls"
[ebuild N ] sys-power/pm-utils-1.2.5 USE="alsa -debug
-networkmanager -ntp" VIDEO_CARDS="-intel -radeon"
[blocks B ] sys-power/powermgmt-base ("sys-power/powermgmt-base" is
blocking sys-power/pm-utils-1.2.5)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in by
>=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
'sys-apps/apmd-3.2.2_p5', 'merge')

('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
sys-power/pm-utils required by ('installed', '/',
'kde-base/powerdevil-4.3.3', 'nomerge')

As you can see powermgmt-base is on the emerge list, as is pm-utils. I
installed kde-meta because my mother-in-law is visiting and she likes
kpatience and it didn't work anymore with kde-3.5. Now, how do I
resolve this block?
 
Old 01-06-2010, 01:17 PM
Alan McKinnon
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Wednesday 06 January 2010 15:49:05 Michael Sullivan wrote:
> I was hoping that this was a dev boo-boo and would work itself out in
> time, but it's been several days and it hasn't, so the problem must be
> on my end. See the following listing:
>
> Calculating dependencies ...... . ....... done!
> [ebuild N ] sys-power/powermgmt-base-1.22
> [ebuild U ] media-libs/libmikmod-3.2.0_beta2-r1 [3.1.11-r5]
> [ebuild N ] sys-apps/apmd-3.2.2_p5 USE="X nls"
> [ebuild N ] sys-power/pm-utils-1.2.5 USE="alsa -debug
> -networkmanager -ntp" VIDEO_CARDS="-intel -radeon"
> [blocks B ] sys-power/powermgmt-base ("sys-power/powermgmt-base" is
> blocking sys-power/pm-utils-1.2.5)
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> ('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in by
>
> >=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
>
> 'sys-apps/apmd-3.2.2_p5', 'merge')
>
> ('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
> sys-power/pm-utils required by ('installed', '/',
> 'kde-base/powerdevil-4.3.3', 'nomerge')
>
> As you can see powermgmt-base is on the emerge list, as is pm-utils. I
> installed kde-meta because my mother-in-law is visiting and she likes
> kpatience and it didn't work anymore with kde-3.5. Now, how do I
> resolve this block?
>

You cannot have both those packages at the same time.

From the pm-utils ebuild:

$ cat pm-utils/pm-utils-1.2.5.ebuild

[snip]

RDEPEND=">=sys-apps/hal-0.5.10
>=sys-apps/dbus-1.0.0
!sys-power/powermgmt-base

You need to get rid of powermgmt-base somehow or not use pm-utils. The depends
list for pm-utils is:

$ equery depends pm-utils
* Searching for pm-utils ...
kde-base/powerdevil-4.3.4 (pm-utils ? sys-power/pm-utils)
net-misc/wicd-1.6.2.2 (pm-utils ? >=sys-power/pm-utils-1.1.1)
sys-apps/hal-0.5.14 (laptop ? >=sys-power/pm-utils-0.99.3)
alan@nazgul ~/downloads/iso/gentoo $ eix powermgmt-base

So I assume you have KDE4 installed.

What package do you have that wants powermgmt-base? (emerge -t helps find
this)


--
alan dot mckinnon at gmail dot com
 
Old 01-06-2010, 02:23 PM
Neil Bothwick
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Wed, 06 Jan 2010 07:49:05 -0600, Michael Sullivan wrote:

> Calculating dependencies ...... . ....... done!
> [ebuild N ] sys-power/powermgmt-base-1.22
> [ebuild U ] media-libs/libmikmod-3.2.0_beta2-r1 [3.1.11-r5]
> [ebuild N ] sys-apps/apmd-3.2.2_p5 USE="X nls"
> [ebuild N ] sys-power/pm-utils-1.2.5 USE="alsa -debug
> -networkmanager -ntp" VIDEO_CARDS="-intel -radeon"
> [blocks B ] sys-power/powermgmt-base ("sys-power/powermgmt-base" is
> blocking sys-power/pm-utils-1.2.5)
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.

Add --tree to the emerge command to see what is pulling in each of these
packages.


--
Neil Bothwick

What Aussies lack in Humour they make up for in Beer!
 
Old 01-06-2010, 08:23 PM
Renat Golubchyk
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

Hi!

On Wed, 06 Jan 2010 07:49:05 -0600
Michael Sullivan <msulli1355@gmail.com> wrote:
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> ('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in
> by
> >=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
> 'sys-apps/apmd-3.2.2_p5', 'merge')
>
> ('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
> sys-power/pm-utils required by ('installed', '/',
> 'kde-base/powerdevil-4.3.3', 'nomerge')

According to the error message sys-power/powermgmt-base is getting
pulled by sys-apps/apmd and sys-power/pm-utils by kde-base/powerdevil.
If you use ACPI then there is probably no need in having APM daemon
installed. Add -t to your emerge command and check what package depends
on apmd.


Cheers,
Renat

--
Probleme kann man niemals mit derselben Denkweise loesen,
durch die sie entstanden sind.
(Einstein)
 
Old 01-07-2010, 02:35 AM
Michael Sullivan
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Wed, 2010-01-06 at 22:23 +0100, Renat Golubchyk wrote:
> Hi!
>
> On Wed, 06 Jan 2010 07:49:05 -0600
> Michael Sullivan <msulli1355@gmail.com> wrote:
> > * Error: The above package list contains packages which cannot be
> > * installed at the same time on the same system.
> >
> > ('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in
> > by
> > >=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
> > 'sys-apps/apmd-3.2.2_p5', 'merge')
> >
> > ('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
> > sys-power/pm-utils required by ('installed', '/',
> > 'kde-base/powerdevil-4.3.3', 'nomerge')
>
> According to the error message sys-power/powermgmt-base is getting
> pulled by sys-apps/apmd and sys-power/pm-utils by kde-base/powerdevil.
> If you use ACPI then there is probably no need in having APM daemon
> installed. Add -t to your emerge command and check what package depends
> on apmd.
>
>
> Cheers,
> Renat
>
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge ] gnome-base/gnome-2.26.3 USE="cdr cups dvdr
-accessibility -esd -ldap -mono"
[nomerge ] gnome-base/gnome-applets-2.26.3 USE="acpi apm gnome
gstreamer hal ipv6 -debug -doc -policykit"
[ebuild N ] sys-apps/apmd-3.2.2_p5 USE="X nls" 0 kB
[nomerge ] games-emulation/dosbox-0.73 USE="alsa opengl -debug
-hardened"
[nomerge ] media-libs/sdl-sound-1.0.3 USE="flac mikmod mp3 mpeg
vorbis -physfs -speex"
[ebuild U ] media-libs/libmikmod-3.2.0_beta2-r1 [3.1.11-r5]
USE="oss (-alsa%*) (-esd%)" 744 kB
[nomerge ] kde-base/kde-meta-4.3.3 USE="nls -accessibility
(-kdeprefix)"
[nomerge ] kde-base/kdebase-meta-4.3.3 USE="semantic-desktop
(-kdeprefix) -policykit"
[nomerge ] kde-base/powerdevil-4.3.3 USE="pm-utils (-aqua)
-debug (-kdeenablefinal) (-kdeprefix)"
[ebuild N ] sys-power/pm-utils-1.2.5 USE="alsa -debug
-networkmanager -ntp" VIDEO_CARDS="-intel -radeon" 0 kB
[nomerge ] sys-apps/apmd-3.2.2_p5 USE="X nls"
[ebuild N ] sys-power/powermgmt-base-1.22 0 kB
[blocks B ] sys-power/powermgmt-base ("sys-power/powermgmt-base" is
blocking sys-power/pm-utils-1.2.5)

Total: 4 packages (1 upgrade, 3 new), Size of downloads: 744 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in by
>=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
'sys-apps/apmd-3.2.2_p5', 'merge')

('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
sys-power/pm-utils required by ('installed', '/',
'kde-base/powerdevil-4.3.3', 'nomerge')


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.
 
Old 01-07-2010, 06:47 AM
Alan McKinnon
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Thursday 07 January 2010 05:35:39 Michael Sullivan wrote:
> On Wed, 2010-01-06 at 22:23 +0100, Renat Golubchyk wrote:
> > Hi!
> >
> > On Wed, 06 Jan 2010 07:49:05 -0600
> >
> > Michael Sullivan <msulli1355@gmail.com> wrote:
> > > * Error: The above package list contains packages which cannot be
> > > * installed at the same time on the same system.
> > >
> > > ('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in
> > > by
> > >
> > > >=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
> > >
> > > 'sys-apps/apmd-3.2.2_p5', 'merge')
> > >
> > > ('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
> > > sys-power/pm-utils required by ('installed', '/',
> > > 'kde-base/powerdevil-4.3.3', 'nomerge')
> >
> > According to the error message sys-power/powermgmt-base is getting
> > pulled by sys-apps/apmd and sys-power/pm-utils by kde-base/powerdevil.
> > If you use ACPI then there is probably no need in having APM daemon
> > installed. Add -t to your emerge command and check what package depends
> > on apmd.
> >
> >
> > Cheers,
> > Renat
>
> These are the packages that would be merged, in reverse order:
>
> Calculating dependencies... done!
> [nomerge ] gnome-base/gnome-2.26.3 USE="cdr cups dvdr
> -accessibility -esd -ldap -mono"
> [nomerge ] gnome-base/gnome-applets-2.26.3 USE="acpi apm gnome
> gstreamer hal ipv6 -debug -doc -policykit"

USE="-apm"

If you have acpi you do not need to use apm. Unless you have weird hardware.

--
alan dot mckinnon at gmail dot com
 
Old 01-07-2010, 12:55 PM
Michael Sullivan
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Thu, 2010-01-07 at 09:47 +0200, Alan McKinnon wrote:
> On Thursday 07 January 2010 05:35:39 Michael Sullivan wrote:
> > On Wed, 2010-01-06 at 22:23 +0100, Renat Golubchyk wrote:
> > > Hi!
> > >
> > > On Wed, 06 Jan 2010 07:49:05 -0600
> > >
> > > Michael Sullivan <msulli1355@gmail.com> wrote:
> > > > * Error: The above package list contains packages which cannot be
> > > > * installed at the same time on the same system.
> > > >
> > > > ('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in
> > > > by
> > > >
> > > > >=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
> > > >
> > > > 'sys-apps/apmd-3.2.2_p5', 'merge')
> > > >
> > > > ('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
> > > > sys-power/pm-utils required by ('installed', '/',
> > > > 'kde-base/powerdevil-4.3.3', 'nomerge')
> > >
> > > According to the error message sys-power/powermgmt-base is getting
> > > pulled by sys-apps/apmd and sys-power/pm-utils by kde-base/powerdevil.
> > > If you use ACPI then there is probably no need in having APM daemon
> > > installed. Add -t to your emerge command and check what package depends
> > > on apmd.
> > >
> > >
> > > Cheers,
> > > Renat
> >
> > These are the packages that would be merged, in reverse order:
> >
> > Calculating dependencies... done!
> > [nomerge ] gnome-base/gnome-2.26.3 USE="cdr cups dvdr
> > -accessibility -esd -ldap -mono"
> > [nomerge ] gnome-base/gnome-applets-2.26.3 USE="acpi apm gnome
> > gstreamer hal ipv6 -debug -doc -policykit"
>
> USE="-apm"
>
> If you have acpi you do not need to use apm. Unless you have weird hardware.

catherine ~ # USE="-apm" emerge -pvuDt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge ] gnome-base/gnome-2.26.3 USE="cdr cups dvdr
-accessibility -esd -ldap -mono"
[nomerge ] gnome-base/gnome-applets-2.26.3 USE="acpi apm gnome
gstreamer hal ipv6 -debug -doc -policykit"
[ebuild N ] sys-apps/apmd-3.2.2_p5 USE="X nls" 0 kB
[nomerge ] games-emulation/dosbox-0.73 USE="alsa opengl -debug
-hardened"
[nomerge ] media-libs/sdl-sound-1.0.3 USE="flac mikmod mp3 mpeg
vorbis -physfs -speex"
[ebuild U ] media-libs/libmikmod-3.2.0_beta2-r1 [3.1.11-r5]
USE="oss (-alsa%*) (-esd%)" 744 kB
[nomerge ] kde-base/kde-meta-4.3.3 USE="nls -accessibility
(-kdeprefix)"
[nomerge ] kde-base/kdebase-meta-4.3.3 USE="semantic-desktop
(-kdeprefix) -policykit"
[nomerge ] kde-base/powerdevil-4.3.3 USE="pm-utils (-aqua)
-debug (-kdeenablefinal) (-kdeprefix)"
[ebuild N ] sys-power/pm-utils-1.2.5 USE="alsa -debug
-networkmanager -ntp" VIDEO_CARDS="-intel -radeon" 0 kB
[nomerge ] sys-apps/apmd-3.2.2_p5 USE="X nls"
[ebuild N ] sys-power/powermgmt-base-1.22 0 kB
[blocks B ] sys-power/powermgmt-base ("sys-power/powermgmt-base" is
blocking sys-power/pm-utils-1.2.5)

Total: 4 packages (1 upgrade, 3 new), Size of downloads: 744 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in by
>=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
'sys-apps/apmd-3.2.2_p5', 'merge')

('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
sys-power/pm-utils required by ('installed', '/',
'kde-base/powerdevil-4.3.3', 'nomerge')


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

catherine ~ #
 
Old 01-07-2010, 01:27 PM
"Zeerak Waseem"
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Thu, 07 Jan 2010 14:55:51 +0100, Michael Sullivan
<msulli1355@gmail.com> wrote:



On Thu, 2010-01-07 at 09:47 +0200, Alan McKinnon wrote:

On Thursday 07 January 2010 05:35:39 Michael Sullivan wrote:
> On Wed, 2010-01-06 at 22:23 +0100, Renat Golubchyk wrote:
> > Hi!
> >
> > On Wed, 06 Jan 2010 07:49:05 -0600
> >
> > Michael Sullivan <msulli1355@gmail.com> wrote:
> > > * Error: The above package list contains packages which cannot be
> > > * installed at the same time on the same system.
> > >
> > > ('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge')
pulled in

> > > by
> > >
> > > >=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
> > >
> > > 'sys-apps/apmd-3.2.2_p5', 'merge')
> > >
> > > ('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in
by

> > > sys-power/pm-utils required by ('installed', '/',
> > > 'kde-base/powerdevil-4.3.3', 'nomerge')
> >
> > According to the error message sys-power/powermgmt-base is getting
> > pulled by sys-apps/apmd and sys-power/pm-utils by
kde-base/powerdevil.

> > If you use ACPI then there is probably no need in having APM daemon
> > installed. Add -t to your emerge command and check what package
depends

> > on apmd.
> >
> >
> > Cheers,
> > Renat
>
> These are the packages that would be merged, in reverse order:
>
> Calculating dependencies... done!
> [nomerge ] gnome-base/gnome-2.26.3 USE="cdr cups dvdr
> -accessibility -esd -ldap -mono"
> [nomerge ] gnome-base/gnome-applets-2.26.3 USE="acpi apm gnome
> gstreamer hal ipv6 -debug -doc -policykit"

USE="-apm"

If you have acpi you do not need to use apm. Unless you have weird
hardware.


catherine ~ # USE="-apm" emerge -pvuDt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge ] gnome-base/gnome-2.26.3 USE="cdr cups dvdr
-accessibility -esd -ldap -mono"
[nomerge ] gnome-base/gnome-applets-2.26.3 USE="acpi apm gnome
gstreamer hal ipv6 -debug -doc -policykit"
[ebuild N ] sys-apps/apmd-3.2.2_p5 USE="X nls" 0 kB
[nomerge ] games-emulation/dosbox-0.73 USE="alsa opengl -debug
-hardened"
[nomerge ] media-libs/sdl-sound-1.0.3 USE="flac mikmod mp3 mpeg
vorbis -physfs -speex"
[ebuild U ] media-libs/libmikmod-3.2.0_beta2-r1 [3.1.11-r5]
USE="oss (-alsa%*) (-esd%)" 744 kB
[nomerge ] kde-base/kde-meta-4.3.3 USE="nls -accessibility
(-kdeprefix)"
[nomerge ] kde-base/kdebase-meta-4.3.3 USE="semantic-desktop
(-kdeprefix) -policykit"
[nomerge ] kde-base/powerdevil-4.3.3 USE="pm-utils (-aqua)
-debug (-kdeenablefinal) (-kdeprefix)"
[ebuild N ] sys-power/pm-utils-1.2.5 USE="alsa -debug
-networkmanager -ntp" VIDEO_CARDS="-intel -radeon" 0 kB
[nomerge ] sys-apps/apmd-3.2.2_p5 USE="X nls"
[ebuild N ] sys-power/powermgmt-base-1.22 0 kB
[blocks B ] sys-power/powermgmt-base ("sys-power/powermgmt-base" is
blocking sys-power/pm-utils-1.2.5)

Total: 4 packages (1 upgrade, 3 new), Size of downloads: 744 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'sys-power/powermgmt-base-1.22', 'merge') pulled in by
>=sys-power/powermgmt-base-1.22 required by ('ebuild', '/',
'sys-apps/apmd-3.2.2_p5', 'merge')

('ebuild', '/', 'sys-power/pm-utils-1.2.5', 'merge') pulled in by
sys-power/pm-utils required by ('installed', '/',
'kde-base/powerdevil-4.3.3', 'nomerge')


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

catherine ~ #







If the package pulling in powermgmt-base isn't necessary for anything you
know of then add it to package.mask


--
Zeerak
 
Old 01-07-2010, 05:16 PM
Alan McKinnon
 
Default sys-power/powermgmt-base blocks sys-power/pm-utils, but it's not installed yet

On Thursday 07 January 2010 15:55:51 Michael Sullivan wrote:
> > USE="-apm"
> >
> > If you have acpi you do not need to use apm. Unless you have weird
> > hardware.
>
> catherine ~ # USE="-apm" emerge -pvuDt world
>

You need "N" in those portage options. Without it, it won't take changed USE
flags into account for already installed packages.

Test with -p, if you are happy with what portage intends to do, put USE="-apm"
into make.conf or packages.use as normal, then run the emerge for real.

--
alan dot mckinnon at gmail dot com
 

Thread Tools




All times are GMT. The time now is 07:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org