FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-02-2010, 09:41 AM
Jon Hardcastle
 
Default revdep-rebuild and kde-base/kdelibs:3.5

Hi I am trying to run revdep-rebuild and it gets to the emerge stage and i get this

!! All ebuilds that could satisfy "kde-base/kdelibs:3.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-3.5.10-r6 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (31 Dec 2009)
# Doesn't compile anymore with Autoconf >= 2.64, wv2 >= 0.4.0,
# several open security bugs, ...
#
# Replaced by app-office/koffice-meta-2.1.0
#
# See bugs 274566, 274918, 279027, 279482, 283429, 285018, 294676,
# 287276, 292791, ...
#
# Masked for removal in 30 days
#


does anyone have any advice? I have tried to force the emerge but i dont really know what i am doing :-/


-----------------------
N: Jon Hardcastle
E: Jon@eHardcastle.com
'Do not worry about tomorrow, for tomorrow will bring worries of its own.'

***********
Please note, I am phasing out jd_hardcastle AT yahoo.com and replacing it with jon AT eHardcastle.com
***********

-----------------------
 
Old 01-02-2010, 11:05 AM
Volker Armin Hemmann
 
Default revdep-rebuild and kde-base/kdelibs:3.5

On Samstag 02 Januar 2010, Jon Hardcastle wrote:
> Hi I am trying to run revdep-rebuild and it gets to the emerge stage and i
> get this
>
> !! All ebuilds that could satisfy "kde-base/kdelibs:3.5" have been masked.
> !!! One of the following masked packages is required to complete your
> request: - kde-base/kdelibs-3.5.10-r6 (masked by: package.mask)
> /usr/portage/profiles/package.mask:
> # Samuli Suominen <ssuominen@gentoo.org> (31 Dec 2009)
> # Doesn't compile anymore with Autoconf >= 2.64, wv2 >= 0.4.0,
> # several open security bugs, ...
> #
> # Replaced by app-office/koffice-meta-2.1.0
> #
> # See bugs 274566, 274918, 279027, 279482, 283429, 285018, 294676,
> # 287276, 292791, ...
> #
> # Masked for removal in 30 days
> #
>
>
> does anyone have any advice? I have tried to force the emerge but i dont
> really know what i am doing :-/
>
>
> -----------------------
> N: Jon Hardcastle
> E: Jon@eHardcastle.com
> 'Do not worry about tomorrow, for tomorrow will bring worries of its own.'
>
> ***********
> Please note, I am phasing out jd_hardcastle AT yahoo.com and replacing it
> with jon AT eHardcastle.com ***********
>
> -----------------------
>


yes, get rid of the app that needs kde3 and move on.
 
Old 01-02-2010, 11:33 AM
Dale
 
Default revdep-rebuild and kde-base/kdelibs:3.5

Jon Hardcastle wrote:

Hi I am trying to run revdep-rebuild and it gets to the emerge stage and i get this

!! All ebuilds that could satisfy "kde-base/kdelibs:3.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-3.5.10-r6 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (31 Dec 2009)
# Doesn't compile anymore with Autoconf >= 2.64, wv2 >= 0.4.0,
# several open security bugs, ...
#
# Replaced by app-office/koffice-meta-2.1.0
#
# See bugs 274566, 274918, 279027, 279482, 283429, 285018, 294676,
# 287276, 292791, ...
#
# Masked for removal in 30 days
#


does anyone have any advice? I have tried to force the emerge but i dont really know what i am doing :-/


-----------------------
N: Jon Hardcastle
E: Jon@eHardcastle.com
'Do not worry about tomorrow, for tomorrow will bring worries of its own.'

***********
Please note, I am phasing out jd_hardcastle AT yahoo.com and replacing it with jon AT eHardcastle.com
***********

-----------------------



This is where you get to choose. You either have to use layman to keep
KDE 3.5 around or move over to KDE 4, which there are still some things
that don't work. KDE 3.5 has been masked and will be removed from the
portage tree, according to the error above.

You may be able to unmask it until it is removed but either way, you
will have to use layman eventually. If you plan to unmask it for now, I
would check out autounmask. I suspect there will be a lot of them
masked. Doing them one by one could take a while.


Dale

:-) :-)

P. S. Don't blame Gentoo for this. KDE is the one that decided not to
maintain KDE 3.5 even tho KDE 4 is not ready yet. The good thing about
Gentoo is that it builds from sources. The bad thing is, it builds from
sources. When the sources stop, Gentoo has to remove them.
 
Old 01-02-2010, 01:24 PM
Neil Bothwick
 
Default revdep-rebuild and kde-base/kdelibs:3.5

On Sat, 2 Jan 2010 13:05:44 +0100, Volker Armin Hemmann wrote:

> yes, get rid of the app that needs kde3 and move on.

Unfortunately there are some apps that do not have KDE4 replacements.
While I understand the Gentoo devs decision to drop the KDE3 desktop and
apps from portage, kdelibs should be kept as long as there are apps
depending on it. No, dropping all those apps is no the answer either, at
least, not yet.


--
Neil Bothwick

Sleep is an excellent way of listening to an opera. - James Stephens
(1882-1950)
 
Old 01-02-2010, 06:11 PM
Dale
 
Default revdep-rebuild and kde-base/kdelibs:3.5

Neil Bothwick wrote:

On Sat, 2 Jan 2010 13:05:44 +0100, Volker Armin Hemmann wrote:



yes, get rid of the app that needs kde3 and move on.



Unfortunately there are some apps that do not have KDE4 replacements.
While I understand the Gentoo devs decision to drop the KDE3 desktop and
apps from portage, kdelibs should be kept as long as there are apps
depending on it. No, dropping all those apps is no the answer either, at
least, not yet.




Very true. There are still things that I can do in KDE 3.5 that I can't
do in KDE 4. Even if I use KDE 4 for the most part, I would still have
to have KDE 3.5 for the things I can't do in KDE 4. This may be the
reason the OP is keeping KDE 3.5 around as well. KDE really dropped the
ball this time.

OP, I would be willing to help you get this sorted out. I could send
the commands I remember using and it is not a bad or difficult thing. I
don't like using layman myself but I do want a working desktop too.


Dale

:-) :-)
 
Old 01-02-2010, 07:39 PM
Philip Webb
 
Default revdep-rebuild and kde-base/kdelibs:3.5

100102 Dale wrote:
> Neil Bothwick wrote:
>> Unfortunately there are some apps that do not have KDE4 replacements.
>> While I understand the Gentoo devs decision to drop the KDE3 desktop
>> and apps from portage, kdelibs should be kept as long as there are apps
>> depending on it. dropping all those apps is no the answer, not yet.
> Very true. Even if I use KDE 4 for the most part,
> I would still have to have KDE 3.5 for the things I can't do in KDE 4.

I haven't installed the KDE desktop pkgs (I use Fluxbox),
but I'm having no problem using KDE 4 for most apps
-- eg Konsole Gwenview Okular Kshisen Speedcrunch -- ,
while retaining Kdelibs 3.5.10 & 3 apps not available in KDE 4
(Ksokoban Kworldclock not ported, Kmahjongg no removed-tiles display).
I just updated to KDE 4.3.3 & there doesn't seem to be anything wrong.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 01-02-2010, 09:44 PM
Dale
 
Default revdep-rebuild and kde-base/kdelibs:3.5

Philip Webb wrote:

100102 Dale wrote:


Neil Bothwick wrote:


Unfortunately there are some apps that do not have KDE4 replacements.
While I understand the Gentoo devs decision to drop the KDE3 desktop
and apps from portage, kdelibs should be kept as long as there are apps
depending on it. dropping all those apps is no the answer, not yet.


Very true. Even if I use KDE 4 for the most part,
I would still have to have KDE 3.5 for the things I can't do in KDE 4.



I haven't installed the KDE desktop pkgs (I use Fluxbox),
but I'm having no problem using KDE 4 for most apps
-- eg Konsole Gwenview Okular Kshisen Speedcrunch -- ,
while retaining Kdelibs 3.5.10 & 3 apps not available in KDE 4
(Ksokoban Kworldclock not ported, Kmahjongg no removed-tiles display).
I just updated to KDE 4.3.3 & there doesn't seem to be anything wrong.




It appears that we use different things tho. The only thing in your
list that I use is Konsole. I don't use any of the other programs you
mention.

I have tried KDE4 and continue to test when it updates but there are
things that still don't work. I posted the issues on the KDE mailing
list and others reported the same thing so it is not just me or a config
problem. I'm just waiting on them to get it all sorted out.

I do know this, if KDE does their next update this way, from KDE4 to
KDE5, I'll be using something else. It's like telling someone that they
can trade in their car but they have to turn in the old one and drive it
with no windshield and some other good things to have for months while
they finish putting the new car together. That may be a bad analogy but
it was what I thought of.


Dale

:-) :-)
 
Old 01-02-2010, 10:34 PM
Jon Hardcastle
 
Default revdep-rebuild and kde-base/kdelibs:3.5

--- On Sat, 2/1/10, Volker Armin Hemmann <volkerarmin@googlemail.com> wrote:

> From: Volker Armin Hemmann <volkerarmin@googlemail.com>
> Subject: Re: [gentoo-user] revdep-rebuild and kde-base/kdelibs:3.5
> To: gentoo-user@lists.gentoo.org
> Date: Saturday, 2 January, 2010, 12:05
> On Samstag 02 Januar 2010, Jon
> Hardcastle wrote:
> > Hi I am trying to run revdep-rebuild and it gets to
> the emerge stage and i
> >* get this
> >
> > !! All ebuilds that could satisfy
> "kde-base/kdelibs:3.5" have been masked.
> > !!! One of the following masked packages is required
> to complete your
> >* request: - kde-base/kdelibs-3.5.10-r6 (masked
> by: package.mask)
> > /usr/portage/profiles/package.mask:
> > # Samuli Suominen <ssuominen@gentoo.org>
> (31 Dec 2009)
> > # Doesn't compile anymore with Autoconf >= 2.64,
> wv2 >= 0.4.0,
> > # several open security bugs, ...
> > #
> > # Replaced by app-office/koffice-meta-2.1.0
> > #
> > # See bugs 274566, 274918, 279027, 279482, 283429,
> 285018, 294676,
> > # 287276, 292791, ...
> > #
> > # Masked for removal in 30 days
> > #
> >
> >
> > does anyone have any advice? I have tried to force the
> emerge but i dont
> >* really know what i am doing :-/
> >
> >
> > -----------------------
> > N: Jon Hardcastle
> > E: Jon@eHardcastle.com
> > 'Do not worry about tomorrow, for tomorrow will bring
> worries of its own.'
> >
> > ***********
> > Please note, I am phasing out jd_hardcastle AT
> yahoo.com and replacing it
> >* with jon AT eHardcastle.com ***********
> >
> > -----------------------
> >
>
>
> yes, get rid of the app that needs kde3 and move on.
>
>

What is the easiest way to do this? Although i dont agree this would perhaps normally be an option, installing kde was a venture that never really worked and as the machine is primarily a file server i can do without it...
 
Old 01-03-2010, 10:48 AM
Helmut Jarausch
 
Default revdep-rebuild and kde-base/kdelibs:3.5

On 2 Jan, Volker Armin Hemmann wrote:
>
> yes, get rid of the app that needs kde3 and move on.
>

Very good idea, indeed.
Then, please, tell me a replacement for app-office/kexi.

Thanks!

--
Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany
 

Thread Tools




All times are GMT. The time now is 06:41 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org