FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-17-2009, 03:26 PM
Paul Hartman
 
Default Blocks with xz-utils lzma-utils

On Thu, Dec 17, 2009 at 9:55 AM, Dale <rdalek1967@gmail.com> wrote:
> I'm trying to get KDE 4 where I can use it so I used the layman to get the
> latest. Anyway, I seem to have ran into a Block, may not be related to KDE4
> tho, that I just can't make sense of. This is the error I get:
>
> [blocks b ] kde-base/kde-meta:4.3[-kdeprefix]
> ("kde-base/kde-meta:4.3[-kdeprefix]" is blocking kde-base/kde-meta-9999)
> [blocks B ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking
> app-arch/xz-utils-9999)
> [blocks B ] app-arch/xz-utils ("app-arch/xz-utils" is blocking
> app-arch/lzma-utils-4.32.7)
>
> Total: 278 packages (17 upgrades, 19 new, 242 in new slots, 248 uninstalls),
> Size of downloads: 240,422 kB
> Conflict: 511 blocks (2 unsatisfied)
> Portage tree and overlays:
> [0] /usr/portage
> [1] /usr/local/portage/layman/kde
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> ('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') pulled in by
> app-arch/xz-utils required by ('installed', '/',
> 'app-arch/rpm2targz-9.0.0.3g', 'nomerge')
> app-arch/xz-utils required by ('installed', '/', 'sys-libs/gpm-1.20.5',
> 'nomerge')
> app-arch/xz-utils required by ('installed', '/', 'dev-libs/mpfr-2.4.1_p1',
> 'nomerge')
> (and 10 more)
>
> ('ebuild', '/', 'app-arch/lzma-utils-4.32.7', 'merge') pulled in by
> app-arch/lzma-utils required by ('installed', '/',
> 'app-portage/eix-0.17.0', 'nomerge')
> app-arch/lzma-utils required by ('installed', '/',
> 'app-arch/libarchive-2.7.0-r1', 'nomerge')
>
>
> I didn't post the whole thing but the part about the Blocks with a capital
> B. I have unmerged both lzma-utils and xz-utils but I still get this error.
> How can they block it when they are not installed yet? I'm missing
> something here. I just don't see it.
> I found a thread on the forums and did what it said but I still get this.
> It said to unmerge xz-utils which I did. Then I unmerged lzma-utils for
> good measure.
>
> Someone tell me the trick to this? Thanks.
>
> Dale
>
> :-) :-)

xz-utils replaces lzma-utils, so you can't have them both installed at
once. Maybe try unmerging and re-emerging the packages that say they
depend on lzma-utils, they've probably been updated to use xz-utils
instead by now.
 
Old 12-17-2009, 04:58 PM
Neil Bothwick
 
Default Blocks with xz-utils lzma-utils

On Thu, 17 Dec 2009 09:55:06 -0600, Dale wrote:

> I didn't post the whole thing but the part about the Blocks with a
> capital B. I have unmerged both lzma-utils and xz-utils but I still
> get this error. How can they block it when they are not installed
> yet? I'm missing something here. I just don't see it.

One package is pulling in lzma-utils, another wants xz-utils.

emerge --oneshot xz-utils (which replaces lzma-utils) should fix this.


--
Neil Bothwick

Yoda of the Borg am I. Futile, resistance is. Be assimilated, you will.
 
Old 12-17-2009, 05:22 PM
Dale
 
Default Blocks with xz-utils lzma-utils

Paul Hartman wrote:

On Thu, Dec 17, 2009 at 9:55 AM, Dale <rdalek1967@gmail.com> wrote:


I'm trying to get KDE 4 where I can use it so I used the layman to get the
latest. Anyway, I seem to have ran into a Block, may not be related to KDE4
tho, that I just can't make sense of. This is the error I get:

[blocks b ] kde-base/kde-meta:4.3[-kdeprefix]
("kde-base/kde-meta:4.3[-kdeprefix]" is blocking kde-base/kde-meta-9999)
[blocks B ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking
app-arch/xz-utils-9999)
[blocks B ] app-arch/xz-utils ("app-arch/xz-utils" is blocking
app-arch/lzma-utils-4.32.7)

Total: 278 packages (17 upgrades, 19 new, 242 in new slots, 248 uninstalls),
Size of downloads: 240,422 kB
Conflict: 511 blocks (2 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage/layman/kde

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') pulled in by
app-arch/xz-utils required by ('installed', '/',
'app-arch/rpm2targz-9.0.0.3g', 'nomerge')
app-arch/xz-utils required by ('installed', '/', 'sys-libs/gpm-1.20.5',
'nomerge')
app-arch/xz-utils required by ('installed', '/', 'dev-libs/mpfr-2.4.1_p1',
'nomerge')
(and 10 more)

('ebuild', '/', 'app-arch/lzma-utils-4.32.7', 'merge') pulled in by
app-arch/lzma-utils required by ('installed', '/',
'app-portage/eix-0.17.0', 'nomerge')
app-arch/lzma-utils required by ('installed', '/',
'app-arch/libarchive-2.7.0-r1', 'nomerge')


I didn't post the whole thing but the part about the Blocks with a capital
B. I have unmerged both lzma-utils and xz-utils but I still get this error.
How can they block it when they are not installed yet? I'm missing
something here. I just don't see it.
I found a thread on the forums and did what it said but I still get this.
It said to unmerge xz-utils which I did. Then I unmerged lzma-utils for
good measure.

Someone tell me the trick to this? Thanks.

Dale

:-) :-)



xz-utils replaces lzma-utils, so you can't have them both installed at
once. Maybe try unmerging and re-emerging the packages that say they
depend on lzma-utils, they've probably been updated to use xz-utils
instead by now.




I think I tried that. I ran this command with both blockers unmerged:

emerge -1v rpm2targz gpm mpfr eix libarchive

Thing is, it pulled both the blockers back in again. I also tried
removing those two blockers and just doing the HUGE update, it still
gripes about the block.


I synced last night. Could it be that I need to sync again? Maybe
something was in the process of changing when I synced?


Thanks.

Dale

:-) :-)
 
Old 12-17-2009, 05:32 PM
Dale
 
Default Blocks with xz-utils lzma-utils

Neil Bothwick wrote:

On Thu, 17 Dec 2009 09:55:06 -0600, Dale wrote:


I didn't post the whole thing but the part about the Blocks with a
capital B. I have unmerged both lzma-utils and xz-utils but I still

get this error. How can they block it when they are not installed
yet? I'm missing something here. I just don't see it.



One package is pulling in lzma-utils, another wants xz-utils.

emerge --oneshot xz-utils (which replaces lzma-utils) should fix this.



I have tried a few things but just to make sure, I tried this just to be
sure. I unmerged both blockers and emerged xz-utils again, same block
as before.


Ideas?

Dale

:-)
 
Old 12-17-2009, 05:39 PM
"Dirk Heinrichs"
 
Default Blocks with xz-utils lzma-utils

Am Donnerstag 17 Dezember 2009 19:32:54 schrieb Dale:
> I have tried a few things but just to make sure, I tried this just to be
> sure. I unmerged both blockers and emerged xz-utils again, same block
> as before.
>
> Ideas?

The solution is in the ebuilds (as always): eix 0.17.0 still depends on lzma-
utils, while 0.17.1 has been switched to xz-utils. The same is true for
libarchive, you need a later version.

HTH...

Dirk
 
Old 12-17-2009, 05:59 PM
Daniel Pielmeier
 
Default Blocks with xz-utils lzma-utils

Dale schrieb am 17.12.2009 16:55:
>
> [blocks b ] kde-base/kde-meta:4.3[-kdeprefix]
> ("kde-base/kde-meta:4.3[-kdeprefix]" is blocking kde-base/kde-meta-9999)
> [blocks B ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking
> app-arch/xz-utils-9999)
> [blocks B ] app-arch/xz-utils ("app-arch/xz-utils" is blocking
> app-arch/lzma-utils-4.32.7)
>
> Total: 278 packages (17 upgrades, 19 new, 242 in new slots, 248
> uninstalls), Size of downloads: 240,422 kB
> Conflict: 511 blocks (2 unsatisfied)
> Portage tree and overlays:
> [0] /usr/portage
> [1] /usr/local/portage/layman/kde
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> ('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') pulled in by
> app-arch/xz-utils required by ('installed', '/',
> 'app-arch/rpm2targz-9.0.0.3g', 'nomerge')
> app-arch/xz-utils required by ('installed', '/',
> 'sys-libs/gpm-1.20.5', 'nomerge')
> app-arch/xz-utils required by ('installed', '/',
> 'dev-libs/mpfr-2.4.1_p1', 'nomerge')
> (and 10 more)
>
> ('ebuild', '/', 'app-arch/lzma-utils-4.32.7', 'merge') pulled in by
> app-arch/lzma-utils required by ('installed', '/',
> 'app-portage/eix-0.17.0', 'nomerge')
> app-arch/lzma-utils required by ('installed', '/',
> 'app-arch/libarchive-2.7.0-r1', 'nomerge')
>

You need at least eix-0.17.1 and libarchive-2.7.1. Older versions depend
on lzma-utils instead of xz-utils, thus the blocker.

--
Daniel Pielmeier
 
Old 12-17-2009, 08:12 PM
Dale
 
Default Blocks with xz-utils lzma-utils

Daniel Pielmeier wrote:

Dale schrieb am 17.12.2009 16:55:


[blocks b ] kde-base/kde-meta:4.3[-kdeprefix]
("kde-base/kde-meta:4.3[-kdeprefix]" is blocking kde-base/kde-meta-9999)
[blocks B ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking
app-arch/xz-utils-9999)
[blocks B ] app-arch/xz-utils ("app-arch/xz-utils" is blocking
app-arch/lzma-utils-4.32.7)

Total: 278 packages (17 upgrades, 19 new, 242 in new slots, 248
uninstalls), Size of downloads: 240,422 kB
Conflict: 511 blocks (2 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage/layman/kde

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') pulled in by
app-arch/xz-utils required by ('installed', '/',
'app-arch/rpm2targz-9.0.0.3g', 'nomerge')
app-arch/xz-utils required by ('installed', '/',
'sys-libs/gpm-1.20.5', 'nomerge')
app-arch/xz-utils required by ('installed', '/',
'dev-libs/mpfr-2.4.1_p1', 'nomerge')
(and 10 more)

('ebuild', '/', 'app-arch/lzma-utils-4.32.7', 'merge') pulled in by
app-arch/lzma-utils required by ('installed', '/',
'app-portage/eix-0.17.0', 'nomerge')
app-arch/lzma-utils required by ('installed', '/',
'app-arch/libarchive-2.7.0-r1', 'nomerge')




You need at least eix-0.17.1 and libarchive-2.7.1. Older versions depend
on lzma-utils instead of xz-utils, thus the blocker.



You are both right. I tried installing a later version on the blockers
but not the packages that depended on them. So, I added the following
to my package.keyword and package.unmask files:


=app-portage/eix-0.18.3
=app-arch/libarchive-2.7.1

Portage is now happy. Every time I think I have figured out portage and
these blocker messages, I get thrown a curve ball. lol


Thanks much for catching that curve ball.

Dale

:-) :-)
 
Old 12-17-2009, 09:15 PM
Neil Bothwick
 
Default Blocks with xz-utils lzma-utils

On Thu, 17 Dec 2009 15:12:19 -0600, Dale wrote:

> You are both right. I tried installing a later version on the blockers
> but not the packages that depended on them. So, I added the following
> to my package.keyword and package.unmask files:
>
> =app-portage/eix-0.18.3
> =app-arch/libarchive-2.7.1
>
> Portage is now happy. Every time I think I have figured out portage
> and these blocker messages, I get thrown a curve ball. lol

Ah, the fun of running a mixed arch/~arch system

BTW ~ is usually better than = in this situation.


--
Neil Bothwick

As of next week, passwords will be entered in Morse code.
 
Old 12-18-2009, 08:12 AM
Helmut Jarausch
 
Default Blocks with xz-utils lzma-utils

On 17 Dec, Dale wrote:
> I'm trying to get KDE 4 where I can use it so I used the layman to get
> the latest. Anyway, I seem to have ran into a Block, may not be related
> to KDE4 tho, that I just can't make sense of. This is the error I get:
>
> [blocks b ] kde-base/kde-meta:4.3[-kdeprefix]
> ("kde-base/kde-meta:4.3[-kdeprefix]" is blocking kde-base/kde-meta-9999)
> [blocks B ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking
> app-arch/xz-utils-9999)
> [blocks B ] app-arch/xz-utils ("app-arch/xz-utils" is blocking
> app-arch/lzma-utils-4.32.7)
>
> Total: 278 packages (17 upgrades, 19 new, 242 in new slots, 248
> uninstalls), Size of downloads: 240,422 kB
> Conflict: 511 blocks (2 unsatisfied)
> Portage tree and overlays:
> [0] /usr/portage
> [1] /usr/local/portage/layman/kde
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> ('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') pulled in by
> app-arch/xz-utils required by ('installed', '/',
> 'app-arch/rpm2targz-9.0.0.3g', 'nomerge')
> app-arch/xz-utils required by ('installed', '/',
> 'sys-libs/gpm-1.20.5', 'nomerge')
> app-arch/xz-utils required by ('installed', '/',
> 'dev-libs/mpfr-2.4.1_p1', 'nomerge')
> (and 10 more)
>
> ('ebuild', '/', 'app-arch/lzma-utils-4.32.7', 'merge') pulled in by
> app-arch/lzma-utils required by ('installed', '/',
> 'app-portage/eix-0.17.0', 'nomerge')
> app-arch/lzma-utils required by ('installed', '/',
> 'app-arch/libarchive-2.7.0-r1', 'nomerge')
>
>
> I didn't post the whole thing but the part about the Blocks with a
> capital B. I have unmerged both lzma-utils and xz-utils but I still get
> this error. How can they block it when they are not installed yet? I'm
> missing something here. I just don't see it.
>
> I found a thread on the forums and did what it said but I still get
> this. It said to unmerge xz-utils which I did. Then I unmerged
> lzma-utils for good measure.
>
> Someone tell me the trick to this? Thanks.
>
> Dale

I had a similar problem since I wanted to use the -J option of tar
(telling it to use the xz compressor)
Someone replied to my bug report that once app-arch/xz-utils becomes
stable it will replace lzma-utils. But I needed both now.
So, I installed app-arch/xz-utils outside of portage with the
prefix /usr/local. Then I told portage about it by

echo "app-arch/xz-utils-9999" > /etc/portage/profile/package.provided

That works.

Helmut.

--
Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany
 
Old 12-18-2009, 02:49 PM
Paul Hartman
 
Default Blocks with xz-utils lzma-utils

On Fri, Dec 18, 2009 at 3:12 AM, Helmut Jarausch
<jarausch@igpm.rwth-aachen.de> wrote:
> I had a similar problem since I wanted to use the -J option of tar
> (telling it to use the xz compressor)

There's also a --use-compress-prog switch for tar so you can make it
use any program you like. (unless that's a new option too?)
 

Thread Tools




All times are GMT. The time now is 11:23 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org