FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-07-2009, 02:49 AM
"Michael P. Soulier"
 
Default python-updater failure

So I ran a big emerge --update world and it picked up Python 2.6 from 2.5.
It'd be nice if python-updater ran automatically when this happens but it
doesn't, but gcompris failing to build was a nice reminder that it needed to
be done.

So I ran it...

msoulier@anton:~$ sudo python-updater
Password:
* Starting Python Updater from 2.5 to 2.6 :
* Adding to list: =net-p2p/bittorrent-5.0.9-r1
* Adding to list: =app-admin/webapp-config-1.50.16-r1
* Adding to list: =dev-util/scons-1.2.0-r1
* Adding to list: =sys-libs/cracklib-2.8.13
* Adding to list: =gnome-extra/libgsf-1.14.11
* Adding to list: =media-libs/mutagen-1.15
* Adding to list: =media-libs/lcms-1.18-r1
* Adding to list: =media-libs/pdflib-7.0.2_p8
* Adding to list: =dev-libs/boost-1.35.0-r2
* Adding to list: =dev-libs/libxslt-1.1.24-r1
* Adding to list: =dev-libs/libgamin-0.1.10-r2
* Adding to list: =dev-python/numeric-24.2-r6
* Adding to list: =dev-python/lxml-2.2.1
* Adding to list: =dev-python/cython-0.11.2
* Adding to list: =dev-python/numpy-1.2.1
* Adding to list: =dev-python/pygobject-2.16.1
* Adding to list: =dev-python/pycairo-1.8.2
* Adding to list: =dev-python/gnuplot-py-1.8
* Adding to list: =dev-python/twisted-web-8.1.0
* Adding to list: =dev-python/pycrypto-2.0.1-r8
* Adding to list: =dev-python/pyopenssl-0.9
* Adding to list: =dev-python/pyopengl-3.0.0
* Adding to list: =dev-python/dnspython-1.6.0
* Adding to list: =dev-python/twisted-8.1.0
* Adding to list: =dev-python/pyxml-0.8.4-r1
* Adding to list: =dev-python/wxpython-2.6.4.0-r2
* Adding to list: =x11-libs/vte-0.17.4-r3
* Adding to list: =net-zope/zope-interface-3.5.1
* Adding to list: =app-portage/layman-1.2.3
* Adding to list: =dev-java/java-config-1.3.7-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-python/lxml-2.2.1".

Umm... now what?

Mike
--
Michael P. Soulier <msoulier@digitaltorque.ca>
"Any intelligent fool can make things bigger and more complex... It takes a
touch of genius - and a lot of courage to move in the opposite direction."
--Albert Einstein
 
Old 12-07-2009, 03:31 AM
Joshua Murphy
 
Default python-updater failure

On Sun, Dec 6, 2009 at 10:49 PM, Michael P. Soulier
<msoulier@digitaltorque.ca> wrote:
> So I ran a big emerge --update world and it picked up Python 2.6 from 2.5.
> It'd be nice if python-updater ran automatically when this happens but it
> doesn't, but gcompris failing to build was a nice reminder that it needed to
> be done.
>
> So I ran it...
>
> msoulier@anton:~$ sudo python-updater
> Password:
> ** Starting Python Updater from 2.5 to 2.6 :
> ** * Adding to list: =net-p2p/bittorrent-5.0.9-r1
> ** * Adding to list: =app-admin/webapp-config-1.50.16-r1
> ** * Adding to list: =dev-util/scons-1.2.0-r1
> ** * Adding to list: =sys-libs/cracklib-2.8.13
> ** * Adding to list: =gnome-extra/libgsf-1.14.11
> ** * Adding to list: =media-libs/mutagen-1.15
> ** * Adding to list: =media-libs/lcms-1.18-r1
> ** * Adding to list: =media-libs/pdflib-7.0.2_p8
> ** * Adding to list: =dev-libs/boost-1.35.0-r2
> ** * Adding to list: =dev-libs/libxslt-1.1.24-r1
> ** * Adding to list: =dev-libs/libgamin-0.1.10-r2
> ** * Adding to list: =dev-python/numeric-24.2-r6
> ** * Adding to list: =dev-python/lxml-2.2.1
> ** * Adding to list: =dev-python/cython-0.11.2
> ** * Adding to list: =dev-python/numpy-1.2.1
> ** * Adding to list: =dev-python/pygobject-2.16.1
> ** * Adding to list: =dev-python/pycairo-1.8.2
> ** * Adding to list: =dev-python/gnuplot-py-1.8
> ** * Adding to list: =dev-python/twisted-web-8.1.0
> ** * Adding to list: =dev-python/pycrypto-2.0.1-r8
> ** * Adding to list: =dev-python/pyopenssl-0.9
> ** * Adding to list: =dev-python/pyopengl-3.0.0
> ** * Adding to list: =dev-python/dnspython-1.6.0
> ** * Adding to list: =dev-python/twisted-8.1.0
> ** * Adding to list: =dev-python/pyxml-0.8.4-r1
> ** * Adding to list: =dev-python/wxpython-2.6.4.0-r2
> ** * Adding to list: =x11-libs/vte-0.17.4-r3
> ** * Adding to list: =net-zope/zope-interface-3.5.1
> ** * Adding to list: =app-portage/layman-1.2.3
> ** * Adding to list: =dev-java/java-config-1.3.7-r1
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
>
> emerge: there are no ebuilds to satisfy "=dev-python/lxml-2.2.1".
>
> Umm... now what?
>
> Mike
> --
> Michael P. Soulier <msoulier@digitaltorque.ca>
> "Any intelligent fool can make things bigger and more complex... It takes a
> touch of genius - and a lot of courage to move in the opposite direction."
> --Albert Einstein
>

umm, well, I've not synced too awefully recently on the box I have
handy, but I'm seeing these two ebuilds for lxml:

lxml-2.2.2.ebuild lxml-2.2.3.ebuild

I'd guess, offhand, that you should install a newer version, since the
one it's looking for (likely due to that being the already installed
version) doesn't appear to exist in the tree anymore.

Also, if you run into errors actually installing any of that list
there, take a glance at http://bugs.gentoo.org/230205 ... down in the
comments there's mention of needing to prod eselect to fix things.

--
Poison [BLX]
Joshua M. Murphy
 
Old 12-07-2009, 04:05 AM
 
Default python-updater failure

Joshua Murphy <poisonbl@gmail.com> wrote:

> On Sun, Dec 6, 2009 at 10:49 PM, Michael P. Soulier
> <msoulier@digitaltorque.ca> wrote:
> > So I ran a big emerge --update world and it picked up Python 2.6 from 2.5.
> > It'd be nice if python-updater ran automatically when this happens but it
> > doesn't, but gcompris failing to build was a nice reminder that it needed to
> > be done.
> >
> > So I ran it...
> >
> > msoulier@anton:~$ sudo python-updater
> > Password:
> > ** Starting Python Updater from 2.5 to 2.6 :
> > ** * Adding to list: =net-p2p/bittorrent-5.0.9-r1
> > ** * Adding to list: =app-admin/webapp-config-1.50.16-r1
> > ** * Adding to list: =dev-util/scons-1.2.0-r1
> > ** * Adding to list: =sys-libs/cracklib-2.8.13
> > ** * Adding to list: =gnome-extra/libgsf-1.14.11
> > ** * Adding to list: =media-libs/mutagen-1.15
> > ** * Adding to list: =media-libs/lcms-1.18-r1
> > ** * Adding to list: =media-libs/pdflib-7.0.2_p8
> > ** * Adding to list: =dev-libs/boost-1.35.0-r2
> > ** * Adding to list: =dev-libs/libxslt-1.1.24-r1
> > ** * Adding to list: =dev-libs/libgamin-0.1.10-r2
> > ** * Adding to list: =dev-python/numeric-24.2-r6
> > ** * Adding to list: =dev-python/lxml-2.2.1
> > ** * Adding to list: =dev-python/cython-0.11.2
> > ** * Adding to list: =dev-python/numpy-1.2.1
> > ** * Adding to list: =dev-python/pygobject-2.16.1
> > ** * Adding to list: =dev-python/pycairo-1.8.2
> > ** * Adding to list: =dev-python/gnuplot-py-1.8
> > ** * Adding to list: =dev-python/twisted-web-8.1.0
> > ** * Adding to list: =dev-python/pycrypto-2.0.1-r8
> > ** * Adding to list: =dev-python/pyopenssl-0.9
> > ** * Adding to list: =dev-python/pyopengl-3.0.0
> > ** * Adding to list: =dev-python/dnspython-1.6.0
> > ** * Adding to list: =dev-python/twisted-8.1.0
> > ** * Adding to list: =dev-python/pyxml-0.8.4-r1
> > ** * Adding to list: =dev-python/wxpython-2.6.4.0-r2
> > ** * Adding to list: =x11-libs/vte-0.17.4-r3
> > ** * Adding to list: =net-zope/zope-interface-3.5.1
> > ** * Adding to list: =app-portage/layman-1.2.3
> > ** * Adding to list: =dev-java/java-config-1.3.7-r1
> >
> > These are the packages that would be merged, in order:
> >
> > Calculating dependencies... done!
> >
> > emerge: there are no ebuilds to satisfy "=dev-python/lxml-2.2.1".
> >
> > Umm... now what?
> >
> > Mike
> > --
> > Michael P. Soulier <msoulier@digitaltorque.ca>
> > "Any intelligent fool can make things bigger and more complex... It takes a
> > touch of genius - and a lot of courage to move in the opposite direction."
> > --Albert Einstein
> >
>
> umm, well, I've not synced too awefully recently on the box I have
> handy, but I'm seeing these two ebuilds for lxml:
>
> lxml-2.2.2.ebuild lxml-2.2.3.ebuild
>
> I'd guess, offhand, that you should install a newer version, since the
> one it's looking for (likely due to that being the already installed
> version) doesn't appear to exist in the tree anymore.
>
> Also, if you run into errors actually installing any of that list
> there, take a glance at http://bugs.gentoo.org/230205 ... down in the
> comments there's mention of needing to prod eselect to fix things.
>
> --
> Poison [BLX]
> Joshua M. Murphy
There is an argument to pythonupdater to ignore version numbers -- maybe
this will help your problem.


--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
 
Old 12-19-2009, 10:53 PM
"Michael P. Soulier"
 
Default python-updater failure

On 07/12/09 covici@ccs.covici.com said:

> There is an argument to pythonupdater to ignore version numbers -- maybe
> this will help your problem.

Yes, that was the issue. Far from intuitive...

Mike
--
Michael P. Soulier <msoulier@digitaltorque.ca>
"Any intelligent fool can make things bigger and more complex... It takes a
touch of genius - and a lot of courage to move in the opposite direction."
--Albert Einstein
 

Thread Tools




All times are GMT. The time now is 09:33 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org