FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-19-2009, 03:57 PM
Jacques Montier
 
Default icons missing in k3b

Hi everybody,

Some news about k3b and its missing icons.
I looked at your useflags and changed mine.
So i had to re-build plenty of packages and spent a very long compiling
time with my 8 year-old pc...
Well, after that,...nothing has changed.. :-(
http://sites.google.com/site/jacquesfr35/telechargement/k3b.jpg?attredirects=0
Never mind, the problem is not very important, so i stop here and will
use xfburn if i want all my icons :-)
As i work with Xfce4, i think i'll put all kde stuff away.

Thank you very much for your help.

Regards,

--
Jacques
 
Old 11-19-2009, 07:42 PM
David W Noon
 
Default icons missing in k3b

On Thu, 19 Nov 2009 18:00:03 +0100, Jacques Montier wrote about
[gentoo-user] [the end] icons missing in k3b:

>Hi everybody,
>
>Some news about k3b and its missing icons.
>I looked at your useflags and changed mine.
>So i had to re-build plenty of packages and spent a very long compiling
>time with my 8 year-old pc...
>Well, after that,...nothing has changed.. :-(
>http://sites.google.com/site/jacquesfr35/telechargement/k3b.jpg?attredirects=0

This looks like your XDG_DATA_DIRS environment variable might be
missing a directory or two. No amount of recompiling will cure that.
Instead, you need to look in the /etc/env.d directory, correct any
errors, then logout and login.

Here's mine:

/usr/local/share:/usr/share:/usr/kde/3.5/share:/usr/share/gdm:/usr/share

The duplication of /usr/share is, at this point in time, quite
deliberate. It works around a problem in GNOME.

>Never mind, the problem is not very important, so i stop here and will
>use xfburn if i want all my icons :-)
>As i work with Xfce4, i think i'll put all kde stuff away.

I use Brasero as a burner for GNOME and Xfce. It's actually rather
good, almost on par with K3b.
--
Regards,

Dave [RLU #314465]
================================================== ====================
dwnoon@ntlworld.com (David W Noon)
================================================== ====================
 
Old 11-20-2009, 01:51 PM
Jacques Montier
 
Default icons missing in k3b

David W Noon a gentiment tapote:
> On Thu, 19 Nov 2009 18:00:03 +0100, Jacques Montier wrote about
> [gentoo-user] [the end] icons missing in k3b:
>
>> Hi everybody,
>>
>> Some news about k3b and its missing icons.
>> I looked at your useflags and changed mine.
>> So i had to re-build plenty of packages and spent a very long compiling
>> time with my 8 year-old pc...
>> Well, after that,...nothing has changed.. :-(
>> http://sites.google.com/site/jacquesfr35/telechargement/k3b.jpg?attredirects=0
>
> This looks like your XDG_DATA_DIRS environment variable might be
> missing a directory or two. No amount of recompiling will cure that.
> Instead, you need to look in the /etc/env.d directory, correct any
> errors, then logout and login.
>
> Here's mine:
>
> /usr/local/share:/usr/share:/usr/kde/3.5/share:/usr/share/gdm:/usr/share
>
> The duplication of /usr/share is, at this point in time, quite
> deliberate. It works around a problem in GNOME.
>
>> Never mind, the problem is not very important, so i stop here and will
>> use xfburn if i want all my icons :-)
>> As i work with Xfce4, i think i'll put all kde stuff away.
>
> I use Brasero as a burner for GNOME and Xfce. It's actually rather
> good, almost on par with K3b.


Thank you David,

Mine is
/usr/local/share:/usr/share:/usr/share/gdm:/usr/share
So i tried to add XDG_DATA_DIRS="/usr/share/kde4/" in /etc/env.d/43kdepaths.
But no success, log out then in does not change anything.

--
Jacques
 
Old 11-20-2009, 09:18 PM
David W Noon
 
Default icons missing in k3b

On Fri, 20 Nov 2009 17:10:02 +0100, Jacques Montier wrote about Re:
[gentoo-user] [the end] icons missing in k3b:

>David W Noon a gentiment tapote:
[snip]
>> This looks like your XDG_DATA_DIRS environment variable might be
>> missing a directory or two. No amount of recompiling will cure that.
>> Instead, you need to look in the /etc/env.d directory, correct any
>> errors, then logout and login.
>>
>> Here's mine:
>>
>> /usr/local/share:/usr/share:/usr/kde/3.5/share:/usr/share/gdm:/usr/share
[snip]
>Mine is
>/usr/local/share:/usr/share:/usr/share/gdm:/usr/share
>So i tried to add XDG_DATA_DIRS="/usr/share/kde4/"
>in /etc/env.d/43kdepaths. But no success, log out then in does not
>change anything.

Hi Jacques,

Try /usr/share/apps/k3b instead. Also, whenever you modify any file
in /etc/env.d you need tp run env-update, so that all the login scripts
are updated for your new environment.
--
Regards,

Dave [RLU #314465]
================================================== ====================
dwnoon@ntlworld.com (David W Noon)
================================================== ====================
 
Old 11-21-2009, 10:00 AM
Jacques Montier
 
Default icons missing in k3b

David W Noon a gentiment tapote:
> On Fri, 20 Nov 2009 17:10:02 +0100, Jacques Montier wrote about Re:
> [gentoo-user] [the end] icons missing in k3b:
>
>> David W Noon a gentiment tapote:
> [snip]
>>> This looks like your XDG_DATA_DIRS environment variable might be
>>> missing a directory or two. No amount of recompiling will cure that.
>>> Instead, you need to look in the /etc/env.d directory, correct any
>>> errors, then logout and login.
>>>
>>> Here's mine:
>>>
>>> /usr/local/share:/usr/share:/usr/kde/3.5/share:/usr/share/gdm:/usr/share
> [snip]
>> Mine is
>> /usr/local/share:/usr/share:/usr/share/gdm:/usr/share
>> So i tried to add XDG_DATA_DIRS="/usr/share/kde4/"
>> in /etc/env.d/43kdepaths. But no success, log out then in does not
>> change anything.
>
> Hi Jacques,
>
> Try /usr/share/apps/k3b instead. Also, whenever you modify any file
> in /etc/env.d you need tp run env-update, so that all the login scripts
> are updated for your new environment.

Hi David,

Oups i forgot to run env-update ( the problem was between the keyboard
and the chair...) !!!
Well, now i put all kde packages away, so no problem anymore and xfburn
works fine !
I'll also try brasero.
Thank you for your help !

Best regards,

--
Jacques
http://sites.google.com/site/jacquesfr35/
 

Thread Tools




All times are GMT. The time now is 06:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org