FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-08-2009, 06:04 PM
Philip Webb
 
Default sensors on ASUS 1005HA

Everything is working on my netbook except Gkrellm,
which needs Lm-sensors, which won't compile: "No rule to make
target 'asm/bitsperlong.h', needed by prog/dump/i2cbusses.rd'.

I can search around, but does anyone have quick advice re what's missing ?
-- might it be I2C_PIIX4 in the kernel ?

BTW Dale was correct: you do have to re-run Lilo
after moving the system files back onto the root partition.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 11-08-2009, 06:45 PM
Peter Ruskin
 
Default sensors on ASUS 1005HA

On Sunday 08 November 2009 19:04:21 Philip Webb wrote:
> Everything is working on my netbook except Gkrellm,
> which needs Lm-sensors, which won't compile: "No rule to make
> target 'asm/bitsperlong.h', needed by prog/dump/i2cbusses.rd'.
>
> I can search around, but does anyone have quick advice re what's
> missing ? -- might it be I2C_PIIX4 in the kernel ?
>
lm_sensors failed to build for me too, although I just retried and
it did work. However, in the meantime I discovered sys-apps/xmbmon
and that works fine with gkrellm.

--
Peter
================================================== ======================
Gentoo Linux: Portage 2.2_rc49 kernel-2.6.31-gentoo-r4
AMD Phenom(tm) 9950 Quad-Core Processor gcc(Gentoo: 4.4.2)
KDE: 3.5.10 Qt: 3.3.8b
================================================== ======================
 
Old 11-08-2009, 07:19 PM
Philip Webb
 
Default sensors on ASUS 1005HA

091108 Peter Ruskin wrote:
> On Sunday 08 November 2009 19:04:21 Philip Webb wrote:
>> Everything is working on my netbook except Gkrellm,
>> which needs Lm-sensors, which won't compile: "No rule to make
>> target 'asm/bitsperlong.h', needed by prog/dump/i2cbusses.rd'.
>> might it be I2C_PIIX4 in the kernel ?
> lm_sensors failed to build for me too,
> although I just retried and it did work.

Was that one of those random failures which happen occasionally
or did you change something meanwhile ?

> I discovered sys-apps/xmbmon and that works fine with gkrellm.

Gkrellm depends on Lm-sensors:
does that change if Xmbmon has been emerged ?

Anyone else have suggestions ? (Thanks for this one)

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 11-08-2009, 07:35 PM
Dale
 
Default sensors on ASUS 1005HA

Philip Webb wrote:
> Everything is working on my netbook except Gkrellm,
> which needs Lm-sensors, which won't compile: "No rule to make
> target 'asm/bitsperlong.h', needed by prog/dump/i2cbusses.rd'.
>
> I can search around, but does anyone have quick advice re what's missing ?
> -- might it be I2C_PIIX4 in the kernel ?
>
> BTW Dale was correct: you do have to re-run Lilo
> after moving the system files back onto the root partition.
>
>

http://bugs.gentoo.org/show_bug.cgi?id=282261

You are not alone and they know about it too. Maybe it will be fixed
soon.

Dale

:-) :-)
 

Thread Tools




All times are GMT. The time now is 02:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org