FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-06-2009, 12:36 AM
Hung Dang
 
Default KDE-4.3.37 with USE=semantic-desktop

I got the same problem with kde-4.3.3 last night, however, I can solve
it by reemerge soprano first then emerge kde.

Hung

Crístian Viana wrote:
> Nepomuk also didn't build for me, while I was emerging kde-meta-4.3.3
> (no overlay). I'll still check if I can solve it by myself.
>
> On Thu, Nov 5, 2009 at 7:40 PM, Alan McKinnon <alan.mckinnon@gmail.com
> <mailto:alan.mckinnon@gmail.com>> wrote:
>
> Has anyone successfully built kde-4.3.73 from kde-testing overlays
> with USE=semantic-desktop? If so, how did you manage?
>
> I get about 8 build failures with the flag set, due to this
> failure in nepomuk:
>
> $ grep -i error kde-base:nepomuk-4.3.73:
> 20091105-205415.log
> /var/tmp/portage/kde-base/nepomuk-4.3.73/work/nepomuk-4.3.73/nepomuk/services/queryservice/queryservice.cpp:52:
> error: 'class Soprano::NRLModel' has no member named
> 'setEnableQueryPrefixExpansion'
> make[2]: ***
> [nepomuk/services/queryservice/CMakeFiles/nepomukqueryservice.dir/queryservice.o]
> Erro 1
> make[1]: ***
> [nepomuk/services/queryservice/CMakeFiles/nepomukqueryservice.dir/all]
> Error 2
> make: *** [all] Error 2
> * ERROR: kde-base/nepomuk-4.3.73 failed:
>
>
>
> --
> Alan McKinnon
> alan dot mckinnon at gmail dot com
>
>
>
>
> --
> Crístian Deives dos Santos Viana [aka CD1]
> Sent from Campinas, São Paulo, Brazil
 
Old 11-06-2009, 06:18 AM
Nagatoro
 
Default KDE-4.3.37 with USE=semantic-desktop

On Thursday 05 November 2009 22.40.47 Alan McKinnon wrote:
> Has anyone successfully built kde-4.3.73 from kde-testing overlays with
> USE=semantic-desktop? If so, how did you manage?
>
> I get about 8 build failures with the flag set, due to this failure in
> nepomuk:
>
> $ grep -i error kde-base:nepomuk-4.3.73:
> 20091105-205415.log
> /var/tmp/portage/kde-base/nepomuk-4.3.73/work/nepomuk-4.3.73/nepomuk/servic
> es/queryservice/queryservice.cpp:52: error: 'class Soprano::NRLModel' has
> no member named
> 'setEnableQueryPrefixExpansion'

Looks like you have the wrong version of soprano installed.

/Naga
 
Old 11-06-2009, 07:06 AM
Alan McKinnon
 
Default KDE-4.3.37 with USE=semantic-desktop

On Friday 06 November 2009 09:18:14 Nagatoro wrote:
> On Thursday 05 November 2009 22.40.47 Alan McKinnon wrote:
> > Has anyone successfully built kde-4.3.73 from kde-testing overlays with
> > USE=semantic-desktop? If so, how did you manage?
> >
> > I get about 8 build failures with the flag set, due to this failure in
> > nepomuk:
> >
> > $ grep -i error kde-base:nepomuk-4.3.73:
> > 20091105-205415.log
> > /var/tmp/portage/kde-base/nepomuk-4.3.73/work/nepomuk-4.3.73/nepomuk/serv
> >ic es/queryservice/queryservice.cpp:52: error: 'class Soprano::NRLModel'
> > has no member named
> > 'setEnableQueryPrefixExpansion'
>
> Looks like you have the wrong version of soprano installed.

Yes indeed. After merging soprano-9999, nepomuk-4.3.73 built fine.

Thanks for the pointer.


--
alan dot mckinnon at gmail dot com
 
Old 11-06-2009, 04:30 PM
"Dirk Heinrichs"
 
Default KDE-4.3.37 with USE=semantic-desktop

Am Donnerstag 05 November 2009 22:40:47 schrieb Alan McKinnon:

> Has anyone successfully built kde-4.3.73 from kde-testing overlays with
> USE=semantic-desktop? If so, how did you manage?
>
> I get about 8 build failures with the flag set, due to this failure in
> nepomuk:
>
> $ grep -i error kde-base:nepomuk-4.3.73:
> 20091105-205415.log
> /var/tmp/portage/kde-base/nepomuk-4.3.73/work/nepomuk-4.3.73/nepomuk/servic
> es/queryservice/queryservice.cpp:52: error: 'class Soprano::NRLModel' has
> no member named
> 'setEnableQueryPrefixExpansion'
> make[2]: ***
> [nepomuk/services/queryservice/CMakeFiles/nepomukqueryservice.dir/queryserv
> ice.o] Erro 1
> make[1]: ***
> [nepomuk/services/queryservice/CMakeFiles/nepomukqueryservice.dir/all]
> Error 2
> make: *** [all] Error 2
> * ERROR: kde-base/nepomuk-4.3.73 failed:

There's already a bug about this, I don't remember the number. Bottom line is
you need to re-emerge soprano.

HTH...

Dirk
 
Old 11-06-2009, 08:44 PM
Alan McKinnon
 
Default KDE-4.3.37 with USE=semantic-desktop

On Friday 06 November 2009 19:30:46 Dirk Heinrichs wrote:
> Am Donnerstag 05 November 2009 22:40:47 schrieb Alan McKinnon:
> > Has anyone successfully built kde-4.3.73 from kde-testing
overlays with
> > USE=semantic-desktop? If so, how did you manage?
> >
> > I get about 8 build failures with the flag set, due to this
failure in
> > nepomuk:
> >
> > $ grep -i error kde-base:nepomuk-4.3.73:
> > 20091105-205415.log
> > /var/tmp/portage/kde-
base/nepomuk-4.3.73/work/nepomuk-4.3.73/nepomuk/serv
> >ic es/queryservice/queryservice.cpp:52: error: 'class
Soprano::NRLModel'
> > has no member named
> > 'setEnableQueryPrefixExpansion'
> > make[2]: ***
> >
[nepomuk/services/queryservice/CMakeFiles/nepomukqueryservice.dir/queryse
> >rv ice.o] Erro 1
> > make[1]: ***
> >
[nepomuk/services/queryservice/CMakeFiles/nepomukqueryservice.dir/all]
> > Error 2
> > make: *** [all] Error 2
> > * ERROR: kde-base/nepomuk-4.3.73 failed:
>
> There's already a bug about this, I don't remember the number.
Bottom line
> is you need to re-emerge soprano.

That was it. A remerge was not enough though - I need to unmask and
install the -9999 version


--
alan dot mckinnon at gmail dot com
 

Thread Tools




All times are GMT. The time now is 07:08 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org