FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-05-2009, 02:36 PM
Helmut Jarausch
 
Default ati-drivers' expert sought

Hi,

I have 4 nearly identical machines (same brand and model of motherbaord)
with AMD 790GX + SB750 Chipsets containing an (onbaord) Radeon HD 3300
graphics chip.

All of these run identical systems
kernel 2.6.31-r4, xorg-server-1.6.5 and ati-drivers-9.10

On one of these machines freezes after some hours with the
following message in /var/log/messages

Nov 5 11:35:48 numa-iii kernel: [fglrx] ASIC hang happened
Nov 5 11:35:48 numa-iii kernel: Pid: 2698, comm: X Tainted: P W
2.6.31-gentoo-r4 #2
Nov 5 11:35:48 numa-iii kernel: Call Trace:
Nov 5 11:35:48 numa-iii kernel: [<ffffffffa005b00c>] ?
firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc459>] ?
_ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc40c>] ?
_ZN4Asic9WaitUntil15WaitForCompleteEv+0x6c/0xb0 [fglrx]
Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cb414>] ?
_ZN4Asic19PM4ElapsedTimeStampERK23PM4_TS_INTERRUPT _PARAMSj14_LARGE_INTEGER+0x134/0x1c0
[fglrx]

and so on.

Shall I conclude that this motherboard is broken?
Or is it bug in ati-drivers (not to recover from this).

Is there a forum or mailing list to ask such specific questions
about the ati-driver?

Many thanks for a hint,
Helmut.

--
Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany
 
Old 11-05-2009, 03:27 PM
Volker Armin Hemmann
 
Default ati-drivers' expert sought

On Donnerstag 05 November 2009, Helmut Jarausch wrote:
> Hi,
>
> I have 4 nearly identical machines (same brand and model of motherbaord)
> with AMD 790GX + SB750 Chipsets containing an (onbaord) Radeon HD 3300
> graphics chip.
>
> All of these run identical systems
> kernel 2.6.31-r4, xorg-server-1.6.5 and ati-drivers-9.10
>
> On one of these machines freezes after some hours with the
> following message in /var/log/messages
>
> Nov 5 11:35:48 numa-iii kernel: [fglrx] ASIC hang happened
> Nov 5 11:35:48 numa-iii kernel: Pid: 2698, comm: X Tainted: P W
> 2.6.31-gentoo-r4 #2
> Nov 5 11:35:48 numa-iii kernel: Call Trace:
> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa005b00c>] ?
> firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc459>] ?
> _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc40c>] ?
> _ZN4Asic9WaitUntil15WaitForCompleteEv+0x6c/0xb0 [fglrx]
> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cb414>] ?
> _ZN4Asic19PM4ElapsedTimeStampERK23PM4_TS_INTERRUPT _PARAMSj14_LARGE_INTEGER+
> 0x134/0x1c0 [fglrx]
>
> and so on.
>
> Shall I conclude that this motherboard is broken?
> Or is it bug in ati-drivers (not to recover from this).
>
> Is there a forum or mailing list to ask such specific questions
> about the ati-driver?

yes and no. phoronix forums has bridgman who is an ati guy involved with the
opensource drivers. mtippett was amd's manager of the fglrx gang but left the
job. Still a good place.

'numa-iii' did you enable numa options in your kernel? single socket amd
systems are not numa - and is your psu ok, nothing overheating?
 
Old 11-05-2009, 04:01 PM
Helmut Jarausch
 
Default ati-drivers' expert sought

On 5 Nov, Volker Armin Hemmann wrote:
> On Donnerstag 05 November 2009, Helmut Jarausch wrote:
>> Hi,
>>
>> I have 4 nearly identical machines (same brand and model of motherbaord)
>> with AMD 790GX + SB750 Chipsets containing an (onbaord) Radeon HD 3300
>> graphics chip.
>>
>> All of these run identical systems
>> kernel 2.6.31-r4, xorg-server-1.6.5 and ati-drivers-9.10
>>
>> On one of these machines freezes after some hours with the
>> following message in /var/log/messages
>>
>> Nov 5 11:35:48 numa-iii kernel: [fglrx] ASIC hang happened
>> Nov 5 11:35:48 numa-iii kernel: Pid: 2698, comm: X Tainted: P W
>> 2.6.31-gentoo-r4 #2
>> Nov 5 11:35:48 numa-iii kernel: Call Trace:
>> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa005b00c>] ?
>> firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
>> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc459>] ?
>> _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
>> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc40c>] ?
>> _ZN4Asic9WaitUntil15WaitForCompleteEv+0x6c/0xb0 [fglrx]
>> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cb414>] ?
>> _ZN4Asic19PM4ElapsedTimeStampERK23PM4_TS_INTERRUPT _PARAMSj14_LARGE_INTEGER+
>> 0x134/0x1c0 [fglrx]
>>
>> and so on.
>>
>> Shall I conclude that this motherboard is broken?
>> Or is it bug in ati-drivers (not to recover from this).
>>
>> Is there a forum or mailing list to ask such specific questions
>> about the ati-driver?
>
> yes and no. phoronix forums has bridgman who is an ati guy involved with the
> opensource drivers. mtippett was amd's manager of the fglrx gang but left the
> job. Still a good place.
>
> 'numa-iii' did you enable numa options in your kernel? single socket amd
> systems are not numa - and is your psu ok, nothing overheating?
>
No, I didn't enable 'numa'.
What, please, is 'psu' ?
I've checked the cpu/board temperature, nothing unusual.
The 'freeze' occur while only a screensaver was active.

Thanks,
Helmut.

--
Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany
 
Old 11-05-2009, 04:07 PM
Volker Armin Hemmann
 
Default ati-drivers' expert sought

On Donnerstag 05 November 2009, Helmut Jarausch wrote:
> On 5 Nov, Volker Armin Hemmann wrote:
> > On Donnerstag 05 November 2009, Helmut Jarausch wrote:
> >> Hi,
> >>
> >> I have 4 nearly identical machines (same brand and model of motherbaord)
> >> with AMD 790GX + SB750 Chipsets containing an (onbaord) Radeon HD 3300
> >> graphics chip.
> >>
> >> All of these run identical systems
> >> kernel 2.6.31-r4, xorg-server-1.6.5 and ati-drivers-9.10
> >>
> >> On one of these machines freezes after some hours with the
> >> following message in /var/log/messages
> >>
> >> Nov 5 11:35:48 numa-iii kernel: [fglrx] ASIC hang happened
> >> Nov 5 11:35:48 numa-iii kernel: Pid: 2698, comm: X Tainted: P W
> >> 2.6.31-gentoo-r4 #2
> >> Nov 5 11:35:48 numa-iii kernel: Call Trace:
> >> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa005b00c>] ?
> >> firegl_hardwareHangRecovery+0x1c/0x50 [fglrx]
> >> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc459>] ?
> >> _ZN4Asic9WaitUntil15ResetASICIfHungEv+0x9/0x10 [fglrx]
> >> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cc40c>] ?
> >> _ZN4Asic9WaitUntil15WaitForCompleteEv+0x6c/0xb0 [fglrx]
> >> Nov 5 11:35:48 numa-iii kernel: [<ffffffffa00cb414>] ?
> >> _ZN4Asic19PM4ElapsedTimeStampERK23PM4_TS_INTERRUPT _PARAMSj14_LARGE_INTEG
> >>ER+ 0x134/0x1c0 [fglrx]
> >>
> >> and so on.
> >>
> >> Shall I conclude that this motherboard is broken?
> >> Or is it bug in ati-drivers (not to recover from this).
> >>
> >> Is there a forum or mailing list to ask such specific questions
> >> about the ati-driver?
> >
> > yes and no. phoronix forums has bridgman who is an ati guy involved with
> > the opensource drivers. mtippett was amd's manager of the fglrx gang but
> > left the job. Still a good place.
> >
> > 'numa-iii' did you enable numa options in your kernel? single socket amd
> > systems are not numa - and is your psu ok, nothing overheating?
>
> No, I didn't enable 'numa'.
> What, please, is 'psu' ?

power supply unit (dat Netzteil)

> I've checked the cpu/board temperature, nothing unusual.
> The 'freeze' occur while only a screensaver was active.

screensavers can create a lot of load it is usually a good idea not to use
them. Either monitor on or off.
 
Old 11-05-2009, 08:10 PM
James Ausmus
 
Default ati-drivers' expert sought

On Thu, Nov 5, 2009 at 7:36 AM, Helmut Jarausch <jarausch@igpm.rwth-aachen.de> wrote:

Hi,



I have 4 nearly identical machines (same brand and model of motherbaord)

with AMD 790GX + SB750 Chipsets containing an (onbaord) Radeon HD 3300

graphics chip.



All of these run identical systems

kernel 2.6.31-r4, xorg-server-1.6.5 and ati-drivers-9.10



On one of these machines freezes after some hours with the

following message in /var/log/messages



Nov *5 11:35:48 numa-iii kernel: [fglrx] ASIC hang happened

I'm no ATI expert (at all - haven't used an ATI card since the 9700 days), but the above dmesg line would indicate that the GPU itself hung - maybe a BIOS/FW update (since this GPU is integrated on the MB) would be a good idea to try? It still, of course, could be a driver issue - if the driver is sending bad commands and getting the GPU into an invalid state, this could happen, but my first thought would be that it is a FW or HW issue...

HTH-
James
 

Thread Tools




All times are GMT. The time now is 08:24 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org