FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-28-2009, 12:58 AM
Paul Hartman
 
Default Bizarre Konqueror crash using flash plugin

On Tue, Oct 27, 2009 at 4:13 PM, Robin Atwood
<robin.atwood@attglobal.net> wrote:
> On Wednesday 28 October 2009, walt wrote:
>> On 10/27/2009 10:23 AM, walt wrote:
>> > On 10/27/2009 06:22 AM, Robin Atwood wrote:
>> >> I have never got the flash plugin to work with Konqueror4 on my 64 bit
>> >> system though it works fine on a 32 bit one...
>> >
>> > I just discovered something pretty strange on my 64 bit machine: the
>> > flash package includes both 32 and 64 bit versions, but the symlink for
>> > the plugin points to the 32 bit version...
>>
>> Sorry, my eyes are playing tricks today. The symlink I mentioned is
>> pointing from /usr/lib32/nsbrowser/, not /usr/lib64.
>>
>> I think you must have something on the machine that's still linked to qt3
>> and it needs to be reinstalled. I would just rename/move the qt3 library
>> and let revdep-rebuild reinstall whatever it is.
>
> I still have QT3/KDE3 installed because I still use some KDE3 applications.
> Removing it is currently not convenient. I have other problems now...
>
> Sigh.

Does flash work in other browsers? 64-bit or 32-bit?

What package does nspluginviewer belong to on your system? I think it
should be using Qt4 if it's the KDE4 version. Mine is from
kde-base/nsplugins-4.3.2 and is located in /usr/bin/nspluginviewer

Perhaps Flash is the one using Qt3... I'm not skilled at reading backtraces.

Do you have adobe-flash emerged with the "64bit" USE flag enabled?
 
Old 10-28-2009, 09:05 AM
Robin Atwood
 
Default Bizarre Konqueror crash using flash plugin

On Wednesday 28 October 2009, Paul Hartman wrote:
>
> Does flash work in other browsers? 64-bit or 32-bit?
>
> What package does nspluginviewer belong to on your system? I think it
> should be using Qt4 if it's the KDE4 version. Mine is from
> kde-base/nsplugins-4.3.2 and is located in /usr/bin/nspluginviewer
>
> Perhaps Flash is the one using Qt3... I'm not skilled at reading
> backtraces.
>
> Do you have adobe-flash emerged with the "64bit" USE flag enabled?
>

Yes, adobe-flash is emerged with "64bit -32bit multilib" and works fine with
firefox.

# equery b /usr/bin/nspluginviewer
* Searching for /usr/bin/nspluginviewer ...
kde-base/nsplugins-4.3.2 (/usr/bin/nspluginviewer)

Looking at the back-trace makes me think there is something wrong with the gtk
theme engine, but it works fine with other gtk apps.

-Robin
--
----------------------------------------------------------------------
Robin Atwood.

"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
----------------------------------------------------------------------
 
Old 10-28-2009, 12:43 PM
Robin Atwood
 
Default Bizarre Konqueror crash using flash plugin

On Wednesday 28 October 2009, Robin Atwood wrote:
> On Wednesday 28 October 2009, Paul Hartman wrote:
> > Does flash work in other browsers? 64-bit or 32-bit?
> >
> > What package does nspluginviewer belong to on your system? I think it
> > should be using Qt4 if it's the KDE4 version. Mine is from
> > kde-base/nsplugins-4.3.2 and is located in /usr/bin/nspluginviewer
> >
> > Perhaps Flash is the one using Qt3... I'm not skilled at reading
> > backtraces.
> >
> > Do you have adobe-flash emerged with the "64bit" USE flag enabled?
>
> Yes, adobe-flash is emerged with "64bit -32bit multilib" and works fine
> with firefox.
>
> # equery b /usr/bin/nspluginviewer
> * Searching for /usr/bin/nspluginviewer ...
> kde-base/nsplugins-4.3.2 (/usr/bin/nspluginviewer)
>
> Looking at the back-trace makes me think there is something wrong with the
> gtk theme engine, but it works fine with other gtk apps.

I was right, x11-themes/gtk-engines-qt 0.8 and 1.1 where installed at the same
time. This seems to be allowed because 1.1 (KDE4) is slotted. I unmerged 0.8
and everything started working.

Cheers
-Robin
--
----------------------------------------------------------------------
Robin Atwood.

"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
----------------------------------------------------------------------
 

Thread Tools




All times are GMT. The time now is 11:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org