FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-24-2009, 04:24 PM
Andrew Gaydenko
 
Default gtkmm puzzle

Hi!

Current ~amd64 tree says - see below. My steps?

-------------------------------------------------------

emerge -pvDuN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] net-firewall/iptables-1.4.3.1 [1.4.2-r2] USE="(-l7filter%)" 422 kB
[ebuild U ] x11-libs/pixman-0.14.0-r1 [0.14.0] USE="mmx sse2 (-altivec) -debug (-sse%*)" 0 kB
[ebuild R ] dev-cpp/gtkmm-2.14.3 USE="-debug -doc -examples -test (-accessibility%*)" 0 kB
[ebuild R ] media-video/mplayer-1.0_rc2_p20090322 USE="X a52 aac aalib alsa amrnb amrwb ass cddb cdio
cdparanoia dirac dts dv dvb dvd dvdnav enca encode faac faad gif iconv jack jpeg ladspa lirc live mad mmx mp2
mp3 nemesi network opengl oss png pulseaudio quicktime rar real rtc schroedinger sdl speex sse sse2 ssse3
theora tremor truetype unicode vorbis x264 xscreensaver xv xvid -3dnow -3dnowext (-altivec) -arts -bidi -
bindist -bl -cpudetection -custom-cflags -custom-cpuopts -debug -dga -directfb -doc -dxr3 -esd -fbcon -ftp -
ggi -gtk -ipv6 -joystick -libcaca -lzo -md5sum -mmxext -mng -musepack -nas -openal -pnm -pvr -radio -samba (-
svga) -teletext -tga -v4l -v4l2 -vdpau (-vidix) (-win32codecs) -xanim -xinerama -xvmc* -zoran" VIDEO_CARDS="-
mga -nvidia -s3virge -tdfx -vesa" 0 kB

Total: 4 packages (2 upgrades, 2 reinstalls), Size of downloads: 422 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-cpp/gtkmm:2.4

('ebuild', '/', 'dev-cpp/gtkmm-2.14.3', 'merge') pulled in by
dev-cpp/gtkmm:2.4 required by world
>=dev-cpp/gtkmm-2.4 required by ('installed', '/', 'dev-cpp/gconfmm-2.24.0', 'nomerge')
>=dev-cpp/gtkmm-2.10.0 required by ('installed', '/', 'media-gfx/inkscape-0.46-r5', 'nomerge')
(and 9 more)

('installed', '/', 'dev-cpp/gtkmm-2.14.3', 'nomerge') pulled in by
>=dev-cpp/gtkmm-2.12.3[accessibility] required by ('installed', '/', 'media-sound/ardour-2.7.1',
'nomerge')
(and 12 more)

Explanation:

New USE for 'dev-cpp/gtkmm:2.4' are incorrectly set. In order to solve
this, adjust USE to satisfy '>=dev-cpp/gtkmm-2.12.3[accessibility]'.
 
Old 03-24-2009, 05:25 PM
Paul Hartman
 
Default gtkmm puzzle

On Tue, Mar 24, 2009 at 12:24 PM, Andrew Gaydenko <a@gaydenko.com> wrote:
> Hi!
>
> Current ~amd64 tree says - see below. My steps?
>
> -------------------------------------------------------
>
> emerge -pvDuN world
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild U ] net-firewall/iptables-1.4.3.1 [1.4.2-r2] USE="(-l7filter%)" 422 kB
> [ebuild U ] x11-libs/pixman-0.14.0-r1 [0.14.0] USE="mmx sse2 (-altivec) -debug (-sse%*)" 0 kB
> [ebuild R ] dev-cpp/gtkmm-2.14.3 USE="-debug -doc -examples -test (-accessibility%*)" 0 kB
> [ebuild R ] media-video/mplayer-1.0_rc2_p20090322 USE="X a52 aac aalib alsa amrnb amrwb ass cddb cdio
> cdparanoia dirac dts dv dvb dvd dvdnav enca encode faac faad gif iconv jack jpeg ladspa lirc live mad mmx mp2
> mp3 nemesi network opengl oss png pulseaudio quicktime rar real rtc schroedinger sdl speex sse sse2 ssse3
> theora tremor truetype unicode vorbis x264 xscreensaver xv xvid -3dnow -3dnowext (-altivec) -arts -bidi -
> bindist -bl -cpudetection -custom-cflags -custom-cpuopts -debug -dga -directfb -doc -dxr3 -esd -fbcon -ftp -
> ggi -gtk -ipv6 -joystick -libcaca -lzo -md5sum -mmxext -mng -musepack -nas -openal -pnm -pvr -radio -samba (-
> svga) -teletext -tga -v4l -v4l2 -vdpau (-vidix) (-win32codecs) -xanim -xinerama -xvmc* -zoran" VIDEO_CARDS="-
> mga -nvidia -s3virge -tdfx -vesa" 0 kB
>
> Total: 4 packages (2 upgrades, 2 reinstalls), Size of downloads: 422 kB
>
> !!! Multiple package instances within a single package slot have been pulled
> !!! into the dependency graph, resulting in a slot conflict:
>
> dev-cpp/gtkmm:2.4
>
> ('ebuild', '/', 'dev-cpp/gtkmm-2.14.3', 'merge') pulled in by
> dev-cpp/gtkmm:2.4 required by world
> >=dev-cpp/gtkmm-2.4 required by ('installed', '/', 'dev-cpp/gconfmm-2.24.0', 'nomerge')
> >=dev-cpp/gtkmm-2.10.0 required by ('installed', '/', 'media-gfx/inkscape-0.46-r5', 'nomerge')
> (and 9 more)
>
> ('installed', '/', 'dev-cpp/gtkmm-2.14.3', 'nomerge') pulled in by
> >=dev-cpp/gtkmm-2.12.3[accessibility] required by ('installed', '/', 'media-sound/ardour-2.7.1',
> 'nomerge')
> (and 12 more)
>
> Explanation:
>
> New USE for 'dev-cpp/gtkmm:2.4' are incorrectly set. In order to solve
> this, adjust USE to satisfy '>=dev-cpp/gtkmm-2.12.3[accessibility]'.
>
>
>

ardour requires gtkmm with accessiblity use flag, but this flag no
longer exists on gtkmm. I think you should file a bug about ardour so
they can fix it.
 

Thread Tools




All times are GMT. The time now is 04:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org