FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-21-2009, 12:47 PM
Daniel Pielmeier
 
Default depclean wants to remove qt-4.4.2

Marc Blumentritt schrieb am 21.03.2009 14:33:
> Hi,
>
> when I run emerge -p --depclen, I get these results:
>
> [...]
>>>> These are the packages that would be unmerged:
>
> x11-libs/qt
> selected: 4.4.2
> protected: none
> omitted: 3.3.8b-r1
>
> x11-libs/qt-assistant
> selected: 4.4.2-r1
> protected: none
> omitted: none
>
> x11-libs/qt-xmlpatterns
> selected: 4.4.2
> protected: none
> omitted: none
> [...]
>
> Can someone explain me this?
>

Yeah these packages are not needed by others anymore. If you really
want/need them which i doubt you can put x11-libs/qt into the world file.

Starting with qt-4.4 the ebuild has been split up into components.
x11-libs/qt is just a meta ebuild nothing needs to depend on.
Dependencies are set upon the components. So if you really want all qt
stuff even if you do not need parts of it put x11-libs/qt in your world
file.

Regards,

Daniel
 
Old 03-22-2009, 10:29 AM
Marc Blumentritt
 
Default depclean wants to remove qt-4.4.2

Daniel Pielmeier schrieb:

Marc Blumentritt schrieb am 21.03.2009 14:33:

Hi,

when I run emerge -p --depclen, I get these results:

[...]

These are the packages that would be unmerged:

x11-libs/qt
selected: 4.4.2
protected: none
omitted: 3.3.8b-r1

x11-libs/qt-assistant
selected: 4.4.2-r1
protected: none
omitted: none

x11-libs/qt-xmlpatterns
selected: 4.4.2
protected: none
omitted: none
[...]

Can someone explain me this?



Yeah these packages are not needed by others anymore. If you really
want/need them which i doubt you can put x11-libs/qt into the world file.

Starting with qt-4.4 the ebuild has been split up into components.
x11-libs/qt is just a meta ebuild nothing needs to depend on.
Dependencies are set upon the components. So if you really want all qt
stuff even if you do not need parts of it put x11-libs/qt in your world
file.


OK, thanks for making this clear for me.

Marc
 

Thread Tools




All times are GMT. The time now is 01:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org