FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-19-2009, 11:10 AM
rdkrsr
 
Default Sound doesn't work on Asus-P5B-Deluxe

Hello,

I don't know if I'm right here, but I try.

I try now for a few days to get sound working. At boot I see a message
that alsa is loaded and I can hear a slight sound (as if I switch on
my speakers) at that moment. I also hear that sound if I change volume
in beep column of alsamixer. But no sound appears with command line
players or in kde (system sounds).

I did emerge -uvDNa system and world, configured kernel by hand,
edited modprobe (but I didn't really know what to do).

Maybe someone can help
Red

http://en.gentoo-wiki.com/wiki/Asus_P5B_Deluxe
spock ~ # uname -a
Linux spock 2.6.27-gentoo-r8 #5 SMP Wed Mar 18 20:39:24 CET 2009 i686 Intel(R)
Core(TM)2 CPU 6400 @ 2.13GHz GenuineIntel GNU/Linux

spock ~ # lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller (rev 02)

spock linux-2.6.27-gentoo-r8 # cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xffaf8000 irq 22

spock ~ # cat /etc/modprobe.d/alsa
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
## ALSA portion
alias snd-card-0 snd-hda-intel
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
## OSS/Free portion
alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##


# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
## OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

# from https://help.ubuntu.com/community/HdaIntelSoundHowto
# options snd-hda-intel model=basic
options snd-hda-intel model=6stack-dig
#
# in /usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt
# AD1988/AD1988B/AD1989A/AD1989B
# 6stack 6-jack
# 6stack-dig ditto with SPDIF
# 3stack 3-jack
# 3stack-dig ditto with SPDIF
# laptop 3-jack with hp-jack automute
# laptop-dig ditto with SPDIF
# auto auto-config reading BIOS (default)
#
spock ~ #
 
Old 03-19-2009, 02:05 PM
Paul Hartman
 
Default Sound doesn't work on Asus-P5B-Deluxe

On Thu, Mar 19, 2009 at 7:10 AM, rdkrsr <rdkrsr@googlemail.com> wrote:
> Hello,
>
> I don't know if I'm right here, but I try.
>
> I try now for a few days to get sound working. At boot I see a message
> that alsa is loaded and I can hear a slight sound (as if I switch on
> my speakers) at that moment. I also hear that sound if I change volume
> in beep column of alsamixer. But no sound appears with command line
> players or in kde (system sounds).
>
> I did emerge -uvDNa system and world, configured kernel by hand,
> edited modprobe (but I didn't really know what to do).
>
> Maybe someone can help
> Red
>
> http://en.gentoo-wiki.com/wiki/Asus_P5B_Deluxe
> spock ~ # uname -a
> Linux spock 2.6.27-gentoo-r8 #5 SMP Wed Mar 18 20:39:24 CET 2009 i686 Intel(R)
> Core(TM)2 CPU 6400 @ 2.13GHz GenuineIntel GNU/Linux
>
> spock ~ # lspci -v | grep -i audio
> 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
> Controller (rev 02)
>
> spock linux-2.6.27-gentoo-r8 # cat /proc/asound/cards
> 0 [Intel ]: HDA-Intel - HDA Intel
> HDA Intel at 0xffaf8000 irq 22
>
> spock ~ # cat /etc/modprobe.d/alsa
> # Alsa kernel modules' configuration file.
>
> # ALSA portion
> alias char-major-116 snd
> # OSS/Free portion
> alias char-major-14 soundcore
>
> ##
> ## IMPORTANT:
> ## You need to customise this section for your specific sound card(s)
> ## and then run `update-modules' command.
> ## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
> ##
> ## ALSA portion
> alias snd-card-0 snd-hda-intel
> ## alias snd-card-0 snd-interwave
> ## alias snd-card-1 snd-ens1371
> ## OSS/Free portion
> alias sound-slot-0 snd-card-0
> ## alias sound-slot-1 snd-card-1
> ##
>
>
> # OSS/Free portion - card #1
> alias sound-service-0-0 snd-mixer-oss
> alias sound-service-0-1 snd-seq-oss
> alias sound-service-0-3 snd-pcm-oss
> alias sound-service-0-8 snd-seq-oss
> alias sound-service-0-12 snd-pcm-oss
> ## OSS/Free portion - card #2
> ## alias sound-service-1-0 snd-mixer-oss
> ## alias sound-service-1-3 snd-pcm-oss
> ## alias sound-service-1-12 snd-pcm-oss
>
> alias /dev/mixer snd-mixer-oss
> alias /dev/dsp snd-pcm-oss
> alias /dev/midi snd-seq-oss
>
> # Set this to the correct number of cards.
> options snd cards_limit=1
>
> # from https://help.ubuntu.com/community/HdaIntelSoundHowto
> # options snd-hda-intel model=basic
> options snd-hda-intel model=6stack-dig
> #
> # in /usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt
> # AD1988/AD1988B/AD1989A/AD1989B
> # 6stack 6-jack
> # 6stack-dig ditto with SPDIF
> # 3stack 3-jack
> # 3stack-dig ditto with SPDIF
> # laptop 3-jack with hp-jack automute
> # laptop-dig ditto with SPDIF
> # auto auto-config reading BIOS (default)
> #
> spock ~ #
>

Did you check alsamixer to make sure it's not muted or 0 volume?
 
Old 03-19-2009, 02:28 PM
Neil Bothwick
 
Default Sound doesn't work on Asus-P5B-Deluxe

On Thu, 19 Mar 2009 13:10:35 +0100, rdkrsr wrote:

> I try now for a few days to get sound working. At boot I see a message
> that alsa is loaded and I can hear a slight sound (as if I switch on
> my speakers) at that moment. I also hear that sound if I change volume
> in beep column of alsamixer. But no sound appears with command line
> players or in kde (system sounds).

I have a P5B with working sound and these are my sound settings

% zgrep SND_HDA /proc/config.gz
CONFIG_SND_HDA_INTEL=m
# CONFIG_SND_HDA_HWDEP is not set
# CONFIG_SND_HDA_INPUT_BEEP is not set
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_ATIHDMI=y
CONFIG_SND_HDA_CODEC_NVHDMI=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
# CONFIG_SND_HDA_POWER_SAVE is not set


% cat /etc/conf.d/alsasound
# ENABLE_OSS_EMUL:
# Do you want to enable in-kernel oss emulation?
# no - Do not load oss emul drivers
# yes - Load oss emul drivers if they're found

ENABLE_OSS_EMUL="yes"

# RESTORE_ON_START:
# Do you want to restore your mixer settings? If not, your cards will be
# muted.
# no - Do not restore state
# yes - Restore state

RESTORE_ON_START="yes"

# SAVE_ON_STOP:
# Do you want to save changes made to your mixer volumes when alsasound
# stops?
# no - Do not save state
# yes - Save state

SAVE_ON_STOP="yes"

# LOAD_ON_START:
# Do you want to load sound modules when alsasound starts?
# Note: The Gentoo ALSA developers encourage you to build your sound
# drivers into the kernel unless the device is hotpluggable or
# you need to supply specific options (such as model= to HD-Audio).
# no - Do not load modules
# yes - Load modules
LOAD_ON_START="yes"

# Deprecated options:
# Upstream feels, and we wholehartedly agree, that this was a silly idea
UNLOAD_ON_STOP="no"
KILLPROC_ON_STOP="no"


% grep -v '^#' /etc/modprobe.d/alsa

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


--
Neil Bothwick

When you are out of whack, the best thing to do is to order more whack.
 
Old 03-23-2009, 01:15 PM
rdkrsr
 
Default Sound doesn't work on Asus-P5B-Deluxe

2009/3/19 Neil Bothwick <neil@digimed.co.uk>:
> On Thu, 19 Mar 2009 13:10:35 +0100, rdkrsr wrote:
>
> I have a P5B with working sound and these are my sound settings

Thanks for your configs. I checked again, but I must admit that I
probably had a mistake in the mixer settings. But I'm quite sure, that
I didn't find the PCM Volume Control, only the IEC958 P where PCM is
writte above but it's not a volume control. After installing gamix I
saw the PCM volume control, and after checking with another linux
installation (SuSE) I was confident that it worked in principle.

But after changing kernel configs or why? I have now strange messages
at startup, but as long as it works I don't car for the moment:

RTNETLINK answers: File exists
RTNETLINK answers: No such process

* Loading ALSA modules ...
* Loading: snd-card-0 ... [
* ok ] * Loading: snd-card-0 ...
* [ ok ] * Restoring Mixer Levels ...
alsactl: set_control:1273: failed to obtain info for control #12 (No such
file or directory)
alsactl: set_control:1273: failed to obtain info for control #21 (No such
file or directory)
alsactl: set_control:1273: failed to obtain info for control #22 (No such
file or directory)
alsactl: set_control:1273: failed to obtain info for control #38 (No such
file or directory)
alsactl: set_control:1273: failed to obtain info for control #44 (No such
file or directory)
alsactl: set_control:1273: failed to obtain info for control #45 (No such
file or directory)
[ ok ] * Loading key mappings ...
[ ok ]


Bye,
Red
 

Thread Tools




All times are GMT. The time now is 09:32 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org