FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-17-2009, 09:23 PM
Harry Putnam
 
Default Gentoo nfs server:Opensolaris client; error `security mode does not match'

I'm having a problem mounting a nfs share exported by my gentoo
server. The client problem occurs on an opensolaris box running
2008-11 build 109.

I have an ancient /etc/exports that may be way out of date... I
rarely use nfs. But I've begun setting up a NAS that consists of an
OpenSolaris server with ZFS file sytem.

I hoped to use NFS to handle backs ups and other work between linux
boxes and solaris NAS, with windows boxes using CIFS.

It doesn't really make sense to mount the other way round, like
serving from OpenSol and client at gentoo host since a general backup
plan will be running from the Solaris box and effecting all lan
machines.

At least that was my first thought. But really would like to
understand what is needed in either direction.

Here is the line from /etc/exports (on gentoo server):
/pub 192.168.0.0/22(rw,insecure,o_root_squash,subtree_check)

This is the command [and result] from Opensolaris client:

mount -F nfs -o ro reader:/pub /pub
nfs mount: security mode does not match the server exporting reader:/pub

I think it is some basic problem between the two NFS implementations
and even found a redhat bug saying as much here:
https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=467613

Those export lines (in the bug report) are vastly different than
mine.. I know next to nothing about what `should' be on those
lines.... I probably copy/pasted the one I'm using years ago from
somewhere.

So, there is some chance, probably even a good chance that its just
some dopey error of mine causing the problem.
 
Old 03-18-2009, 06:57 AM
Alan McKinnon
 
Default Gentoo nfs server:Opensolaris client; error `security mode does not match'

On Wednesday 18 March 2009 00:23:58 Harry Putnam wrote:
> I'm having a problem mounting a nfs share exported by my gentoo
> server. The client problem occurs on an opensolaris box running
> 2008-11 build 109.
>
> I have an ancient /etc/exports that may be way out of date... I
> rarely use nfs. But I've begun setting up a NAS that consists of an
> OpenSolaris server with ZFS file sytem.
>
> I hoped to use NFS to handle backs ups and other work between linux
> boxes and solaris NAS, with windows boxes using CIFS.
>
> It doesn't really make sense to mount the other way round, like
> serving from OpenSol and client at gentoo host since a general backup
> plan will be running from the Solaris box and effecting all lan
> machines.
>
> At least that was my first thought. But really would like to
> understand what is needed in either direction.
>
> Here is the line from /etc/exports (on gentoo server):
> /pub 192.168.0.0/22(rw,insecure,o_root_squash,subtree_check)

try remove insecure, and it's no_root_squash

--
alan dot mckinnon at gmail dot com
 

Thread Tools




All times are GMT. The time now is 11:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org