FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-08-2009, 01:18 AM
Grant Edwards
 
Default What version of nvidia-drivers to use with FX5200?

I can't seem to find an nvidia driver version that works with a
PCI FX5200. Versions later >= 173.15 don't support the 5200
series. I tried several 173.14.xx versions, and they all build
and the nvidia module loads, but Xorg dies with an illegal
instruction signal when it starts. (Xorg runs fine with the
"nv" driver.) I'm trying the 100.14.19 driver, but so far, I
can't get it to compile. I've tried 2.6.27 and 2.6.25 kernels,
and the nvidia module fails to compile with them. I'm trying
2.6.24 next, but it takes so long to build kernels on a 400MHz
box that the trail and error approach is pretty frustrating.

Is there a database somewhere of what nvidia driver versions
work with which kernel versions and which boards?

--
Grant
 
Old 02-08-2009, 03:22 AM
Dale
 
Default What version of nvidia-drivers to use with FX5200?

Grant Edwards wrote:
> I can't seem to find an nvidia driver version that works with a
> PCI FX5200. Versions later >= 173.15 don't support the 5200
> series. I tried several 173.14.xx versions, and they all build
> and the nvidia module loads, but Xorg dies with an illegal
> instruction signal when it starts. (Xorg runs fine with the
> "nv" driver.) I'm trying the 100.14.19 driver, but so far, I
> can't get it to compile. I've tried 2.6.27 and 2.6.25 kernels,
> and the nvidia module fails to compile with them. I'm trying
> 2.6.24 next, but it takes so long to build kernels on a 400MHz
> box that the trail and error approach is pretty frustrating.
>
> Is there a database somewhere of what nvidia driver versions
> work with which kernel versions and which boards?
>
>


I have a FX5200 here and this works well.

root@smoker / # equery list nvidia
[ Searching for package 'nvidia' in all categories among: ]
* installed packages
[I--] [ ] media-video/nvidia-settings-169.07 (0)
[I--] [ ] x11-drivers/nvidia-drivers-173.14.09 (0)
root@smoker / #

root@smoker / # cat /etc/make.conf | grep nv
VIDEO_CARDS="nvidia nv"
root@smoker / #


You may have to mask the newer ones. They do not work with mine at
least. The last info is in make.conf.

Dale

:-) :-)
 
Old 02-08-2009, 04:48 AM
Grant Edwards
 
Default What version of nvidia-drivers to use with FX5200?

On 2009-02-08, Dale <rdalek1967@gmail.com> wrote:

> I have a FX5200 here and this works well.
>
> root@smoker / # equery list nvidia
> [ Searching for package 'nvidia' in all categories among: ]
> * installed packages
> [I--] [ ] media-video/nvidia-settings-169.07 (0)
> [I--] [ ] x11-drivers/nvidia-drivers-173.14.09 (0)

> You may have to mask the newer ones. They do not work with
> mine at least.

I know. 173.15 and newer don't support FX5200 cards.

I tried several different 173.14.xx versions and none of them
work for me (I don't remmeber if .09 was one of them). I
always got an illegal instruction traps when Xorg is starting.
Other people reported that same problem to nvidia, but AFAICT,
there was never any fix.

I went back to 100.19 and a 2.6.24 kernel and it seems to work
fine. It's a bit dissappointing that my card isn't suported by
recent drivers/kernels when it's only about 1-1/2 years old.

--
Grant
 
Old 02-08-2009, 02:04 PM
Grant Edwards
 
Default What version of nvidia-drivers to use with FX5200?

On 2009-02-08, Michael P. Soulier <msoulier@digitaltorque.ca> wrote:

> 01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200]
>[...]

> msoulier@anton:~$ equery list | grep nvidia
> media-video/nvidia-settings-169.07
> x11-drivers/nvidia-drivers-173.14.15
>
> msoulier@anton:~$ uname -a
> Linux anton 2.6.25-gentoo-r8 #9 Sun Nov 23 19:14:08 EST 2008 i686 AMD
> Athlon(tm) XP 1700+ AuthenticAMD GNU/Linux
>
> This works for me. I'm masking out newer nvidia-drivers now
> and kernels, since I'm told that version of nvidia-drivers
> won't build against a newer kernel.

I never got any of the 173.14 series to work -- I alwasy got an
illegal instruction trap as Xorg was starting up. My box is a
Celeron Mendocino, and I suspect that the binary blob in
173.14.xx drivers is incompatile with older processors. So
it's not my card that's not supported by 173.14.xx, but my CPU.
There's also a chance that it's not the CPU which is
unsupported by 173.14.xx but rather the PCI bus interface, but
because the fault is illegal instruction, I'm guessing the CPU
is no longer supported by the driver.

The 100.19.xx series seems to work, but I had to go back to
2.6.24 to get it to build.


--
Grant
 

Thread Tools




All times are GMT. The time now is 03:10 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org