FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-01-2009, 02:38 PM
Daniel D Jones
 
Default KDE 4.2 and 3.5

I have KDE 3.5 and 4.1 installed and am trying to upgrade to 4.2. I'm getting
the following:

<=kde-base/kdebase-3.5.9-r4 ("<=kde-base/kdebase-3.5.9-r4" is blocking
kde-base/kdelibs-4.2.0)

Is there an issue with 3.5 and 4.2 being installed together? Is the above
block a known issue that's being worked out as 4.2 is integrated into the
stable tree? (I was unable to find a bug filed on it or any other hits on
Google.)



As a second question, can anyone point me to an informative reference on
~arch? It's impossible to search for the term on Google - the tilde gets
ignored and the number of false positives are overwhelming. Although I've
been using Gentoo for awhile, I don't really understand the difference
between something being in ~arch and something being blocked. I'd like to
make myself a little smarter.
 
Old 02-01-2009, 02:40 PM
Norberto Bensa
 
Default KDE 4.2 and 3.5

On Sun, Feb 1, 2009 at 1:38 PM, Daniel D Jones <ddjones@riddlemaster.org> wrote:
> I have KDE 3.5 and 4.1 installed and am trying to upgrade to 4.2. I'm getting
> the following:
>

You'll need kde-3.5.10 (or kdebase-startkde at least)

Look in the archives, a similar question was posted a few days ago.
 
Old 02-01-2009, 02:52 PM
Neil Bothwick
 
Default KDE 4.2 and 3.5

On Sun, 1 Feb 2009 15:38:03 +0000, Daniel D Jones wrote:

> As a second question, can anyone point me to an informative reference
> on ~arch?

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3&chap=3


--
Neil Bothwick

Law of Mechanical Repair: After your hands become coated with
grease, your nose will begin to itch.
 
Old 02-01-2009, 04:07 PM
Daniel D Jones
 
Default KDE 4.2 and 3.5

On Sunday 01 February 2009 15:40:29 Norberto Bensa wrote:
> On Sun, Feb 1, 2009 at 1:38 PM, Daniel D Jones <ddjones@riddlemaster.org>
wrote:
> > I have KDE 3.5 and 4.1 installed and am trying to upgrade to 4.2. I'm
> > getting the following:
>
> You'll need kde-3.5.10 (or kdebase-startkde at least)
>
> Look in the archives, a similar question was posted a few days ago.

Thanks for your response. I did search the archives and did not find anything
relevant. I saw and read a thread where a block was occurring:

<=kde-base/kdebase-startkde-3.5.10" is blocking kde-base/kdelibs-4.2.0

It wasn't clear to me that this was the same problem, since that block
referenced a 3.5.10 package and mine referenced a 3.5.9 package.

However, upgrading to 3.5.10 raises another issue. For 3.5, I didn't install
the meta package, I installed the KDE base package:

ROOT / # eix -e kde
[i] kde-base/kde
Available versions: (3.5) 3.5.9
{accessibility}
Installed versions: 3.5.9(3.5)(02:18:39 05/27/08)(-accessibility)
Homepage: http://www.kde.org/
Description: KDE - merge this to pull in all non-developer
kde-base/* packages


ROOT / # eix kde-meta
* kde-base/kde-meta
Available versions:
(3.5) 3.5.9 ~3.5.10
(4.1) (~)4.1.4
(4.2) (~)4.2.0
{accessibility nls}
Homepage: http://www.kde.org/
Description: KDE - merge this to pull in all non-developer, split
kde-base/* packages


3.5.10 is available under the meta package system but not under the KDE
package. Do I have to switch to the meta package to go to 3.5.10? (Without,
that is, manually unblocking lots and lots of packages.) Can I simply
install the meta package over the base package or will that create blocks or
other issues?
 
Old 02-01-2009, 04:17 PM
Norberto Bensa
 
Default KDE 4.2 and 3.5

On Sun, Feb 1, 2009 at 3:07 PM, Daniel D Jones <ddjones@riddlemaster.org> wrote:
> On Sunday 01 February 2009 15:40:29 Norberto Bensa wrote:
>> On Sun, Feb 1, 2009 at 1:38 PM, Daniel D Jones <ddjones@riddlemaster.org>
> wrote:
>> > I have KDE 3.5 and 4.1 installed and am trying to upgrade to 4.2. I'm
>> > getting the following:
>>
>> You'll need kde-3.5.10 (or kdebase-startkde at least)
>>
>> Look in the archives, a similar question was posted a few days ago.
>
> Thanks for your response. I did search the archives and did not find anything
> relevant. I saw and read a thread where a block was occurring:
>
> <=kde-base/kdebase-startkde-3.5.10" is blocking kde-base/kdelibs-4.2.0
>
> It wasn't clear to me that this was the same problem, since that block
> referenced a 3.5.10 package and mine referenced a 3.5.9 package.

since the block is:

<=kde-base/kdebase-startkde-3.5.10" is blocking kde-base/kdelibs-4.2.0

and 3.5.9 <= 3.5.10, then yes, the mail applies to you

You'll need kdebase-startkde > 3.5.10 (3.5.10-r5 is available in portage)


> However, upgrading to 3.5.10 raises another issue. For 3.5, I didn't install
> the meta package, I installed the KDE base package:

Uhm... Do you mean monolitich (base) vs. modules (meta)?


> 3.5.10 is available under the meta package system but not under the KDE
> package. Do I have to switch to the meta package to go to 3.5.10? (Without,
> that is, manually unblocking lots and lots of packages.) Can I simply
> install the meta package over the base package or will that create blocks or
> other issues?

I don't know. Perhaps another user can answer that question. I moved
to modules as soon as it was made available.

Regards,
Norberto
 
Old 02-01-2009, 04:49 PM
Neil Bothwick
 
Default KDE 4.2 and 3.5

On Sun, 1 Feb 2009 17:07:37 +0000, Daniel D Jones wrote:

> 3.5.10 is available under the meta package system but not under the KDE
> package. Do I have to switch to the meta package to go to 3.5.10?
> (Without, that is, manually unblocking lots and lots of packages.) Can
> I simply install the meta package over the base package or will that
> create blocks or other issues?

The monolithic and split ebuilds are incompatible, so you'll have to
uninstall one before you can install the other.

emerge -C kde
emerge --depclean -a
emerge -av kde-meta


--
Neil Bothwick

[---- Printed on recycled electrons ----]
 
Old 02-01-2009, 04:50 PM
Daniel D Jones
 
Default KDE 4.2 and 3.5

On Sunday 01 February 2009 17:17:59 Norberto Bensa wrote:
> On Sun, Feb 1, 2009 at 3:07 PM, Daniel D Jones <ddjones@riddlemaster.org>
wrote:
> > On Sunday 01 February 2009 15:40:29 Norberto Bensa wrote:
> >> On Sun, Feb 1, 2009 at 1:38 PM, Daniel D Jones
> >> <ddjones@riddlemaster.org>
> >
> > wrote:
> >> > I have KDE 3.5 and 4.1 installed and am trying to upgrade to 4.2. I'm
> >> > getting the following:
> >>
> >> You'll need kde-3.5.10 (or kdebase-startkde at least)
> >>
> >> Look in the archives, a similar question was posted a few days ago.
> >
> > Thanks for your response. I did search the archives and did not find
> > anything relevant. I saw and read a thread where a block was occurring:
> >
> > <=kde-base/kdebase-startkde-3.5.10" is blocking kde-base/kdelibs-4.2.0
> >
> > It wasn't clear to me that this was the same problem, since that block
> > referenced a 3.5.10 package and mine referenced a 3.5.9 package.
>
> since the block is:
>
> <=kde-base/kdebase-startkde-3.5.10" is blocking kde-base/kdelibs-4.2.0
>
> and 3.5.9 <= 3.5.10, then yes, the mail applies to you
>
> You'll need kdebase-startkde > 3.5.10 (3.5.10-r5 is available in portage)

Uh, someone's confused here. It may very well be me but I'm not following you
at all. The other post concerned startkde blocking kdelibs.

My block is kdebase 3.5 blocking kdelibs 4.2. There's no mention of startkde
bocking anything on my system. So I don't follow why you're telling me that
I need startkde 3.5.10.
 
Old 02-01-2009, 05:07 PM
Norberto Bensa
 
Default KDE 4.2 and 3.5

On Sun, Feb 1, 2009 at 3:50 PM, Daniel D Jones <ddjones@riddlemaster.org> wrote:
> Uh, someone's confused here. It may very well be me but I'm not following you
> at all. The other post concerned startkde blocking kdelibs.

Yes. I'm sorry. You're using monolithic KDE. I don't remember if
startkde was part of kdebase. Maybe that's where your problem is.


> My block is kdebase 3.5 blocking kdelibs 4.2. There's no mention of startkde
> bocking anything on my system. So I don't follow why you're telling me that
> I need startkde 3.5.10.

My bad. I'm sorry.

Neil says you'll need to remove kde and emerge kde-meta. Follow his advice.

Regards,
Norberto
 
Old 02-01-2009, 05:28 PM
Daniel D Jones
 
Default KDE 4.2 and 3.5

On Sunday 01 February 2009 17:49:03 Neil Bothwick wrote:
> On Sun, 1 Feb 2009 17:07:37 +0000, Daniel D Jones wrote:
> > 3.5.10 is available under the meta package system but not under the KDE
> > package. Do I have to switch to the meta package to go to 3.5.10?
> > (Without, that is, manually unblocking lots and lots of packages.) Can
> > I simply install the meta package over the base package or will that
> > create blocks or other issues?
>
> The monolithic and split ebuilds are incompatible, so you'll have to
> uninstall one before you can install the other.
>
> emerge -C kde
> emerge --depclean -a
> emerge -av kde-meta

That's what I was afraid of. Sigh. Thanks.
 
Old 02-01-2009, 05:41 PM
Dale
 
Default KDE 4.2 and 3.5

Daniel D Jones wrote:
> On Sunday 01 February 2009 17:49:03 Neil Bothwick wrote:
>
>> On Sun, 1 Feb 2009 17:07:37 +0000, Daniel D Jones wrote:
>>
>>> 3.5.10 is available under the meta package system but not under the KDE
>>> package. Do I have to switch to the meta package to go to 3.5.10?
>>> (Without, that is, manually unblocking lots and lots of packages.) Can
>>> I simply install the meta package over the base package or will that
>>> create blocks or other issues?
>>>
>> The monolithic and split ebuilds are incompatible, so you'll have to
>> uninstall one before you can install the other.
>>
>> emerge -C kde
>> emerge --depclean -a
>> emerge -av kde-meta
>>
>
> That's what I was afraid of. Sigh. Thanks.
>
>
>

Could he just emerge -C kde then re-emerge whatever he wanted without
having to reinstall all of KDE? Isn't packages like Konqueror just a
dependency pulled in by the original emerge kde?

Maybe I am missing something but I would hate to have to recompile all
of KDE just for that upgrade.

Dale

:-) :-)
 

Thread Tools




All times are GMT. The time now is 04:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org