FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-30-2009, 03:52 PM
Hung Dang
 
Default KDE 4.2 blocked packages

Hi all,
I am trying to emerge KDE 4.2 and receive the following message:

.....
[ebuild U ] kde-base/kmail-4.2.0-r1 [4.2.0] USE="kdeprefix kontact
semantic-desktop -debug -htmlhandbook" 0 kB
[ebuild NS ] kde-base/step-4.1.4 [4.2.0] USE="gsl kdeprefix
qalculate" 0 kB
[blocks B ] kde-base/phonon-xine ("kde-base/phonon-xine" is blocking
media-sound/phonon-4.3.0)

Total: 215 packages (1 upgrade, 8 new, 206 in new slots), Size of
downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('installed', '/', 'media-sound/phonon-4.3.0', 'nomerge') pulled in by
media-sound/phonon required by ('ebuild', '/',
'kde-base/knotify-4.1.4', 'merge')
media-sound/phonon required by ('ebuild', '/',
'kde-base/kttsd-4.1.4', 'merge')
>media-sound/phonon-4.1.0 required by ('ebuild', '/',
'kde-base/libtaskmanager-4.1.4', 'merge')
(and 9 more)

('ebuild', '/', 'kde-base/phonon-xine-4.1.4', 'merge') pulled in by
>=kde-base/phonon-xine-4.1.4:4.1 required by ('ebuild', '/',
'kde-base/kdebase-meta-4.1.4', 'merge')
kde-base/phonon-xine:4.1[xcb] required by ('ebuild', '/',
'kde-base/dragonplayer-4.1.4', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

I have remove pulled packages but there is still no luck. Any idea ?

Hung
 
Old 01-30-2009, 04:02 PM
Paul Hartman
 
Default KDE 4.2 blocked packages

On Fri, Jan 30, 2009 at 10:52 AM, Hung Dang <hungptit@gmail.com> wrote:
> Hi all,
> I am trying to emerge KDE 4.2 and receive the following message:
>
> .....
> [ebuild U ] kde-base/kmail-4.2.0-r1 [4.2.0] USE="kdeprefix kontact
> semantic-desktop -debug -htmlhandbook" 0 kB
> [ebuild NS ] kde-base/step-4.1.4 [4.2.0] USE="gsl kdeprefix
> qalculate" 0 kB
> [blocks B ] kde-base/phonon-xine ("kde-base/phonon-xine" is blocking
> media-sound/phonon-4.3.0)
>
> Total: 215 packages (1 upgrade, 8 new, 206 in new slots), Size of
> downloads: 0 kB
> Conflict: 1 block (1 unsatisfied)
>
> * Error: The above package list contains packages which cannot be
> * installed at the same time on the same system.
>
> ('installed', '/', 'media-sound/phonon-4.3.0', 'nomerge') pulled in by
> media-sound/phonon required by ('ebuild', '/',
> 'kde-base/knotify-4.1.4', 'merge')
> media-sound/phonon required by ('ebuild', '/',
> 'kde-base/kttsd-4.1.4', 'merge')
> >media-sound/phonon-4.1.0 required by ('ebuild', '/',
> 'kde-base/libtaskmanager-4.1.4', 'merge')
> (and 9 more)
>
> ('ebuild', '/', 'kde-base/phonon-xine-4.1.4', 'merge') pulled in by
> >=kde-base/phonon-xine-4.1.4:4.1 required by ('ebuild', '/',
> 'kde-base/kdebase-meta-4.1.4', 'merge')
> kde-base/phonon-xine:4.1[xcb] required by ('ebuild', '/',
> 'kde-base/dragonplayer-4.1.4', 'merge')
>
>
> For more information about Blocked Packages, please refer to the following
> section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
>
> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>
> I have remove pulled packages but there is still no luck. Any idea ?
>
> Hung
>
>

Try to unmerge KDE 4.1 first. It looks like you've still got some of
it in your system (my 4.2 doesn't use phonon-xine).
 
Old 01-30-2009, 04:27 PM
Hung Dang
 
Default KDE 4.2 blocked packages

Paul Hartman wrote:
> On Fri, Jan 30, 2009 at 10:52 AM, Hung Dang <hungptit@gmail.com> wrote:
>
>> Hi all,
>> I am trying to emerge KDE 4.2 and receive the following message:
>>
>> .....
>> [ebuild U ] kde-base/kmail-4.2.0-r1 [4.2.0] USE="kdeprefix kontact
>> semantic-desktop -debug -htmlhandbook" 0 kB
>> [ebuild NS ] kde-base/step-4.1.4 [4.2.0] USE="gsl kdeprefix
>> qalculate" 0 kB
>> [blocks B ] kde-base/phonon-xine ("kde-base/phonon-xine" is blocking
>> media-sound/phonon-4.3.0)
>>
>> Total: 215 packages (1 upgrade, 8 new, 206 in new slots), Size of
>> downloads: 0 kB
>> Conflict: 1 block (1 unsatisfied)
>>
>> * Error: The above package list contains packages which cannot be
>> * installed at the same time on the same system.
>>
>> ('installed', '/', 'media-sound/phonon-4.3.0', 'nomerge') pulled in by
>> media-sound/phonon required by ('ebuild', '/',
>> 'kde-base/knotify-4.1.4', 'merge')
>> media-sound/phonon required by ('ebuild', '/',
>> 'kde-base/kttsd-4.1.4', 'merge')
>> >media-sound/phonon-4.1.0 required by ('ebuild', '/',
>> 'kde-base/libtaskmanager-4.1.4', 'merge')
>> (and 9 more)
>>
>> ('ebuild', '/', 'kde-base/phonon-xine-4.1.4', 'merge') pulled in by
>> >=kde-base/phonon-xine-4.1.4:4.1 required by ('ebuild', '/',
>> 'kde-base/kdebase-meta-4.1.4', 'merge')
>> kde-base/phonon-xine:4.1[xcb] required by ('ebuild', '/',
>> 'kde-base/dragonplayer-4.1.4', 'merge')
>>
>>
>> For more information about Blocked Packages, please refer to the following
>> section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
>>
>> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>>
>> I have remove pulled packages but there is still no luck. Any idea ?
>>
>> Hung
>>
>>
>>
>
> Try to unmerge KDE 4.1 first. It looks like you've still got some of
> it in your system (my 4.2 doesn't use phonon-xine).
>
>
Hi Paul,
I have unmerge KDE-4.1 using command: emerge -C $(qfile -C -q -e
/usr/kde/4.1) and there is no KDE-4.1 packages.
And I still get the same problem.


Thanks
Hung
 
Old 01-30-2009, 04:35 PM
Paul Hartman
 
Default KDE 4.2 blocked packages

On Fri, Jan 30, 2009 at 11:27 AM, Hung Dang <hungptit@gmail.com> wrote:
> Paul Hartman wrote:
>> On Fri, Jan 30, 2009 at 10:52 AM, Hung Dang <hungptit@gmail.com> wrote:
>>
>>> Hi all,
>>> I am trying to emerge KDE 4.2 and receive the following message:
>>>
>>> .....
>>> [ebuild U ] kde-base/kmail-4.2.0-r1 [4.2.0] USE="kdeprefix kontact
>>> semantic-desktop -debug -htmlhandbook" 0 kB
>>> [ebuild NS ] kde-base/step-4.1.4 [4.2.0] USE="gsl kdeprefix
>>> qalculate" 0 kB
>>> [blocks B ] kde-base/phonon-xine ("kde-base/phonon-xine" is blocking
>>> media-sound/phonon-4.3.0)
>>>
>>> Total: 215 packages (1 upgrade, 8 new, 206 in new slots), Size of
>>> downloads: 0 kB
>>> Conflict: 1 block (1 unsatisfied)
>>>
>>> * Error: The above package list contains packages which cannot be
>>> * installed at the same time on the same system.
>>>
>>> ('installed', '/', 'media-sound/phonon-4.3.0', 'nomerge') pulled in by
>>> media-sound/phonon required by ('ebuild', '/',
>>> 'kde-base/knotify-4.1.4', 'merge')
>>> media-sound/phonon required by ('ebuild', '/',
>>> 'kde-base/kttsd-4.1.4', 'merge')
>>> >media-sound/phonon-4.1.0 required by ('ebuild', '/',
>>> 'kde-base/libtaskmanager-4.1.4', 'merge')
>>> (and 9 more)
>>>
>>> ('ebuild', '/', 'kde-base/phonon-xine-4.1.4', 'merge') pulled in by
>>> >=kde-base/phonon-xine-4.1.4:4.1 required by ('ebuild', '/',
>>> 'kde-base/kdebase-meta-4.1.4', 'merge')
>>> kde-base/phonon-xine:4.1[xcb] required by ('ebuild', '/',
>>> 'kde-base/dragonplayer-4.1.4', 'merge')
>>>
>>>
>>> For more information about Blocked Packages, please refer to the following
>>> section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
>>>
>>> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
>>>
>>> I have remove pulled packages but there is still no luck. Any idea ?
>>>
>>> Hung
>>>
>>>
>>>
>>
>> Try to unmerge KDE 4.1 first. It looks like you've still got some of
>> it in your system (my 4.2 doesn't use phonon-xine).
>>
>>
> Hi Paul,
> I have unmerge KDE-4.1 using command: emerge -C $(qfile -C -q -e
> /usr/kde/4.1) and there is no KDE-4.1 packages.
> And I still get the same problem.

Hello Hung,

This part looks like kdebase-meta-4.1.4 is still in your system somewhere:

('ebuild', '/', 'kde-base/phonon-xine-4.1.4', 'merge') pulled in by
>=kde-base/phonon-xine-4.1.4:4.1 required by ('ebuild', '/',
'kde-base/kdebase-meta-4.1.4', 'merge')
kde-base/phonon-xine:4.1[xcb] required by ('ebuild', '/',
'kde-base/dragonplayer-4.1.4', 'merge')

check your /var/lib/portage/world and /var/lib/portage/world_sets to
be sure there's no kde 4.1 (or kde packages without slot defined could
also be pulling old stuff)
 
Old 01-30-2009, 04:37 PM
Volker Armin Hemmann
 
Default KDE 4.2 blocked packages

On Freitag 30 Januar 2009, Hung Dang wrote:
> Hi all,
> I am trying to emerge KDE 4.2 and receive the following message:
>
> .....
> [ebuild U ] kde-base/kmail-4.2.0-r1 [4.2.0] USE="kdeprefix kontact
> semantic-desktop -debug -htmlhandbook" 0 kB
> [ebuild NS ] kde-base/step-4.1.4 [4.2.0] USE="gsl kdeprefix
> qalculate" 0 kB
> [blocks B ] kde-base/phonon-xine ("kde-base/phonon-xine" is blocking
> media-sound/phonon-4.3.0)
>

unmerge phonon-xine
 

Thread Tools




All times are GMT. The time now is 01:32 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org