FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-24-2009, 09:11 AM
Rod
 
Default ltmain.sh version 1.5.22

I'm getting the following error too much, many packages are no longer
insalling with this problem ;o(


>>> Emerging dev-libs/libmcrypt-2.5.8-r1
* libmcrypt-2.5.8.tar.gz RMD160 SHA1 SHA256 size ;-)
...
[ ok ]
* checking ebuild checksums ;-)
...
[ ok ]
* checking auxfile checksums ;-)
...
[ ok ]
* checking miscfile checksums ;-)
...
[ ok ]

>>> Unpacking source...
>>> Unpacking libmcrypt-2.5.8.tar.gz to
/var/tmp/portage/dev-libs/libmcrypt-2.5.8-r1/work
* Applying libmcrypt-2.5.8-rotate-mask.patch
...
[ ok ]

* Running elibtoolize in: libmcrypt-2.5.8
* Applying install-sh-1.5.patch ...

* Portage patch failed to apply (ltmain.sh version 1.5.22)!
* Please bug azarah or vapier to add proper patch.
*
* ERROR: dev-libs/libmcrypt-2.5.8-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 2364: Called elibtoolize
* environment, line 943: Called die
* The specific snippet of code:
* die "Portage patch failed to apply!";
* The die message:
* Portage patch failed to apply!
*
* If you need support, post the topmost build error, and the call stack
if relevant.
* A complete build log is located at
'/var/log/portage/dev-libs:libmcrypt-2.5.8-r1:20081226-103235.log'.
* The ebuild environment file is located at
'/var/tmp/portage/dev-libs/libmcrypt-2.5.8-r1/temp/environment'.

*

Searching the Gentoo Forums, I get most posts about this from
2005... this is upgrading a currently working install.
 
Old 01-25-2009, 09:45 AM
Alan McKinnon
 
Default ltmain.sh version 1.5.22

On Saturday 24 January 2009 12:11:41 Rod wrote:
> I'm getting the following error too much, many packages are no longer
> insalling with this problem ;o(

> * Running elibtoolize in: libmcrypt-2.5.8
> * Applying install-sh-1.5.patch ...
>
> * Portage patch failed to apply (ltmain.sh version 1.5.22)!
> * Please bug azarah or vapier to add proper patch.

That patch applies just fine here, both 2.5.8 and 2.5.8-r1.

In case it helps, my system is ~amd64

The emerge output is very sparse, I can't see the reason for the patch
failing. Try unpacking and patching manually to get a descriptive error
message.

Also, is your emerge --sync up to date?


--
alan dot mckinnon at gmail dot com
 
Old 01-25-2009, 07:21 PM
ABCD
 
Default ltmain.sh version 1.5.22

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rod wrote:
> * Running elibtoolize in: libmcrypt-2.5.8
> * Applying install-sh-1.5.patch ...
>
> * Portage patch failed to apply (ltmain.sh version 1.5.22)!
> * Please bug azarah or vapier to add proper patch.

Try reinstalling and/or upgrading sys-devel/libtool

- --
ABCD
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkl8yeMACgkQOypDUo0oQOpo0wCeKqToUftZ/jb5RKPtzlJHoHUM
FekAnR1/GwO1EUb5PnZZ58UAXStadPCf
=FjyW
-----END PGP SIGNATURE-----
 
Old 01-26-2009, 08:23 PM
Rod
 
Default ltmain.sh version 1.5.22

Alan McKinnon wrote:

On Saturday 24 January 2009 12:11:41 Rod wrote:


I'm getting the following error too much, many packages are no longer
insalling with this problem ;o(





* Running elibtoolize in: libmcrypt-2.5.8
* Applying install-sh-1.5.patch ...

* Portage patch failed to apply (ltmain.sh version 1.5.22)!
* Please bug azarah or vapier to add proper patch.



That patch applies just fine here, both 2.5.8 and 2.5.8-r1.

In case it helps, my system is ~amd64

The emerge output is very sparse, I can't see the reason for the patch
failing. Try unpacking and patching manually to get a descriptive error
message.


Also, is your emerge --sync up to date?
Yes my sync is up to date, I'm not sure why I can no longer use
`emerge --sync` more interested in getting the ltmain problem fixed first.


# emerge-webrsync
Fetching most recent snapshot ...
Trying to retrieve 20090125 snapshot from http://distfiles.gentoo.org ...
Fetching file portage-20090125.tar.lzma.md5sum ...
Fetching file portage-20090125.tar.lzma.gpgsig ...
Fetching file portage-20090125.tar.lzma ...


I'm running ~x64 (32bit)

Would you be able to tell me how to do this patch & build manually
please?
 

Thread Tools




All times are GMT. The time now is 04:34 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org