FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-24-2009, 07:09 PM
Grant
 
Default evince won't open PDFs

For some reason, evince won't open PDFs anymore. I've tried different
versions of evince, poppler, and shared-mime-info, but evince says:

"File type PDF document (application/pdf) is not supported"

epdfview works, but it segfaults when trying to open shipping labels
from usps.com. Does anyone have any ideas on getting evince back to
normal? I did try deleting .gnome2/evince.

- Grant
 
Old 01-24-2009, 08:26 PM
Allan Gottlieb
 
Default evince won't open PDFs

At Sat, 24 Jan 2009 12:09:32 -0800 Grant <emailgrant@gmail.com> wrote:

> For some reason, evince won't open PDFs anymore. I've tried different
> versions of evince, poppler, and shared-mime-info, but evince says:
>
> "File type PDF document (application/pdf) is not supported"
>
> epdfview works, but it segfaults when trying to open shipping labels
> from usps.com. Does anyone have any ideas on getting evince back to
> normal? I did try deleting .gnome2/evince.

Have you recently emerged evince/poppler/poppler-bindings ?

To test if perhaps the version on the gentoo servers is currently bad
I just now remerged them and did the suggested revdep-rebuild, which as
expected rebuilt nothing. Everything worked fine; in particular,
evince file.pdf
worked.

Perhaps you should remerge them in case one of yours is corrupted.

Here is the beginning of my emerge showing the use flags

allan gottlieb # emerge evince poppler poppler-bindings

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild R ] app-text/evince-2.22.2-r1 USE="dbus doc gnome gnome-keyring tiff -debug -djvu -dvi -t1lib" 1,592 kB
[ebuild R ] app-text/poppler-bindings-0.8.7 USE="cairo gtk -qt3 -qt4 -test" 1,436 kB
[ebuild R ] app-text/poppler-0.8.7 USE="jpeg zlib -cjk" 0 kB

Total: 3 packages (3 reinstalls), Size of downloads: 3,027 kB

Would you like to merge these packages? [Yes/No]

Good luck!

allan
 
Old 01-24-2009, 08:32 PM
Saphirus Sage
 
Default evince won't open PDFs

Grant wrote:
> For some reason, evince won't open PDFs anymore. I've tried different
> versions of evince, poppler, and shared-mime-info, but evince says:
>
> "File type PDF document (application/pdf) is not supported"
>
> epdfview works, but it segfaults when trying to open shipping labels
> from usps.com. Does anyone have any ideas on getting evince back to
> normal? I did try deleting .gnome2/evince.
>
> - Grant
>
>
I've always preferred xpdf just for simplicity, but be sure you have
'pdf' in your USE flags for make.conf either way. That would probably
handle the error of pdf being an unsupported file type.
 
Old 01-25-2009, 03:04 AM
Chris Thomas
 
Default evince won't open PDFs

Without looking it up, I'm pretty sure there's no pdf use flag. Make
sure Evince is listed as the default application for pdfs in your web
browser.

-Chris

On Sat, Jan 24, 2009 at 4:32 PM, Saphirus Sage <saphirus497@gmail.com> wrote:
> Grant wrote:
>> For some reason, evince won't open PDFs anymore. I've tried different
>> versions of evince, poppler, and shared-mime-info, but evince says:
>>
>> "File type PDF document (application/pdf) is not supported"
>>
>> epdfview works, but it segfaults when trying to open shipping labels
>> from usps.com. Does anyone have any ideas on getting evince back to
>> normal? I did try deleting .gnome2/evince.
>>
>> - Grant
>>
>>
> I've always preferred xpdf just for simplicity, but be sure you have
> 'pdf' in your USE flags for make.conf either way. That would probably
> handle the error of pdf being an unsupported file type.
>
>
 
Old 01-25-2009, 03:26 AM
Saphirus Sage
 
Default evince won't open PDFs

Chris Thomas wrote:
> Without looking it up, I'm pretty sure there's no pdf use flag. Make
> sure Evince is listed as the default application for pdfs in your web
> browser.
>
> -Chris
>
> On Sat, Jan 24, 2009 at 4:32 PM, Saphirus Sage <saphirus497@gmail.com> wrote:
>
>> Grant wrote:
>>
>>> For some reason, evince won't open PDFs anymore. I've tried different
>>> versions of evince, poppler, and shared-mime-info, but evince says:
>>>
>>> "File type PDF document (application/pdf) is not supported"
>>>
>>> epdfview works, but it segfaults when trying to open shipping labels
>>> from usps.com. Does anyone have any ideas on getting evince back to
>>> normal? I did try deleting .gnome2/evince.
>>>
>>> - Grant
>>>
>>>
>>>
>> I've always preferred xpdf just for simplicity, but be sure you have
>> 'pdf' in your USE flags for make.conf either way. That would probably
>> handle the error of pdf being an unsupported file type.
>>
>>
>>
>
>
Consult /usr/portage/profiles/use.desc and tell me that again.
 
Old 01-25-2009, 03:49 AM
Grant
 
Default evince won't open PDFs

>> For some reason, evince won't open PDFs anymore. I've tried different
>> versions of evince, poppler, and shared-mime-info, but evince says:
>>
>> "File type PDF document (application/pdf) is not supported"
>>
>> epdfview works, but it segfaults when trying to open shipping labels
>> from usps.com. Does anyone have any ideas on getting evince back to
>> normal? I did try deleting .gnome2/evince.
>
> Have you recently emerged evince/poppler/poppler-bindings ?
>
> To test if perhaps the version on the gentoo servers is currently bad
> I just now remerged them and did the suggested revdep-rebuild, which as
> expected rebuilt nothing. Everything worked fine; in particular,
> evince file.pdf
> worked.
>
> Perhaps you should remerge them in case one of yours is corrupted.
>
> Here is the beginning of my emerge showing the use flags
>
> allan gottlieb # emerge evince poppler poppler-bindings
>
> These are the packages that would be merged, in reverse order:
>
> Calculating dependencies... done!
> [ebuild R ] app-text/evince-2.22.2-r1 USE="dbus doc gnome gnome-keyring tiff -debug -djvu -dvi -t1lib" 1,592 kB
> [ebuild R ] app-text/poppler-bindings-0.8.7 USE="cairo gtk -qt3 -qt4 -test" 1,436 kB
> [ebuild R ] app-text/poppler-0.8.7 USE="jpeg zlib -cjk" 0 kB
>
> Total: 3 packages (3 reinstalls), Size of downloads: 3,027 kB
>
> Would you like to merge these packages? [Yes/No]

It turns out evince, xpdf, and epdfview all segfault on the PDF
shipping labels produced by usps.com. The latest stable evince does
open other PDF files, although newer evince versions give me the "not
supported" problem.

Has anyone successfully opened a usps.com shipping label?

- Grant
 
Old 01-25-2009, 05:10 AM
David
 
Default evince won't open PDFs

On Sunday 25 January 2009 05:49:31 Grant wrote:
> >> For some reason, evince won't open PDFs anymore. I've tried different
> >> versions of evince, poppler, and shared-mime-info, but evince says:
> >>
> >> "File type PDF document (application/pdf) is not supported"
> >>
> >> epdfview works, but it segfaults when trying to open shipping labels
> >> from usps.com. Does anyone have any ideas on getting evince back to
> >> normal? I did try deleting .gnome2/evince.
> >
> > Have you recently emerged evince/poppler/poppler-bindings ?
> >
> > To test if perhaps the version on the gentoo servers is currently bad
> > I just now remerged them and did the suggested revdep-rebuild, which as
> > expected rebuilt nothing. Everything worked fine; in particular,
> > evince file.pdf
> > worked.
> >
> > Perhaps you should remerge them in case one of yours is corrupted.
> >
> > Here is the beginning of my emerge showing the use flags
> >
> > allan gottlieb # emerge evince poppler poppler-bindings
> >
> > These are the packages that would be merged, in reverse order:
> >
> > Calculating dependencies... done!
> > [ebuild R ] app-text/evince-2.22.2-r1 USE="dbus doc gnome
> > gnome-keyring tiff -debug -djvu -dvi -t1lib" 1,592 kB [ebuild R ]
> > app-text/poppler-bindings-0.8.7 USE="cairo gtk -qt3 -qt4 -test" 1,436 kB
> > [ebuild R ] app-text/poppler-0.8.7 USE="jpeg zlib -cjk" 0 kB
> >
> > Total: 3 packages (3 reinstalls), Size of downloads: 3,027 kB
> >
> > Would you like to merge these packages? [Yes/No]
>
> It turns out evince, xpdf, and epdfview all segfault on the PDF
> shipping labels produced by usps.com. The latest stable evince does
> open other PDF files, although newer evince versions give me the "not
> supported" problem.
>
> Has anyone successfully opened a usps.com shipping label?
>
> - Grant

The problem is the stable version of poppler (app-text/poppler-0.8.7). I have
upgrade it to app-text/poppler-0.10.3 and it is working fine now. You will
have to run revdep-rebuild after updrading poppler.
 
Old 01-25-2009, 02:32 PM
Grant
 
Default evince won't open PDFs

>> >> For some reason, evince won't open PDFs anymore. I've tried different
>> >> versions of evince, poppler, and shared-mime-info, but evince says:
>> >>
>> >> "File type PDF document (application/pdf) is not supported"
>> >>
>> >> epdfview works, but it segfaults when trying to open shipping labels
>> >> from usps.com. Does anyone have any ideas on getting evince back to
>> >> normal? I did try deleting .gnome2/evince.
>> >
>> > Have you recently emerged evince/poppler/poppler-bindings ?
>> >
>> > To test if perhaps the version on the gentoo servers is currently bad
>> > I just now remerged them and did the suggested revdep-rebuild, which as
>> > expected rebuilt nothing. Everything worked fine; in particular,
>> > evince file.pdf
>> > worked.
>> >
>> > Perhaps you should remerge them in case one of yours is corrupted.
>> >
>> > Here is the beginning of my emerge showing the use flags
>> >
>> > allan gottlieb # emerge evince poppler poppler-bindings
>> >
>> > These are the packages that would be merged, in reverse order:
>> >
>> > Calculating dependencies... done!
>> > [ebuild R ] app-text/evince-2.22.2-r1 USE="dbus doc gnome
>> > gnome-keyring tiff -debug -djvu -dvi -t1lib" 1,592 kB [ebuild R ]
>> > app-text/poppler-bindings-0.8.7 USE="cairo gtk -qt3 -qt4 -test" 1,436 kB
>> > [ebuild R ] app-text/poppler-0.8.7 USE="jpeg zlib -cjk" 0 kB
>> >
>> > Total: 3 packages (3 reinstalls), Size of downloads: 3,027 kB
>> >
>> > Would you like to merge these packages? [Yes/No]
>>
>> It turns out evince, xpdf, and epdfview all segfault on the PDF
>> shipping labels produced by usps.com. The latest stable evince does
>> open other PDF files, although newer evince versions give me the "not
>> supported" problem.
>>
>> Has anyone successfully opened a usps.com shipping label?
>>
>> - Grant
>
> The problem is the stable version of poppler (app-text/poppler-0.8.7). I have
> upgrade it to app-text/poppler-0.10.3 and it is working fine now. You will
> have to run revdep-rebuild after updrading poppler.

Thank you very much, that fixed it. I needed to upgrade evince and
poppler-bindings along with poppler.

- Grant
 

Thread Tools




All times are GMT. The time now is 01:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org