FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-21-2009, 04:31 PM
Michael Sullivan
 
Default Slot Nightmare

I've been fighting this for two days now:

catherine ~ # emerge -uD world
Calculating dependencies... done!
[ebuild U ] app-arch/cpio-2.9-r2 [2.9-r1]
[ebuild U ] net-misc/dhcpcd-4.0.7 [4.0.2]
[ebuild U ] dev-libs/mpfr-2.3.2 [2.3.1_p1]
[ebuild N ] dev-perl/yaml-0.65
[ebuild NS ] sys-kernel/gentoo-sources-2.6.27-r8 [2.6.27-r7]
USE="-build -symlink"
[ebuild U ] sys-devel/gdb-6.8-r1 [6.7.1-r3] USE="-multitarget%"
[ebuild UD] app-text/poppler-0.6.3-r1 [0.10.3] USE="jpeg%* zlib%*
-cjk%"
[ebuild U ] sys-apps/groff-1.19.2-r3 [1.19.2-r1]
[ebuild U ] x11-terms/xterm-239 [237]
[ebuild U ] dev-java/ant-core-1.7.1-r2 [1.7.0-r1]
[ebuild U ] dev-lang/nasm-2.05.01 [2.04]
[ebuild U ] media-libs/libmpeg2-0.5.1 [0.4.1]
[ebuild U ] x11-libs/qscintilla-2.3.2 [2.1-r1]
[ebuild U ] dev-python/qscintilla-python-2.3.2 [2.1]
[ebuild U ] dev-python/PyQt-3.17.6 [3.17.4]
[ebuild N ] perl-core/Module-Build-0.28.08
[ebuild N ] virtual/perl-Module-Build-0.28.08
[ebuild N ] perl-core/ExtUtils-CBuilder-0.23
[ebuild N ] virtual/perl-ExtUtils-CBuilder-0.23
[ebuild N ] perl-core/ExtUtils-ParseXS-2.19
[ebuild N ] virtual/perl-ExtUtils-ParseXS-2.19

!!! Multiple package instances within a single package slot have been
pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

('installed', '/', 'app-text/poppler-0.10.3', 'nomerge') pulled in by
~app-text/poppler-0.10.3 required by ('installed', '/',
'app-text/poppler-bindings-0.10.3', 'nomerge')
(and 4 more)

('ebuild', '/', 'app-text/poppler-0.6.3-r1', 'merge') pulled in by
app-text/poppler required by world
>=app-text/poppler-0.6.1 required by ('installed', '/',
'kde-base/kdegraphics-3.5.9', 'nomerge')
>=app-text/poppler-0.4.3-r1 required by ('installed', '/',
'net-print/cups-1.3.9-r1', 'nomerge')
(and 1 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

I need poppler-0.10.3 to get around the qt circular dependency problem.
Lower versions of poppler and poppler-bindings are not installed:

catherine ~ # emerge -pvC poppler poppler-bindings

>>> These are the packages that would be unmerged:

app-text/poppler
selected: 0.10.3
protected: none
omitted: none

app-text/poppler-bindings
selected: 0.10.3
protected: none
omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

I've tried every trick I can think of to get around this and nothing has
worked. Please help me.
 
Old 01-21-2009, 05:10 PM
Neil Bothwick
 
Default Slot Nightmare

On Wed, 21 Jan 2009 11:31:36 -0600, Michael Sullivan wrote:

> ('ebuild', '/', 'app-text/poppler-0.6.3-r1', 'merge') pulled in by
> app-text/poppler required by world

Why have you got poppler in world?


--
Neil Bothwick

Windows NT is the OS of the future and always will be...
 

Thread Tools




All times are GMT. The time now is 12:48 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org