FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-21-2009, 03:02 AM
Norberto Bensa
 
Default resolving blocks from sets

Hello list,

well. I couldn't resist and I emerged kde4.2 with something like this:

sudo emerge @kdebase

Now I want to upgrade Qt to 4.5beta but (see below)

Is there any obvious way to solve this that can't see because it's 2AM
and need some sleep or are @sets _evil_ ?

And before you jump and tell me "hey, just remove the packages and
update Qt" see this:

$ sudo emerge -C kdm-4.1.96
Not unmerging package kde-base/kdm-4.1.96 as it is
still referenced by the following package sets:
kdebase

Do I _really_ need to do "emerge -C @kdebase!"?


sudo emerge @qt-all-4.5
Calculating dependencies... done!
[ebuild U ] x11-libs/qt-core-4.5.0_beta1 [4.4.2] USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-sql-4.5.0_beta1 [4.4.2] USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-dbus-4.5.0_beta1 [4.4.2] USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-script-4.5.0_beta1 [4.4.2] USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-test-4.5.0_beta1 [4.4.2] USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-xmlpatterns-4.5.0_beta1 [4.4.2]
USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-gui-4.5.0_beta1 [4.4.2-r1] USE="gtkstyle%*
-custom-cxxflags%"
[ebuild U ] x11-libs/qt-qt3support-4.5.0_beta1 [4.4.2]
USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-webkit-4.5.0_beta1 [4.4.2]
USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-opengl-4.5.0_beta1 [4.4.2]
USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-svg-4.5.0_beta1 [4.4.2]
USE="-custom-cxxflags%"
[ebuild U ] x11-libs/qt-assistant-4.5.0_beta1 [4.4.2-r1]
USE="-custom-cxxflags%"
[ebuild N ] x11-libs/qt-phonon-4.5.0_beta1 USE="dbus pch
-custom-cxxflags -debug"
[uninstall ] kde-base/ktimezoned-4.1.96
[uninstall ] kde-base/ark-4.1.96
[uninstall ] kde-base/solid-4.1.96
[uninstall ] kde-base/kopete-4.1.96
[uninstall ] kde-base/kscd-4.1.96
[blocks B ] media-sound/phonon ("media-sound/phonon" is blocking
x11-libs/qt-phonon-4.5.0_beta1)
[blocks B ] x11-libs/qt-phonon:4 ("x11-libs/qt-phonon:4" is
blocking media-sound/phonon-4.2.96)
[blocks B ] x11-libs/qt-phonon ("x11-libs/qt-phonon" is blocking
kde-base/kquitapp-4.1.96, kde-base/kdedglobalaccel-4.1.96,
kde-base/kdeartwork-kscreensaver-4.1.96, kde-base/plasma-apps-4.1.96,
kde-base/knetattach-4.1.96, kde-base/kdebugdialog-4.1.96,
kde-base/kmail-4.1.96, kde-base/powerdevil-4.1.96,
kde-base/solid-4.1.96, kde-base/phonon-kde-4.1.96,
kde-base/kdm-4.1.96, kde-misc/yakuake-2.9.4-r2,
kde-base/soliduiserver-4.1.96, kde-base/kode-4.1.96,
kde-base/kde-menu-4.1.96, kde-base/libkonq-4.1.96,
kde-base/kstartupconfig-4.1.96, kde-base/kdepimlibs-4.1.4,
kde-base/knetworkconf-4.1.96, kde-base/libkdcraw-4.1.96,
kde-base/kmix-4.1.96, kde-base/kdebase-startkde-4.1.96,
kde-base/libksieve-4.1.96, kde-base/kdeplasma-addons-4.1.96,
kde-base/dragonplayer-4.1.96, kde-base/kdebase-kioslaves-4.1.96,
kde-base/ktnef-4.1.4, kde-base/kwrite-4.1.96, kde-base/mimelib-4.1.96,
kde-base/kscreensaver-4.1.96, kde-base/kmimetypefinder-4.1.96,
kde-base/renamedlg-plugins-4.1.96, kde-base/kaddressbook-4.1.96,
kde-base/plasma-workspace-4.1.96, kde-base/kdepasswd-4.1.96,
kde-base/kioclient-4.1.96, kde-base/kinfocenter-4.1.96,
kde-base/libplasmaclock-4.1.96, kde-base/nepomuk-4.1.96,
kde-base/kappfinder-4.1.96, kde-base/kode-4.1.4,
kde-base/kdelibs-4.1.4, kde-base/klipper-4.1.96, kde-base/kwin-4.1.96,
kde-base/kontact-4.1.96, kde-base/kfind-4.1.96,
kde-base/ksmserver-4.1.96, media-gfx/digikam-0.10.0_beta8,
kde-base/kscd-4.1.96, kde-base/libkpgp-4.1.96,
kde-base/libtaskmanager-4.1.96, kde-base/kdebase-data-4.1.4,
kde-base/libkcddb-4.1.96, kde-base/kcminit-4.1.96,
kde-base/kontactinterfaces-4.1.96, kde-base/libkipi-4.1.96,
kde-base/nsplugins-4.1.96, kde-base/krdc-4.1.96,
kde-base/kdenetwork-filesharing-4.1.96, kde-base/libkworkspace-4.1.96,
kde-base/konqueror-4.1.96, kde-base/kopete-4.1.96,
kde-base/okular-4.1.96, kde-base/juk-4.1.96, kde-base/dolphin-4.1.96,
kde-base/kdelibs-4.1.96, kde-base/kamera-4.1.96,
kde-base/kdebase-desktoptheme-4.1.96, kde-base/kdebase-data-4.1.96,
kde-base/kdnssd-4.1.96, kde-base/keditbookmarks-4.1.96,
kde-base/kurifilter-plugins-4.1.96, kde-base/kmailcvt-4.1.96,
kde-base/kdebase-cursors-4.1.96, kde-base/kwrited-4.1.96,
kde-base/kstyles-4.1.96, kde-base/kreadconfig-4.1.96,
kde-base/kephal-4.1.96, kde-base/kate-4.1.96,
kde-base/kiconfinder-4.1.96, kde-base/kcontrol-4.1.96,
kde-base/ark-4.1.96, media-plugins/kipi-plugins-0.2.0_beta6,
kde-base/ksplash-4.1.96, kde-base/knewstuff-4.1.96,
kde-misc/kdiff3-0.9.93, kde-base/ksysguard-4.1.96,
kde-base/knotes-4.1.96, kde-base/ksnapshot-4.1.96,
kde-base/solid-hardware-4.1.96, kde-base/kcmshell-4.1.96,
kde-base/kdialog-4.1.96, kde-base/ksystraycmd-4.1.96,
kde-base/krunner-4.1.96, kde-base/kuiserver-4.1.96,
kde-base/khotkeys-4.1.96, kde-base/kde-wallpapers-4.1.96,
kde-base/kpasswdserver-4.1.96, kde-base/drkonqi-4.1.96,
kde-base/libkleo-4.1.96, kde-base/kdepimlibs-4.1.96,
kde-base/libkexiv2-4.1.96, kde-base/kgamma-4.1.96,
kde-base/kstart-4.1.96, kde-base/gwenview-4.1.96,
kde-base/kfile-4.1.96, kde-base/kcheckpass-4.1.96,
kde-base/khelpcenter-4.1.96, kde-base/kdemultimedia-kioslaves-4.1.96,
kde-base/konsole-4.1.96, kde-base/ktraderclient-4.1.96,
kde-base/knotify-4.1.96, kde-base/libkcompactdisc-4.1.96,
kde-base/pykde4-4.1.96, kde-base/kdesu-4.1.96,
kde-base/systemsettings-4.1.96, kde-base/kwalletd-4.1.96,
kde-base/kde-menu-icons-4.1.96, kde-base/ktimezoned-4.1.96,
kde-base/kmenuedit-4.1.96, kde-base/libkdepim-4.1.96)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('installed', '/', 'kde-base/okular-4.1.96', 'nomerge') pulled in by
kde-base/okular required by @world

('installed', '/', 'kde-misc/kdiff3-0.9.93', 'nomerge') pulled in by
kde-misc/kdiff3 required by @world

('ebuild', '/', 'x11-libs/qt-phonon-4.5.0_beta1', 'merge') pulled in by
=x11-libs/qt-phonon-4.5* required by @qt-all-4.5

('installed', '/', 'kde-base/kdebase-cursors-4.1.96', 'nomerge') pulled in by
kde-base/kdebase-cursors required by @world

('installed', '/', 'kde-base/dragonplayer-4.1.96', 'nomerge') pulled in by
kde-base/dragonplayer required by @world

('installed', '/', 'kde-base/kdebase-desktoptheme-4.1.96',
'nomerge') pulled in by
kde-base/kdebase-desktoptheme required by @world

('installed', '/', 'kde-base/kdeplasma-addons-4.1.96', 'nomerge') pulled in by
kde-base/kdeplasma-addons required by @world

('installed', '/', 'kde-base/dolphin-4.1.96', 'nomerge') pulled in by
kde-base/dolphin required by @world

('installed', '/', 'kde-base/phonon-kde-4.1.96', 'nomerge') pulled in by
kde-base/phonon-kde required by @world

('installed', '/', 'kde-base/gwenview-4.1.96', 'nomerge') pulled in by
kde-base/gwenview required by @world


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
 
Old 01-21-2009, 03:13 AM
Volker Armin Hemmann
 
Default resolving blocks from sets

On Mittwoch 21 Januar 2009, Norberto Bensa wrote:
> Hello list,
>
> well. I couldn't resist and I emerged kde4.2 with something like this:
>
> sudo emerge @kdebase
>
> Now I want to upgrade Qt to 4.5beta but (see below)
>
> Is there any obvious way to solve this that can't see because it's 2AM
> and need some sleep or are @sets _evil_ ?
>

no, sets are great.

> And before you jump and tell me "hey, just remove the packages and
> update Qt" see this:
>
> $ sudo emerge -C kdm-4.1.96
> Not unmerging package kde-base/kdm-4.1.96 as it is
> still referenced by the following package sets:
> kdebase
>
> Do I _really_ need to do "emerge -C @kdebase!"?
>

no.

a) why do you want to install 4.5 beta?
b) why don't you just uninstall the phonon stuff?
 
Old 01-21-2009, 03:21 AM
Norberto Bensa
 
Default resolving blocks from sets

On Wed, Jan 21, 2009 at 2:13 AM, Volker Armin Hemmann
<volkerarmin@googlemail.com> wrote:
> a) why do you want to install 4.5 beta?

To see if it solves a nasty bug in systray when composite is enabled.


> b) why don't you just uninstall the phonon stuff?

Oh. I'll try that.

Thanks.
 
Old 01-21-2009, 03:25 AM
Volker Armin Hemmann
 
Default resolving blocks from sets

On Mittwoch 21 Januar 2009, Norberto Bensa wrote:
> On Wed, Jan 21, 2009 at 2:13 AM, Volker Armin Hemmann
>
> <volkerarmin@googlemail.com> wrote:
> > a) why do you want to install 4.5 beta?
>

don't try the beta, try qt-copy

> To see if it solves a nasty bug in systray when composite is enabled.
>
> > b) why don't you just uninstall the phonon stuff?
>
> Oh. I'll try that.
>
> Thanks.
 
Old 01-21-2009, 03:29 AM
Norberto Bensa
 
Default resolving blocks from sets

On Wed, Jan 21, 2009 at 2:25 AM, Volker Armin Hemmann
<volkerarmin@googlemail.com> wrote:

> don't try the beta, try qt-copy

Ohhh... Let's try that then

Thanks.
 

Thread Tools




All times are GMT. The time now is 11:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org