FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-18-2009, 09:26 PM
"Mark Knecht"
 
Default qt blockages...

Hi,
I'm not used to seeing all the additional messages below the
blockage indication. Can someone possibly help me understand how to
read this?

Are there really application packages that cannot be installed at
the same or is only about qt and possibly the USE flags I've got?

I tried removing qjackctl (the only world package I spotted in the
list) but that didn't help.

What to try next?

Thanks,
Mark


lightning ~ # emerge -pvDuN system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] app-arch/cpio-2.9-r2 [2.9-r1] USE="nls" 0 kB
[ebuild U ] dev-db/sqlite-3.6.6.2 [3.5.9] USE="threadsafe -debug
-doc -soundex -tcl" 2,250 kB
[ebuild U ] media-libs/libpng-1.2.34 [1.2.33] 503 kB
[ebuild U ] dev-libs/mpfr-2.3.2 [2.3.1_p1] 798 kB
[ebuild U ] dev-python/sip-4.7.9 [4.7.3] USE="-debug" 461 kB
[ebuild U ] x11-libs/gtk+-2.14.7 [2.14.5] USE="X cups jpeg tiff
-debug -doc -jpeg2k -vim-syntax -xinerama" 17,067 kB
[ebuild U ] sys-apps/groff-1.19.2-r3 [1.19.2-r1] USE="X cjk" 0 kB
[ebuild U ] sys-libs/gpm-1.20.5 [1.20.1-r6] USE="(-selinux)" 1,269 kB
[ebuild U ] dev-python/PyQt-3.17.6 [3.17.4] USE="-debug -doc
-examples" 795 kB
[ebuild N ] x11-libs/qt-core-4.4.2 USE="qt3support ssl -debug
-doc -glib -pch" 102,858 kB
[ebuild N ] x11-libs/qt-dbus-4.4.2 USE="-debug -pch" 0 kB
[ebuild N ] x11-libs/qt-sql-4.4.2 USE="mysql odbc qt3support
sqlite -debug (-firebird) -pch -postgres" 0 kB
[ebuild N ] x11-libs/qt-script-4.4.2 USE="-debug -pch" 0 kB
[ebuild N ] x11-libs/qt-gui-4.4.2-r1 USE="accessibility cups dbus
qt3support tiff -debug -glib -mng -nas -nis -pch -xinerama"
INPUT_DEVICES="-wacom" 0 kB
[ebuild N ] x11-libs/qt-qt3support-4.4.2 USE="accessibility
-debug -pch" 0 kB
[ebuild N ] x11-libs/qt-svg-4.4.2 USE="-debug -pch" 0 kB
[ebuild N ] x11-libs/qt-opengl-4.4.2 USE="qt3support -debug -pch" 0 kB
[ebuild U ] dev-python/PyQt4-4.4.4-r1 [4.3.3] USE="X%* dbus%*
opengl%* qt3support%* svg%* -debug -doc -examples -webkit%" 6,819 kB
[ebuild U ] x11-libs/qscintilla-2.3.2 [2.1-r1] USE="python qt4
-debug -doc -examples" 2,097 kB
[ebuild U ] dev-python/qscintilla-python-2.3.2 [2.1] USE="qt4" 0 kB
[blocks B ] x11-libs/qt-core ("x11-libs/qt-core" is blocking
x11-libs/qt-4.3.3)
[blocks B ] <=x11-libs/qt-4.4.0_alpha:4
("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-script-4.4.2,
x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1,
x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2,
x11-libs/qt-svg-4.4.2, x11-libs/qt-core-4.4.2,
x11-libs/qt-opengl-4.4.2)

Total: 20 packages (12 upgrades, 8 new), Size of downloads: 134,911 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'x11-libs/qt-opengl-4.4.2', 'merge') pulled in by
>=x11-libs/qt-opengl-4.4.2:4 required by ('ebuild', '/',
'dev-python/PyQt4-4.4.4-r1', 'merge')

('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge') pulled in by
x11-libs/qt-gui:4 required by ('installed', '/',
'media-sound/qjackctl-0.3.3', 'nomerge')
>=x11-libs/qt-gui-4.4.2:4 required by ('ebuild', '/',
'dev-python/PyQt4-4.4.4-r1', 'merge')
x11-libs/qt-gui:4 required by ('ebuild', '/',
'x11-libs/qscintilla-2.3.2', 'merge')
(and 4 more)

('ebuild', '/', 'x11-libs/qt-svg-4.4.2', 'merge') pulled in by
>=x11-libs/qt-svg-4.4.2:4 required by ('ebuild', '/',
'dev-python/PyQt4-4.4.4-r1', 'merge')

('ebuild', '/', 'x11-libs/qt-core-4.4.2', 'merge') pulled in by
>=x11-libs/qt-core-4.4.2:4 required by ('ebuild', '/',
'dev-python/PyQt4-4.4.4-r1', 'merge')
x11-libs/qt-core:4 required by ('installed', '/',
'media-sound/qjackctl-0.3.3', 'nomerge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/',
'x11-libs/qt-sql-4.4.2', 'merge')
(and 4 more)

('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/',
'x11-libs/qt-gui-4.4.2-r1', 'merge')
>=x11-libs/qt-dbus-4.4.2:4 required by ('ebuild', '/',
'dev-python/PyQt4-4.4.4-r1', 'merge')

('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
>=x11-libs/qt-qt3support-4.4.2:4 required by ('ebuild', '/',
'dev-python/PyQt4-4.4.4-r1', 'merge')
~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/',
'x11-libs/qt-gui-4.4.2-r1', 'merge')

('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
>=x11-libs/qt-4.3:4 required by ('installed', '/',
'app-text/poppler-bindings-0.8.7', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- x11-libs/qt-4.3.3 (masked by: package.mask)
/usr/portage/profiles/arch/amd64/package.mask:
# Markus Meier <maekke@gentoo.org> (18 Jan 2009)
# mask this version for a smooth upgrade wrt bug #248038

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

lightning ~ #
 

Thread Tools




All times are GMT. The time now is 01:39 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org