FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-04-2008, 10:46 AM
Neil Bothwick
 
Default emerging gnome - blocked package

On Tue, 4 Nov 2008 11:23:11 +0100, András Csányi wrote:

> Calculating dependencies... done!
> [ebuild N ] gnome-base/gail-1.22.3 USE="-debug -doc" 659 kB
> [ebuild N ] x11-libs/gtk+-2.14.4 USE="X jpeg jpeg2k tiff
> vim-syntax -cups -debug -doc -xinerama" 0 kB
> [blocks B ] <gnome-base/gail-1000 (is blocking x11-libs/gtk+-2.14.4)
>
> Total: 2 packages (2 new, 1 block), Size of downloads: 659 kB
>
> After this I tried to install gtk+ first and gail second, but blocking
> situation is same.

You're trying to use a ~arch gtk+ with an arch gail. The block message
shows that gail versions less than 1000 block, and you are trying to
emerge 1.22.3 because gail-1000 is keyworded ~arch. Add it
to /etc/portage/package.keywords and the block will go away.

This is one of the disadvantages of running a mixed arch/~arch system.


--
Neil Bothwick

Ralph's Observation - It is a mistake to allow any mechanical object
to realize that you are in a hurry.
 
Old 11-04-2008, 11:23 AM
"Daniel Pielmeier"
 
Default emerging gnome - blocked package

2008/11/4 Neil Bothwick <neil@digimed.co.uk>:
> On Tue, 4 Nov 2008 11:23:11 +0100, András Csányi wrote:
>
>> Calculating dependencies... done!
>> [ebuild N ] gnome-base/gail-1.22.3 USE="-debug -doc" 659 kB
>> [ebuild N ] x11-libs/gtk+-2.14.4 USE="X jpeg jpeg2k tiff
>> vim-syntax -cups -debug -doc -xinerama" 0 kB
>> [blocks B ] <gnome-base/gail-1000 (is blocking x11-libs/gtk+-2.14.4)
>>
>> Total: 2 packages (2 new, 1 block), Size of downloads: 659 kB
>>
>> After this I tried to install gtk+ first and gail second, but blocking
>> situation is same.
>
> You're trying to use a ~arch gtk+ with an arch gail. The block message
> shows that gail versions less than 1000 block, and you are trying to
> emerge 1.22.3 because gail-1000 is keyworded ~arch. Add it
> to /etc/portage/package.keywords and the block will go away.
>
> This is one of the disadvantages of running a mixed arch/~arch system.

Okay from your first mail I got the intention you want to install gail.

Anyway Neil's recommendation should do the trick. gail-1000 is just a
dummy ebuild to make the transition from gtk+ with separate gail to
gtk+ with integrated gail easier.

--
Regards,
Daniel
 
Old 11-04-2008, 12:38 PM
"Jorge Peixoto de Morais Neto"
 
Default emerging gnome - blocked package

> I have a little problem with gnome.
> I wanted to install gnome, but I got this error message:
>
> [blocks B ] <gnome-base/gail-1000 (is blocking x11-libs/gtk+-2.14.4)
>
> I thought isn't a problem because I'm using Gentoo for 3 years. I
> uninstall gail and gtk+ and emerge is working fine... But after this
> the blockign situation is same.
> Okay, nothing problem I thought, I install the gail and after I can
> install gtk+ BUT - and this is a really big BUT - gail depending of
> gtk+.
>
> softwarealchemy sayusi # emerge -avt gail
>
> These are the packages that would be merged, in reverse order:
>
> Calculating dependencies... done!
> [ebuild N ] gnome-base/gail-1.22.3 USE="-debug -doc" 659 kB
> [ebuild N ] x11-libs/gtk+-2.14.4 USE="X jpeg jpeg2k tiff
> vim-syntax -cups -debug -doc -xinerama" 0 kB
> [blocks B ] <gnome-base/gail-1000 (is blocking x11-libs/gtk+-2.14.4)
>
> Total: 2 packages (2 new, 1 block), Size of downloads: 659 kB
>
> After this I tried to install gtk+ first and gail second, but blocking
> situation is same.

Maybe you don't have to install gail at all? What depends on gail? I
heard that recent versions of gtk+ integrate gail functionality. So
for each package that depends on gail, you could see if a more recent
version of that package does not have the gail dependency.

--
Software is like sex: it is better when it is free - Linus Torvalds
 
Old 11-04-2008, 12:48 PM
"András Csányi"
 
Default emerging gnome - blocked package

2008/11/4 Jorge Peixoto de Morais Neto <please.no.spam.here@gmail.com>:
>
> Maybe you don't have to install gail at all? What depends on gail? I
> heard that recent versions of gtk+ integrate gail functionality. So
> for each package that depends on gail, you could see if a more recent
> version of that package does not have the gail dependency.

Hmmm... good idea. I will try it!
On other hand. I like stable system. If I can I avoid the ~x86
packages, but sometimes I have to...

Thank you for yours suggestion.

--
- -
-- Csanyi Andras -- http://sayusi.hu -- Sayusi Ando
-- "Bízzál Istenben és tartsd szárazon a puskaport!".-- Cromwell
 

Thread Tools




All times are GMT. The time now is 04:01 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org