FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-31-2008, 12:09 PM
BRM
 
Default Updating a system....catch-22...

I have a system that I'm just bringing back online after a few months down due to hardware issues and lack of resources to get new hardware.

Some things are going okay - I got it past the e2fsprogs/e2fsprogs-lib update fiasco (after hosing it and using GRML to get it back up).
However, I'm now stuck.

emerge world -vuDN won't complete because a package can't use "java-config", complaining about python-updater needing to be run.
However, python-updater won't run because the of blocks due to software being outdated and masked.

So it's a catch-22. I need to install a new java-config and other software before I can get python-updater to run, but the emerge won't go through without running python-updater for at least one package.

Any ideas on how to resolve?

TIA,

Ben
 
Old 10-31-2008, 12:13 PM
"James Homuth"
 
Default Updating a system....catch-22...

-----Original Message-----
From: BRM [mailto:bm_witness@yahoo.com]
Sent: October 31, 2008 9:10 AM
To: Users Gentoo
Subject: [gentoo-user] Updating a system....catch-22...

I have a system that I'm just bringing back online after a few months down
due to hardware issues and lack of resources to get new hardware.

Some things are going okay - I got it past the e2fsprogs/e2fsprogs-lib
update fiasco (after hosing it and using GRML to get it back up).
However, I'm now stuck.

emerge world -vuDN won't complete because a package can't use "java-config",
complaining about python-updater needing to be run.
However, python-updater won't run because the of blocks due to software
being outdated and masked.

So it's a catch-22. I need to install a new java-config and other software
before I can get python-updater to run, but the emerge won't go through
without running python-updater for at least one package.

Any ideas on how to resolve?

TIA,

Ben


Try running python-updater for one package at a time and see what happens?
Once it gets past one or two it might not complain at you as much.
 

Thread Tools




All times are GMT. The time now is 09:44 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org