FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-25-2008, 05:51 PM
"Andrey Vul"
 
Default broken ALSA

Here's the error from using mplayer on an mp3 file:
[AO_ALSA] alsa-lib: dlmisc.c:118snd_dlsym_verify) unable to verify
version for symbol _snd_pcm_asym_open
[AO_ALSA] alsa-lib: pcm.c:2148snd_pcm_open_conf) symbol
_snd_pcm_asym_open isnot defined inside [builtin]

Similar output happens in vlc and other players.

I've recompiled alsa-lib about 5 times and the error still persists.
How do I fix this?

--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-25-2008, 09:55 PM
Willie Wong
 
Default broken ALSA

On Sat, Oct 25, 2008 at 01:51:17PM -0400, Penguin Lover Andrey Vul squawked:
> Here's the error from using mplayer on an mp3 file:
> [AO_ALSA] alsa-lib: dlmisc.c:118snd_dlsym_verify) unable to verify
> version for symbol _snd_pcm_asym_open
> [AO_ALSA] alsa-lib: pcm.c:2148snd_pcm_open_conf) symbol
> _snd_pcm_asym_open isnot defined inside [builtin]
>
> Similar output happens in vlc and other players.
>
> I've recompiled alsa-lib about 5 times and the error still persists.
> How do I fix this?
>

If you have recently updated ALSA, check to see if you have all the
alsa pcm plugins you need. I just enable all of them to save myself
some headache. It looks like you don't have the asym plugin compiled.

(Hint: look at emerge --verbose --pretend alsa-lib ; you can set
ALSA_PCM_PLUGINS in /etc/make.conf)

W
--
"I assume you've all done stationary phase integrals...right?"
~DeathMech, S. Sondhi. P-town PHY 205
Sortir en Pantoufles: up 687 days, 20:31
 
Old 10-28-2008, 05:30 AM
"M. Sitorus"
 
Default broken ALSA

i have the same problem. here is mine :
http://forums.gentoo.org/viewtopic-t-712862.html

--
Salam,

Marc
 
Old 10-28-2008, 06:05 AM
"Andrey Vul"
 
Default broken ALSA

On Tue, Oct 28, 2008 at 2:30 AM, M. Sitorus <gkjdsh@gmail.com> wrote:
> i have the same problem. here is mine :
> http://forums.gentoo.org/viewtopic-t-712862.html
>
> --
> Salam,
>
> Marc
>
>
Apparently asym needs to be the final token in ALSA_PCM_PLUGINS.
I don't know why, but doing that made alsa work again (i.e. the ebuild
recognized ALSA_PCM_PLUGINS contains "asym").


--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-30-2008, 02:05 AM
"M. Sitorus"
 
Default broken ALSA

Hi Andrey,
what do you mean by: "Apparently asym needs to be the final token in
ALSA_PCM_PLUGINS.
I don't know why, but doing that made alsa work again (i.e. the ebuild
recognized ALSA_PCM_PLUGINS contains "asym")." ?
I have try to enable asym use flag, but alsa still not working.

--
Salam,

Marc
 
Old 10-30-2008, 02:10 AM
"Andrey Vul"
 
Default broken ALSA

On Wed, Oct 29, 2008 at 11:05 PM, M. Sitorus <gkjdsh@gmail.com> wrote:
> Hi Andrey,
> what do you mean by: "Apparently asym needs to be the final token in
> ALSA_PCM_PLUGINS.
> I don't know why, but doing that made alsa work again (i.e. the ebuild
> recognized ALSA_PCM_PLUGINS contains "asym")." ?
> I have try to enable asym use flag, but alsa still not working.
I mean this (taken from make.conf):
ALSA_PCM_PLUGINS="adpcm alaw copy dmix dshare dsnoop empty extplug
file hooks ioplug
ladspa lfloat linear meter mulaw multi null plug rate
route share shm softvol asym"

"asym" is the final space-delimited token in ALSA_PCM_PLUGINS.



--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-30-2008, 02:53 AM
"M. Sitorus"
 
Default broken ALSA

asym should be the last flag? i don't know emerge read USE Flag by order.

by the way, i usually only have dmix in ALSA_PCM_PLUGINS, and it's
work. Only after i read your email i put asym on it. So, right know i
have ALSA_PCM_PLUGINS="asym dmix" on make.conf.
It's okay right? I don't need to put the same flag with yours, to make
alsa work again right?


--
Salam,

Marc
 
Old 10-30-2008, 03:02 AM
"Andrey Vul"
 
Default broken ALSA

On Wed, Oct 29, 2008 at 11:53 PM, M. Sitorus <gkjdsh@gmail.com> wrote:
> asym should be the last flag? i don't know emerge read USE Flag by order.
It's not supposed to. There's a bug in the ebuild or eclass and
putting asym is the best workaround.
> by the way, i usually only have dmix in ALSA_PCM_PLUGINS, and it's
> work. Only after i read your email i put asym on it. So, right know i
> have ALSA_PCM_PLUGINS="asym dmix" on make.conf.
> It's okay right? I don't need to put the same flag with yours, to make
> alsa work again right?
>



--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-30-2008, 03:04 AM
"Andrey Vul"
 
Default broken ALSA

On Wed, Oct 29, 2008 at 11:53 PM, M. Sitorus <gkjdsh@gmail.com> wrote:
> asym should be the last flag? i don't know emerge read USE Flag by order.
>
> by the way, i usually only have dmix in ALSA_PCM_PLUGINS, and it's
> work. Only after i read your email i put asym on it. So, right know i
> have ALSA_PCM_PLUGINS="asym dmix" on make.conf.
> It's okay right? I don't need to put the same flag with yours, to make
> alsa work again right?
>
You're not missing asym, you're missing empty.
Easy way to check for missing ALSA_PCM_PLUGIN token:
errors of the form _snd_pcm_$foo_open
where $foo is the missing pcm plugin.



--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-30-2008, 04:26 AM
"M. Sitorus"
 
Default broken ALSA

pardon me?
here is my error:

-------------------------------------------------------------------------------------------------
slumpia@sitorus ~ $ mpg123 Padi-Sobat.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
version 0.65; written and copyright by Michael Hipp and others
free software (LGPL/GPL) without any warranty but with best wishes
ALSA lib dlmisc.c:118snd_dlsym_verify) unable to verify version for
symbol _snd_pcm_empty_open
ALSA lib pcm.c:2148snd_pcm_open_conf) symbol _snd_pcm_empty_open is
not defined inside [builtin]
audio_open(): cannot open device default
audio: Success

Playing MPEG stream 1 of 1: Padi-Sobat.mp3 ...
Title: Artist:
Comment: Album:
Year: 0 Genre: Unknown
MPEG 1.0 layer III, 160 kbits/s, 44100 Hz stereo
[audio.c:264] error: No supported rate found!
-----------------------------------------------------------------------------------------------------------
snd_pcm_open_conf <--- i miss conf USE Flag?



--
Salam,

Marc
 

Thread Tools




All times are GMT. The time now is 01:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org